C5 X7 trailer connection status missing

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

itdoesnotmatter
Posts: 4
Joined: 23 Feb 2020, 02:48

C5 X7 trailer connection status missing

Post by itdoesnotmatter »

I have a 2015 C5 X7 with DW10FD engine. I have recently fitted a tow bar in it and everything seems to work properly except parking assistance system. Connecting the trailer does not deactivate the rear sensors so every reversing is quite annoying. I know I can deactivate the system manually, but that's not how it is supposed to work.

The tow bar was installed by Citroen authorised service station with dedicated harness. The car had trailer relay unit (TRU) and its harness most likely built in before.
Connecting trailer socket does not change trailer presence status in TRU or BSI, its still missing. I suppose that's the main reason why parking assistance system does not deactivate rear sensors.
I checked the wiring between TRU and trailer socket, it seems OK and it aligns with what I have been able to find about the trailer wiring in C5. The switch in the socket works properly and closes the circuit upon connecting trailer. All lights in trailer work properly as well.

One of the differences I identified compared to what I have read on the internet, including this forum, is that I have 4 wires in the 10 pin black TRU socket while I have usually seen 5. Pin number 3 is the one that is unused in my case.
IMG_20200223_124247.jpg
Another thing is that the fuse G40, which is marked as the trailer relay unit supply, is in my car not used, i.e there are no cables connected to it. It might be a reason why there are 5 wires in the 6 pin socket of the harness in the boot (I have typically seen 6 wires there). What I was also able to understand is that typically the supply from fuse G40 is in fact connected to the above mentioned pin number 3.
IMG_20200223_124300.jpg
It seems like there is no signal coming out of the pin number 4 in the 10 pin black TRU socket and pin number 1 of the 16 pin grey TRU socket. These are the two pins the trailer presence switch wires are connected to. Not sure which is "in" and which is "out".

Is it possible that the lack of signal in the trailer presence switch circuit is caused by no supply at the pin 3 in the 10 pin black TRU socket?

Did anyone have similar problem? I would appreciate any suggestions.

Also, is there any way to get a wiring diagram so I can better understand the circuits and look for the reason? I can provide VIN number, but I'd prefer PM.

Kind regards,
Lukasz

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21298
Joined: 15 Sep 2015, 19:38
x 2122

Re: C5 X7 trailer connection status missing

Post by GiveMeABreak »

The issue I can see potentially, is that there are several electrical harnesses for the BSR (trailer unit fuse box) depending on application and vehicle of course. But I would of expected Citroen tompick the correct one from your VIN.

You can pop your VIN here, it is automatically masked from public view on submission, but staff can see it.

I can then provide you with correct harness and part details for your C5 and you can check theybinstalled the correct one.

Not only is the parking assistance supposed to be disabled, but the special ESP programme is activated for towing.

itdoesnotmatter
Posts: 4
Joined: 23 Feb 2020, 02:48

Re: C5 X7 trailer connection status missing

Post by itdoesnotmatter »

Thanks Marc.
The VIN number is VF7**************[VIN obfuscated, can be read by forum staff]

Lukasz

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21298
Joined: 15 Sep 2015, 19:38
x 2122

Re: C5 X7 trailer connection status missing

Post by GiveMeABreak »

Ok, I’ll have a check now for you.....

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21298
Joined: 15 Sep 2015, 19:38
x 2122

Re: C5 X7 trailer connection status missing

Post by GiveMeABreak »

So the trailer Relay Unit (BSR EV) is part: 9688EL or may have 1610619280 on the unit.

There are 2 harnesses compatible - Part: 9428F7 which is the 13 channel towbar harness for electrical supply of a trailer for this specific vehicle.
The second one is the additional harness if you need to power a fridge: 1609732180

For the first one, I have emailed you the fitting guide for this specific harness - if the wires are not the same, then I suspect they have wired in the wrong one.....

User avatar
Paul-R
Donor 2020
Posts: 4153
Joined: 07 May 2009, 16:24
x 426

Re: C5 X7 trailer connection status missing

Post by Paul-R »

If all X7s use the same system and if your X7 is a Tourer (estate car) then it will be 9428 F7.

I fitted one to my X7 a couple of years ago but only recently got around to telling the BSI that it was fitted. To be honest I didn't do very much towing during that time so the lack of complete functionality did not worry me.

See this thread viewtopic.php?t=58457

itdoesnotmatter
Posts: 4
Joined: 23 Feb 2020, 02:48

Re: C5 X7 trailer connection status missing

Post by itdoesnotmatter »

GiveMeABreak wrote:
23 Feb 2020, 22:43
So the trailer Relay Unit (BSR EV) is part: 9688EL or may have 1610619280 on the unit.
The sticker on my TRU shows 9665778480 with some additional numbers.
GiveMeABreak wrote:
23 Feb 2020, 22:43
There are 2 harnesses compatible - Part: 9428F7 which is the 13 channel towbar harness for electrical supply of a trailer for this specific vehicle.
The second one is the additional harness if you need to power a fridge: 1609732180

For the first one, I have emailed you the fitting guide for this specific harness - if the wires are not the same, then I suspect they have wired in the wrong one.....
Thanks. The wiring and sockets look same as the 9428F7 in the instruction, except:
- I have no wire in pin/connector location number 3 in the socket "E" (third wire from the left in picture of the step 5)
- The socket of my car built-in harness the socket "F" connects to has 5 wires. It is missing the green wire on the picture for step 6. The picture is not very precise, but I have an impression that it is not used anyway. Can you confirm?
I believe I have seen this instruction before (or at least pictures from it) which actually led me to "the missing wire" theory :)

It also appears I have more wires in the 16 pin socket "C", but again, it's hard to tell from photos.
2.jpg
I have identified the BSI connecting socket and pin locations the socket F harness goes to for all but one wire. It is actually one of the trailer presence contactor circuit wires , the one that connects to pin number 4 in the socket "E".

Regards,
Lukasz

itdoesnotmatter
Posts: 4
Joined: 23 Feb 2020, 02:48

Re: C5 X7 trailer connection status missing

Post by itdoesnotmatter »

Paul-R wrote:
23 Feb 2020, 22:48
See this thread viewtopic.php?t=58457
Thanks Paul-R. This is in line with what Marc sent me.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21298
Joined: 15 Sep 2015, 19:38
x 2122

Re: C5 X7 trailer connection status missing

Post by GiveMeABreak »

Hi Lukasz - I won't have time to look at this tonight or tomorrow, as I've a 200 mile trip to take in the morning - the instructions, directly for this kit, are from Citroen - just so you know it's not from some internet blog :-D

Paul may be able to assist as he has / had one fitted - I have a saloon without towbar, otherwise I would of gone out and checked for you.

User avatar
Paul-R
Donor 2020
Posts: 4153
Joined: 07 May 2009, 16:24
x 426

Re: C5 X7 trailer connection status missing

Post by Paul-R »

I'm willing to help as much as I can but I'm down in France at the moment and the Diagbox is in the UK. You'd have to rely on my memory!