U1213 on C5 X7

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

U1213 on C5 X7

Post by yoseff »

Yesterday , after some bad connection on the battery (Already cleaned, so no more bad connection) , my work C5 Showed "Parking brake Malfunction" and it has an U1213 code now.
It had also P0215 (Main relay?) , but after clearing , that one didnt show up anymore.
Acording to Diagbox, the vehicle speed information received by ABS and ESP module has some issue?
Where should i start looking to solve the issue? Could a BSI reset help?
I've already saw the procedure for it that Marc shared , but i'm a bit stuck on what means turning on the sidelights. Is it the first position on the front lights (presence lights)? Or is it the warning lights?
If i'm not mistaken , a BSI reset can also be done with Diagbox?
Tomorrow will connect Diagbox once again , as the car did a good amount of kilometers (30 - 40) without showing the error , but after a while appeared again :(
Hopefully , it's nothing too serious.
User avatar
Sloppysod
Donor 2024
Posts: 1043
Joined: 23 May 2015, 23:35
x 238

Re: U1213 on C5 X7

Post by Sloppysod »

Turning on of sidelights, is to remove the possibility of a power spike/surge when reconnecting the battery.
Rotate light switch fully off, then on one click.(for X7)
Stu 🏴󠁧󠁢󠁷󠁬󠁳󠁿

"Some cause happiness wherever they go, others whenever they go"Oscar Wilde (1854-1900)
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38187
Joined: 15 Sep 2015, 19:38
x 5932

Re: U1213 on C5 X7

Post by GiveMeABreak »

I'll need the VIN for your X7 for specific fault code help.
Please Don't PM Me For Technical Help

Marc
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

Sloppysod wrote: 31 Dec 2023, 11:43 Turning on of sidelights, is to remove the possibility of a power spike/surge when reconnecting the battery.
Rotate light switch fully off, then on one click.(for X7)
But from what i read in this great tutorial from Marc ( https://www.frenchcarforum.co.uk/forum/ ... 51&t=61997 ) is that sidelights are to be turn on AFTER reconnecting the battery... And my question (as English is not my main language is what exactly are the Sidelights (in my literal reading , that would be lights that are in the sides of the car :-D )
Are those the presence lights (first position after the Auto)? Or the next position where main beams are on?
Sorry if it looks a somehow "stoopid" question , but i just need to understood it properly to do it right :mrgreen:
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38187
Joined: 15 Sep 2015, 19:38
x 5932

Re: U1213 on C5 X7

Post by GiveMeABreak »

First position (sidelights)
Please Don't PM Me For Technical Help

Marc
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

GiveMeABreak wrote: 31 Dec 2023, 11:52 I'll need the VIN for your X7 for specific fault code help.
Sure. Thanks, Marc: :)
VF7**************[VIN obfuscated, can be read by forum staff]
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

I'll be driving te car in a few minutes (it's my work car) , but later on , as i have a bit more time , i'll connect it to Lexia once again to see what is there.
"On the go" i have the FAP app , but that doesnt show much info that could help with that particular issue.
However, i'm able to delete some codes with it - but on a situatin like this , i prefer to do it with Diagbox.
By the way , should i use 7.xxx or 9.xxx (I have both available , but usually been using 9.xxx)
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38187
Joined: 15 Sep 2015, 19:38
x 5932

Re: U1213 on C5 X7

Post by GiveMeABreak »

The U1213 fault means there is a communication fault somewhere - and can appear on different components, so as you mentioned parking brake malfunction, I've included the code as it relates to this system
yos park.PNG
Switching on of the warning lamp and/or warning message:
"a": Electric parking brake fault warning lamp
"b": Electric parking brake warning lamp
"c": Service warning lamp

Fault Code: U1213
Description of Fault: Fault - absence of communication with the stability control (ESP) ECU: Value received incorrect. The ESP ECU sends out data that is invalid or information that is too short.
Conditions for Fault to clear:
  • Reception of 3 consecutive items of valid information
Downgrade Modes whilst Fault is active: Possibility 1
- Deactivation of automatic mode
- Ignition on : The electrically controlled parking brake releases if the button is not held
- Ignition off : The electrically controlled parking brake releases if you hold the button for less than 3 seconds
Possibility 2
- Deactivation of the hill start assistance
- Dynamic braking by the electric parking brake

Switching on of the warning lamp and/or warning message: Warning lamp
- "a" : lit
- "b" : lit
- "c" : lit
Symptoms:
  • Illumination of LED/Error message
  • Electrically-controlled parking brake does not apply correctly
  • Electrically-controlled parking brake releases unexpectedly
  • Electrically-controlled parking brake does not release correctly
  • Electrically-controlled parking brake applies itself unexpectedly
  • The hill start assist is not working
Suspect Areas:
  • Brake pedal switch
  • Electronic stability control (ESP)

Fault Code: P0215
Description of Fault: Principal relay: Incorrect operation of the relay, the engine management ECU does not have the correct power supply.
Description of the diagnostics:
Possibility 1
Engine ECU still supplied for 2 s despite a request for cutting of its supply.
Possibility 2
Loss of supply of the engine ECU for 2 s without a prior request being detected, due to an incorrect value memorised at the following wake-up.
Conditions for Fault to clear:
  • Driving with the engine hot for 5 minutes
Downgrade Modes whilst Fault is active: -
Symptoms:
  • Starting problem
Suspect Areas:
  • Electrical harness
  • Connectors
  • Principal relay
Please Don't PM Me For Technical Help

Marc
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

Thanks a lot, Marc.
Arrived from a trip and for the first 40 or so Km , no error showing up , then short trip , error appears , then another 40 km with the error , then short trip no error - that's puzzling. I didnt clear the error at any time today, but it doesnt show up always.
I'll connect Lexia to see what errors i have now.
Edit to add that car drives normal - just dont have auto brake (except when turning on engine just before the error appears once again) , no hill assist (could live with that :mrgreen: ) and no cruise control while error is on.
Oh , and that big orange SERVICE light (plus "no auto parking brake" light)
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

After 2 smaller trips yesterday , the error didn't reappeared, but i drove a bit with lexia connected and an error related to clutch pedal captor appeared ( C1396 )
I noted also that one of the wheels was with less speed than the others - maybe a bad ABS sensor?
20231231_172503.jpg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38187
Joined: 15 Sep 2015, 19:38
x 5932

Re: U1213 on C5 X7

Post by GiveMeABreak »

That may be due to a variation in the tyre pressure of that specific wheel's tyre.

Fault:
Fault Code: C1396
Description of Fault: Clutch pedal sensor signal fault: Coherence. The time of appearance of the fault code is 1s.
The measured clutch pedal position value is more than 60 % and the engine management ECU clutch switch indicates the value 0
The measured clutch pedal position value is less than 5 % and the engine management ECU clutch switch indicates the value 1
Conditions of activation of the diagnostics:
Pressing and releasing of the clutch pedal
Conditions for Fault to clear:
  • The measured clutch pedal position value and the engine management ECU clutch switch value are coherent
Downgrade Modes whilst Fault is active: Possibility 1
The regulation functions remain active
Hill start assistance function inactive
Switching of the electric parking brake to manual mode
Possibility 2
The regulation functions remain active
Hill start assistance function inactive

Switching on of the warning lamp and/or warning message:
Possibility 1
ESP/ASR indicator lamp
Electric parking brake automatic functions deactivation warning lamp
SERVICE indicator lamp
Possibility 2
ESP/ASR indicator lamp
SERVICE indicator lamp
Symptoms:
  • Lighting of the ABS and ESP warning lamps
Suspect Areas:
  • Condition of the clutch pedal sensor
  • Connectors
  • Electrical harnesses
  • Clutch pedal position sensor
Please Don't PM Me For Technical Help

Marc
User avatar
yoseff
Posts: 139
Joined: 29 Nov 2010, 01:34
x 16

Re: U1213 on C5 X7

Post by yoseff »

Thanks for all the good info, Marc.
The last 2 trips i did with the car errors didnt reappeared , so fingers crossed that it fixed all by itself. :mrgreen:
Starting to suspect also that battery may not be helping. It's one year old , but (unfortunately) not a Varta or any other premium brand, and in that year car did "quite a bit" of kilometers. Probably around 80 to 90k (need to check) Also was the same battery that was there when alternator died last year , so it went to very low charge situation...
In FAP app , i can see that many times voltage goes over 15Volts - can that be a sign that battery is low on charge and alternator sends more voltage to charge it? Economy mode is also kicking in quite quickly.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38187
Joined: 15 Sep 2015, 19:38
x 5932

Re: U1213 on C5 X7

Post by GiveMeABreak »

Try and get a decent battery, YUASA seem to be recommended by quite a few here.
Please Don't PM Me For Technical Help

Marc