C2 abs light not illuminating help and advice please

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

C2 abs light not illuminating help and advice please

Post by Stenfsa »

Hi, C2 1,4 petrol manual gearbox. ABS-problem. The warning light will not lit at all. I've just changed the abs unit but no change to better. Vehicle speed is in abs ecu and sometimes in steering ecu but not in engine ecu? Speedo showing zero. Fuses ok and there is voltage on abs connector pins 1, 14 and 20. ABS relay changed also but nothing seems to help this little black beast. I would need to find ABS/CAN wiring diagram, there is only abs no ESP in this car.
wheeler
Posts: 5267
Joined: 21 Sep 2002, 19:07
x 316

Re: C2 abs light not illuminating help and advice please

Post by wheeler »

Do you have the VIN of the vehicle to hand?
Are you using diagbox?
Are you getting communion with the ABS unit & are there any fault codes?
Are you saying that if you go into live data all 4 wheels are showing the correct speed?
Does this model have a separate road speed sensor on the gearbox?
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

VIN VF7**************[VIN obfuscated, can be read by forum staff]
No diagbox, I have Icarsoft scanner. No fault codes in ABS unit at all and yes connection to all ecus. Engine ecu and steering ecu showing no vehicle speed faults.
I receive correct speed from all 4 wheels with scanner and its correct compared to gps speed. I havent found sensor on gearbox, I would guess the speedo info is coming from abs.
I can also see vehicle speed time to time from steering ecu but its unstable and varies a lot. Normally the steering is light all the time, maybe ecu thinks speed is 0.
wheeler
Posts: 5267
Joined: 21 Sep 2002, 19:07
x 316

Re: C2 abs light not illuminating help and advice please

Post by wheeler »

OK here is the diagram. You have already done most of the checks i would have done.
I would also check the earth at pin 26 but check it under load. Might even be worth removing & cleaning earth point MC10 anyway.
Does everything else on the instrument panel work as it should apart front the ABS light not illuminating & the speedo always showing 0?
Can Icarsoft connect to the instrument panel & actuate the ABS warning lamp (just to confirm the LED actually works)?
With the ABS unit disconnected can you measure the resistances across pins 25 & 19 and then 21 & 23 & confirm both read 120 ohms?
Attachments
C2 ABS Earth.jpg
C2 ABS.jpg
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

Thanks for the diagrams.
Everything on instrument panel works fine except ABS warning light. Speedo shows 0 and odometer shows the same figure. I'n not able to test the abs warning light with this scanner. I have opened the instrument panel and made visual inspection...all well I quess.
Resistance 25&19=114,3 ohm and 21&23=123,8ohm are these close enough or should I start fighting these wires?
After replacing the ABS-unit now the abs-brakes work (just tested on gravel road). And no DTCs at all at the moment... confused.
Hell Razor5543
Donor 2021
Posts: 12007
Joined: 01 Apr 2012, 09:47
x 1510

Re: C2 abs light not illuminating help and advice please

Post by Hell Razor5543 »

Simple question. Does the ABS (on the panel) use a light bulb or an LED? Years ago (on a Xantia) the ABS light didn't work, and it turned out to be a blown lightbulb. Changing the bulb (well, all of them really, as the panel was out) showed the ABS was working properly, as the light only came on for a moment when the car was started.
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

It's led.
wheeler
Posts: 5267
Joined: 21 Sep 2002, 19:07
x 316

Re: C2 abs light not illuminating help and advice please

Post by wheeler »

Stenfsa wrote:
01 Aug 2021, 17:30
Thanks for the diagrams.
Everything on instrument panel works fine except ABS warning light. Speedo shows 0 and odometer shows the same figure. I'n not able to test the abs warning light with this scanner. I have opened the instrument panel and made visual inspection...all well I quess.
Resistance 25&19=114,3 ohm and 21&23=123,8ohm are these close enough or should I start fighting these wires?
After replacing the ABS-unit now the abs-brakes work (just tested on gravel road). And no DTCs at all at the moment... confused.
Id say the ohms reading are probably close enough.
Can you just confirm that the ABS unit was replaced to sort this exact fault or is the problem different since replacing the ABS unit?
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

The ABS-unit (pump) was replaced to sort the problem (no warning light and abs-brakes not working and no speedo the most important). After replacement ABS-brakes work and at least for me it's a sign that the unit is powered. Which ecu collects the vehicle speed information and sends it to dash board. Since ABS-unit is showing right figures and steering ecu is partly (fluctuating) and "main"ecu nothing at all I'm thinking that there must me a broken wire or something in between.
ozvtr
Posts: 113
Joined: 13 Oct 2020, 01:11
x 26

Re: C2 abs light not illuminating help and advice please

Post by ozvtr »

I don't know the year of this C2 so I don't know if the instrument cluster is CAN or VAN BUS but I don't think that will matter.

The speed info is generated by the ABS system and fed to the BSI (glove box ECU) on the CAN BUS network. If the car was built prior to 2005, there is only one CAN network, it is then passed to the instrument cluster on the "comfort VAN" network. Post 2005 it's all CAN BUS but I don't know how many separate CAN networks there are in post 2005 cars. The BSI is typically a nexus for all the buses.

As Wheeler says, some cars have a speed sensor on the back of the gearbox but I was under the opinion this was for cars WITHOUT ABS? This does not explain the ABS light not coming on.

The failure mode is a bit weird but I am unfamiliar with HOW the cluster decodes information. Or for that matter if the BSI decodes and passes on the info to the cluster.
1) engine info such as engine temperature and RPM come through the ABS ECU to the CAN BUS. Loss of the CAN bus from the ABS module to the BSI will cause loss of engine data, the engine light will illuminate and the engine probably wont run.
2) If the turn indicator lights, illumination lamps in the cluster, temperature, fuel ETC all work, then the bus from the BSI to the cluster is also working.
3) The OP has established that the ABS system is actually working by using a scanner and getting speed data.
So it's not the ABS module and it's not any of the communication lines leading to the cluster! But then is there some bizarre failure in the cluster? It's just not displaying anything to do with the ABS. Doesn't sound right.

Under any circumstance the ABS light should come on...and then go out once communication with the ABS module is established and there are no faults. If no communication is established, then the light should stay on. It's possible for the system to have communication with an ECU and not receive data, but that's highly unlikely!
I have seen examples where disreputable people have "disabled" an indicator to hide a problem. But in this case the facts don't add up.
Its possible the ABS light has been disabled in the cluster but the lack of speed information is impossible to hide! So why bother?

This is assuming that the OP has just bought the car or fixing it for a 'friend' and that it didn't 'just happen'? What's the story?

It's possible the BSI is not decoding the speed or ABS information or not passing it on to the cluster. But that's just as bizarre as a failure in the cluster! It decodes everything else but not that!? Nope, that's not right either.

Hmm hang on, if the BSI is 'told' the system does not have an ABS module it might not go looking for it and it might not accept, decode or pass on data from it!?
Given the RPO and VIN, LEXIA can build up a list of things that are suposed to be on the car, however the car will tell LEXIA if that item is enabled or disabled. It's possible the ABS is disabled or "not present" and still doing it's "thing" but the system is just ignoring it?? Just a guess. The ABS CAN'T be turned off (not without pulling fuses)! If it can work, it will work! However can the rest of the system be programmed to ignore it?
But how would it get disabled? Is the fact the old ABS module was faulty but had not been replaced have some bearing?
The OP is using a scan tool through the OBD2 port to read ABS info, not LEXIA.
Does the OP have any more info for us?
ozvtr
Posts: 113
Joined: 13 Oct 2020, 01:11
x 26

Re: C2 abs light not illuminating help and advice please

Post by ozvtr »

Yep. Looks like a configuration problem.
I went into the BSI configuration and found this:
ABS 001.jpg
The ABS light comes on when the ignition is turned on
ABS 003.jpg
When I changed the configuration to 'missing',
No ABS light.
ABS 002.jpg
I did not drive the car but I bet the speed wont register. The configuration is in the driving information!
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

Thanks for the information. I'll find Lexia to my hands somewhere and let you know how it goes.
wheeler
Posts: 5267
Joined: 21 Sep 2002, 19:07
x 316

Re: C2 abs light not illuminating help and advice please

Post by wheeler »

So has someone been messing with this before you then? Have you inherited the car with the fault?

@ozvtr this is a VAN/CAN C2
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

Yes probably previous owner tried to hide the warning light for inspection (MOT). I bought the car just some months ago in order to practice driving with my daughter. I found out that the speedometer wasn't working but never cross my mind it's driven by ABS. Just thought its mechanical connection... Well I'm waiting for lexia at the moment, interesting to see what else come to daylight if I get connected.
Stenfsa
Posts: 8
Joined: 01 Aug 2021, 08:25

Re: C2 abs light not illuminating help and advice please

Post by Stenfsa »

After hours of installation managed to finalize Diagbox/Lexia and connection to C2 was established :-D
Took a while to think how the program works but found the ABS multiplexer... and quess what. It was in status: Missing. Managed to activate it and there we go.

Warning light illuminates now when I turn key and works as planned and even the speedometer works fine.

Thank you for your big support and help!