Xantia Blower Fan Not Working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
DHallworth
Donor 2016
Posts: 2280
Joined: 20 Nov 2005, 18:05
x 78

Xantia Blower Fan Not Working

Post by DHallworth »

A friend owns a 2000 Xantia V6 Exclusive and today the internal blower fan has packed in.

Apparently it stopped working then came back on for a minute or two and then stopped again.

I had a look at it this evening briefly and there’s no power getting to the plug that goes into the fan. I checked fuses 12 and 21 as per the handbook and there’s 12v at both fuses.

I also noticed that the air conditioning switch on the dashboard is no longer illuminating either.

Does anyone have any thoughts?

Also, does anyone have a wiring diagram and key for the system on a very late Series 2 car?

Thanks,
David.
admiral51
Donor 2021
Posts: 2376
Joined: 24 May 2007, 10:11
x 300

Re: Xantia Blower Fan Not Working

Post by admiral51 »

I think it could be an ignition switch issue, i know it was a problem with the MK1 and the MK2 had the mod done in the factory i am not sure where or which fuse would be the one that is responsible but i think it would be worth a look. Not unknown for a relay to burn out so that would be worth a look also.
I know it is an old car but maybe someone has already been messing around prior to the current owner so yes a detailed wiring diagram will be important and helpful.

Colin
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Xantia Blower Fan Not Working

Post by xantia_v6 »

It would be sensible to try changing the blower relay.

I think that these may be the applicable diagrams, they are certainly S2 Xantia with the factory-fitted blower relay. The relay is located with the relays near the fuse box under the dash board (8048 in these diagrams).

Image

Image

Image
User avatar
white exec
Moderating Team
Posts: 7378
Joined: 21 Dec 2015, 13:46
x 1443

Re: Xantia Blower Fan Not Working

Post by white exec »

You got there first, Mike. Was just about to paste!

Component Codes (full list):
Component codes p1.jpg
Component codes p2.jpg
Component codes p3.jpg
Component codes p4.jpg
Component codes p5.jpg
Component codes p6.jpg
User avatar
xantia_v6
Forum Admin Team
Posts: 7905
Joined: 09 Nov 2005, 23:03
x 512

Re: Xantia Blower Fan Not Working

Post by xantia_v6 »

Chris, can you confirm that you have no later diagram? There were dashboard wiring changes very late in production.

Mike, these are the latest I have here (RP7438 onwards, = 21.3.97) . . .
click to enlarge
XanV6 2000 cabin blower p1.jpg
XanV6 2000 cabin blower p2.jpg
XanV6 2000 cabin blower p3.jpg
RichardW
Forum Treasurer
Posts: 9644
Joined: 07 Aug 2002, 17:12
x 486

Re: Xantia Blower Fan Not Working

Post by RichardW »

There was a long thread about this a while back, which if you asked me I'd have said was by you David!! The AC light was integral... I'll see if I can find it. I had similar trouble with mine, I jumped a feed off the back of the fuse board somewhere.
User avatar
white exec
Moderating Team
Posts: 7378
Joined: 21 Dec 2015, 13:46
x 1443

Re: Xantia Blower Fan Not Working

Post by white exec »

Check the motor is ok (direct wire to 12v)
Relay on the control board comes in for Full Speed only.
Bench test the module (see below).

Couple of earlier threads:
viewtopic.php?p=633501#p633501
http://www.club-xm.co.uk/forum/viewtopi ... 90#p116112
↑ That second one explains how to bench test the control module.

Beware chinese fakes, some with wrong transistors.
User avatar
DHallworth
Donor 2016
Posts: 2280
Joined: 20 Nov 2005, 18:05
x 78

Re: Xantia Blower Fan Not Working

Post by DHallworth »

Thanks very much guys!

Richard, you’re right. I have had a huge thread on this before but from memory the rear heated window packed in, the air con switch LED was very dim and the fan would run on full speed with the control wire unplugged.

Now I’ve got the wiring diagrams I’ll have a proper look at it now and see what I can trace.

Thanks all!

David.