Look up please.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Gibbo2286
(Donor 2020)
Posts: 6075
Joined: 08 Jun 2011, 18:04
x 1490

Look up please.

Post by Gibbo2286 »

My scan says "Diesel additive system, defect filler cap sensor or additive level error."

I'm assuming it's either the wiring from the filler neck or the sensor at the other end, Anyone know what's the most likely?

There are no DMF warnings popping up on the car and it's running fine.

Also there are plenty of the sensors listed but none seem to have the same part number I found in Service Citroen i.e. 1525.CV, and the harness 6534.NV, I'd like to be sure before I order.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 29049
Joined: 15 Sep 2015, 19:38
x 3614

Re: Look up please.

Post by GiveMeABreak »

Assuming this is for your car VIN ending in 202....

6534HY is the Plug Presence Detection Harness (item 25)
6534NV is the Particle Filter Harness (item 26)
Gibbo.PNG
Gibbo2286
(Donor 2020)
Posts: 6075
Joined: 08 Jun 2011, 18:04
x 1490

Re: Look up please.

Post by Gibbo2286 »

Thanks Marc, any experience of a cure for the fault, harness, sensor, connections?

I might have to put the overalls on again and get under there when I promised myself I wouldn't do any more. :(
User avatar
GiveMeABreak
Forum Admin Team
Posts: 29049
Joined: 15 Sep 2015, 19:38
x 3614

Re: Look up please.

Post by GiveMeABreak »

I'd need the full fault codes Gibbo - but most of the similar issues have been down to the plug detect harness needing replacing.
Gibbo2286
(Donor 2020)
Posts: 6075
Joined: 08 Jun 2011, 18:04
x 1490

Re: Look up please.

Post by Gibbo2286 »

Thanks Marc, maybe I'll raise the necessary enthusiasm...….soon.
Gibbo2286
(Donor 2020)
Posts: 6075
Joined: 08 Jun 2011, 18:04
x 1490

Re: Look up please.

Post by Gibbo2286 »

I just removed the harness, a bit of a pain to get out from its route, looked up the price £80 + for what's hardly more than a meter of cable a plug and the plastic packed sensor on the other end. :(

Anyone know what's actually in that sensor pack?
User avatar
GiveMeABreak
Forum Admin Team
Posts: 29049
Joined: 15 Sep 2015, 19:38
x 3614

Re: Look up please.

Post by GiveMeABreak »

Check the magnet(s) haven’t gone AWOL first Gibbo.

See picture here:

viewtopic.php?t=59601#p567667