Xsara VTS Not charging (other electrical issues too)

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

JVille
Posts: 2
Joined: 18 Jan 2019, 19:34

Xsara VTS Not charging (other electrical issues too)

Post by JVille »

Hello!

Car related is Citroen Xsara VTS -98. Problem is that there is no noticeable difference in voltage whether the car is running or only ignition on. Alternator would be the most sensible cause but I'm afraid there may be more.

Then some details. This car has some other electrical issues too. There is some leds strips installed on to the interior lighting via cigarette lighter light wire and ground on some nearby ground wire. One led strip connector had come loose and when I inserted it instrument panel lights were gone. Other problem is that blower motor is not running. Decided to sort both by running a new wire directly from the battery to Blower motor positive wire and from there on to interior light wire. Both problems sorted. Lights ok and blower motor on and fully controllable.

Then car was probably on idle for 10 minutes and after that drove for maybe 5 minutes. Then the charging light came on. I was able to drive it a half an hour trip back home from garage. Some more warning lights came on due to voltage decreasing.

There was some trial and error when thinking where will I pull a new wire. Some short duration shorts when testing new wires from battery. Would think the battery to act as a "fuse" and not damaging the alternator because car was not running during these bad trials. Have I damaged something else during this all or has my new wire damaged something. Would think that running voltage via other way should be ok.

All the fuses have been checked as good. Alternator brushes look ok to me. Do I really have to go for a new alternator or am I missing something?
User avatar
myglaren
Forum Admin Team
Posts: 25450
Joined: 02 Mar 2008, 14:30
x 4917

Re: Xsara VTS Not charging (other electrical issues too)

Post by myglaren »

Disconnect whatever you did and see if the problem with charging continues or is eliminated before going down potentially tortuous and expensive routes.

If you have inadvertently caused a short circuit while working on it there is the possibility that the diodes in the regulator have been damaged which could potentially lead to the problems you are experiencing.
wheeler
Posts: 6880
Joined: 21 Sep 2002, 19:07
x 728

Re: Xsara VTS Not charging (other electrical issues too)

Post by wheeler »

Try measuring the voltage again with the engine running but this time put the negative lead of your meter directly on the alternator casing & the positive lead right on the main positive connection of the alternator what are you getting now? This should rule out a fault with the main cabling to the alternator.
Have you actually dismantled the alternator to inspect the brushes? If not then you will have no real idea if the brushes ‘look ok’.
JVille
Posts: 2
Joined: 18 Jan 2019, 19:34

Re: Xsara VTS Not charging (other electrical issues too)

Post by JVille »

Not able to check exact voltage now but remember seeing a very low voltage that way. But did also test the voltage drops between battery and alternator on both posts. Almost zero.

This one has a Bosch alternator, was able to take the end cap and brushes out without taking the alternator out. So yes, visually inspected.
Brushes
Brushes
I did disconnect all that I have done and no difference. After browsing other forums too, I found out info that if alternator stops working also the blower motor stops working. There hasn't been no sight of warning light earlier, but what exactly is a cutout voltage for that? Could the alternator have been bad earlier?

Something I have been started to wonder also is could the problem be in exciter wire? Fooling the electrics with new cable may disturb, but on the other hand shouldn't the alternator start charging only once? So charging shouldn't have stopped in the middle of highway?

Right now I'm leaning towards the diodes and possibly only changing the diode pack. But also thinking that if short circuit made them fail, why did it made them fail once driving and not right after?

Thank you very much for these replies, as of now alternator is without brushes for now. Will be able to get back to it on monday. But before that soaking all the info and looking for every info you can give to me.
picassodad
Posts: 251
Joined: 04 Oct 2018, 14:26
x 14

Re: Xsara VTS Not charging (other electrical issues too)

Post by picassodad »

Earths earths earths, check them all to rule those out.