No DTCs displayed, but……

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Pete_D60
Donor 2024
Posts: 16
Joined: 26 Apr 2024, 09:39
x 2

No DTCs displayed, but……

Post by Pete_D60 »

Hi All,
I recently acquired a 2014 C3 Picasso with a few issues.
There are no DTCs coming up on the dashboard, but my ArtiDiag800BT has picked up P0693, P0691, P0495, P0494, P0493 as per the attached report.
DTC Report
DTC Report
All looks to be associated with the fan control side of things and I’ve replaced the 1529 fan resistor unit which was badly corroded and the varistor open circuit. However, after clearing the codes, they reappear.
So, more work to do, but looking at the codes, I’m thinking it looks like a status condition issue with the actual status not getting back to the ECU.

Do you guys agree or am I barking up the wrong tree?

Thanks in advance,

Pete
Occasionally, I actually understand what I’m doing, however, now is not one of those times! #-o
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38225
Joined: 15 Sep 2015, 19:38
x 5938

Re: No DTCs displayed, but……

Post by GiveMeABreak »

Pop the VIN up Pete and I'll take a look. Please post your VIN in full without spaces - it will be automatically masked from public view after submitting your post & will only be visible to staff.
Please Don't PM Me For Technical Help

Marc
Pete_D60
Donor 2024
Posts: 16
Joined: 26 Apr 2024, 09:39
x 2

Re: No DTCs displayed, but……

Post by Pete_D60 »

Hi Marc,

The VIN is VF7**************[VIN obfuscated, can be read by forum staff]

Thanks & regards,

Pete
Occasionally, I actually understand what I’m doing, however, now is not one of those times! #-o
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38225
Joined: 15 Sep 2015, 19:38
x 5938

Re: No DTCs displayed, but……

Post by GiveMeABreak »

Fault Code: P0693
Description of Fault: Electric cooling fan unit: Short circuit to earth on the fan assembly control 2
Description of the diagnostics:
Electrical fault detected for 200 ms
Conditions for Fault to clear:
  • Engine running hot for 5 minutes with the cooling fan activated
Downgrade Modes whilst Fault is active:
  • Inhibiting of the exhaust heat recovery function.
  • Prohibiting of regeneration of the particle emission filter and stopping of the requests in progress.
  • Deactivation of the request for regeneration of the particle filter from the diagnostic tool.
Symptoms:
  • Engine overheating with illumination of the engine coolant temperature indicator light
  • No automatic stopping of the internal combustion engine
Suspect Areas:
  • Fan assembly
  • Fuse
  • Electrical harnesses
  • Connectors

Ditto the above for P0691 but refers to: Electric cooling fan unit: Short-circuit to earth or open circuit on the control of cooling fan 1.

Fault Code: P0495
Description of Fault: Electric cooling fan unit: Twin speed: Incoherence between the reference value (high speed) and the status of the fan assembly; Variable Speed: Short-circuit to earth or to the battery or open circuit on the status of the cooling fan'
Description of the diagnostics: Incoherence between the reference value (high speed) and the status of the fan assembly (For 5 seconds)
Conditions for Fault to clear:
  • Activation of the cooling fans unit
Downgrade Modes whilst Fault is active:
  • Inhibiting of the exhaust heat recovery function
  • Prohibiting of regeneration of the particle emission filter and stopping of the requests in progress.
  • Deactivation of the request for regeneration of the particle filter from the diagnostic tool.
Symptoms:
  • Engine overheating with illumination of the engine coolant temperature indicator light
  • No automatic stopping of the internal combustion engine
Suspect Areas:
  • Fan assembly
  • Fuse
  • Electrical harnesses
  • Connectors

Fault Code: P0494
Description of Fault: Electric cooling fan unit: Twin speed: Incoherence between the reference value (low speed) and the status of the fan assembly.
Description of the diagnostics: Incoherence between the reference value (low speed) and the status of the fan assembly (For 5 seconds).
Conditions for Fault to clear:
  • Activation of the cooling fans unit
Downgrade Modes whilst Fault is active: -
Symptoms:
  • Engine overheating with illumination of the engine coolant temperature indicator light
  • No automatic stopping of the internal combustion engine
Suspect Areas:
  • Fan assembly
  • Fuse
  • Electrical harnesses
  • Connectors
Similar for P0493:

Electric cooling fan unit: Twin speed: Incoherence between the reference value (no control) and the status of the fan assembly
Please Don't PM Me For Technical Help

Marc
Pete_D60
Donor 2024
Posts: 16
Joined: 26 Apr 2024, 09:39
x 2

Re: No DTCs displayed, but……

Post by Pete_D60 »

Thanks Marc,

So, from that I think the next thing to check is continuity of the elements in the fan control circuits. Do you have a schematic of the interconnections available or can you link to it on the forum please?

Once that’s completed and if all okay, I guess the fan unit itself is the likely culprit?

Thanks,

Pete
Occasionally, I actually understand what I’m doing, however, now is not one of those times! #-o
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38225
Joined: 15 Sep 2015, 19:38
x 5938

Re: No DTCs displayed, but……

Post by GiveMeABreak »

Your best bet is to just replace the whole assembly to be honest. I don't have the circuit diagram concerned, sorry.
Please Don't PM Me For Technical Help

Marc
Pete_D60
Donor 2024
Posts: 16
Joined: 26 Apr 2024, 09:39
x 2

Re: No DTCs displayed, but……

Post by Pete_D60 »

Sounds like an expensive option Marc, particularly if it turns out to be a wiring continuity issue.

I’ll try and find something online and if successful, I’ll post it on the forum.

Thanks,

Pete
Occasionally, I actually understand what I’m doing, however, now is not one of those times! #-o
Pete_D60
Donor 2024
Posts: 16
Joined: 26 Apr 2024, 09:39
x 2

Re: No DTCs displayed, but……

Post by Pete_D60 »

UPDATE:

After disconnecting connectors from the fan and fan resistor relay unit, ECU, I couldn’t see anything obvious like a corroded pin or loose wire etc.
As I had to go out, I reassembled everything and out of idle curiosity ran a diag with my ArtiDiag800BT, fully expecting the DTCs to reappear after I cleared them.
However, whatever I disturbed seems to have done the trick and everything is working as it should - DTCs cleared! :-D
Occasionally, I actually understand what I’m doing, however, now is not one of those times! #-o