Saxo VTR cant find the immobiliser! help

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Saxo VTR cant find the immobiliser! help

Post by Cyan »

Ive had an alarm fault on my 2003 saxo vtr for a while now and have been doing lots of electrical testing to fix it. Battery is fine, alarm itself is fine I think the antenna coil and transponder chip is fine but will have to double check. Was going to bypass the immobiliser to rule it out bit cant seem to find it. Any help would be much appreciated.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37785
Joined: 15 Sep 2015, 19:38
x 5820

Re: Saxo VTR cant find the immobiliser! help

Post by GiveMeABreak »

The you probably need to change the alarm module nothing to do with the immobiliser - these have batteries in that will discharge over the years and then you'll get problems with the alarm going off all the time.
Please Don't PM Me For Technical Help

Marc
Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Re: Saxo VTR cant find the immobiliser! help

Post by Cyan »

Thanks for the reply but the alarm at the moment is removed entirely. When the key is turned the starter motor goes but hazards go off and car wont start. To me this means it is likely a faulty immobiliser. Thanks again for the reply
User avatar
GiveMeABreak
Forum Admin Team
Posts: 37785
Joined: 15 Sep 2015, 19:38
x 5820

Re: Saxo VTR cant find the immobiliser! help

Post by GiveMeABreak »

Not sure why you mentioned the alarm in your first post in that case if it's been removed?
Please Don't PM Me For Technical Help

Marc
wheeler
Posts: 6931
Joined: 21 Sep 2002, 19:07
x 747

Re: Saxo VTR cant find the immobiliser! help

Post by wheeler »

Are you sure this is a factory alarm? The VTR didn't have a factory alarm as standard like the VTS however it was an option.
Do you have this button in the pic below? looks like a speaker with a cross through it.
Any brand name on the alarm you removed? The factory & dealer accessory ones were made by Texton.
Is the immobiliser warning lamp coming on when the ignition is turned on then go off after a second or 2?
The hazards are unconnected to the factory immobiliser & wouldn't flash them if the the immobiliser was preventing starting.
Can you hear the fuel pump prime when you switch the ignition on?
Attachments
saxo.jpg
wheeler
Posts: 6931
Joined: 21 Sep 2002, 19:07
x 747

Re: Saxo VTR cant find the immobiliser! help

Post by wheeler »

The factory immobiliser box is located behind the glovebox, you wont be able to bypass it by twisting a few wires together, bypassing it will require re writing the eeprom inside the engine ECU.
If it’s aftermarket should be easy enough to bypass depending how lazy the fitter has been.
Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Re: Saxo VTR cant find the immobiliser! help

Post by Cyan »

Also dont know what this thing is. was resting just underneath the steering wheel.

Thanks again for your help mate
Attachments
85C9B805-4B31-485E-970D-F9EA5CA10A57.jpeg
7685F53F-5424-4A45-9CC7-6138689290E8.jpeg
Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Re: Saxo VTR cant find the immobiliser! help

Post by Cyan »

Dont know if my last message got through but here is the summary:
.immobiliser warning light comes on and of again almost instantly
.I can hear the fuel pump priming
.Ive checked with previous owner and the alarm is after market
.I dont have the button in the picture and the removed alarm doesnt have a brand name
User avatar
xantia_v6
Forum Admin Team
Posts: 9134
Joined: 09 Nov 2005, 23:03
x 847

Re: Saxo VTR cant find the immobiliser! help

Post by xantia_v6 »

Cyan wrote: 26 Apr 2024, 19:29 Also dont know what this thing is. was resting just underneath the steering wheel.

Thanks again for your help mate
Image
Image
That is the "clock spring" for the driver's airbag mounted in the steering wheel. I am guessing that your car has had a different steering wheel fitted without airbag.
PaulC5
Donor 2024
Posts: 355
Joined: 06 Jun 2023, 15:26
x 93

Re: Saxo VTR cant find the immobiliser! help

Post by PaulC5 »

Our 2007 C5 has a factory fitted alarm and if the alarm module (not just the siren) is disconnected the hazards flash all the time when the engine is switched on. Whilst you do not have a factory fitted alarm, before you disconnected it did the hazards not flash and did the engine start - just wondering if whoever fit it made some connections that you have not reversed ?

If your steering wheel air bag has been removed I would think this would be a modification for insurance purposes, never mind a safety thing.
Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Re: Saxo VTR cant find the immobiliser! help

Post by Cyan »

Thanks for the reply mate.

When I disconnected the alarm I was expecting it to go off and hazards flash etc but absolutely nothing happened. The problem was fixed for about 2 weeks then It came back. Battery was buggered so changed that and all worked fine for 2 weeks again then it came back. And thats where I am now.
And Im not sure at all about the reversed connections.

Thanks again
User avatar
xantia_v6
Forum Admin Team
Posts: 9134
Joined: 09 Nov 2005, 23:03
x 847

Re: Saxo VTR cant find the immobiliser! help

Post by xantia_v6 »

Several things have been discussed in this topic and I have got a bit confused as to what is the actual problem you are trying to solve. Is it a non-starting engine?
PaulC5
Donor 2024
Posts: 355
Joined: 06 Jun 2023, 15:26
x 93

Re: Saxo VTR cant find the immobiliser! help

Post by PaulC5 »

If a new battery cured the faults, have you checked the voltage of the one now installed in case it has gone flat ? Before starting the engine a fully charged one will be about 12.7 volts but if much below 12.5 volts and it needs charging. When the battery is flat on our C5 odd things will happen on their own when switching on the ignition such as the headlights will come on, the front wipers will move but the engine will barely turn over on the starter so the engine will not start.
Cyan
Posts: 8
Joined: 25 Apr 2024, 13:32

Re: Saxo VTR cant find the immobiliser! help

Post by Cyan »

Yeah the new battery is fine Ive checked and double checked voltage and amps. Voltage still at around 12 despite having been sat there for about 2 weeks.
And to reiterate the problem is a non starting engine.

Thanks for the replies
wheeler
Posts: 6931
Joined: 21 Sep 2002, 19:07
x 747

Re: Saxo VTR cant find the immobiliser! help

Post by wheeler »

Initially i would forget about the factory immobiliser & just treat it as a regular non starter. Spark, fuel, compression & timing etc.
If the ECU was not unlocking i would expect the immo lamp to be flashing rapidly with ignition on.