Blower Motor - Am I missing something?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Rosco88
Posts: 4
Joined: 17 Apr 2023, 09:38

Blower Motor - Am I missing something?

Post by Rosco88 »

Morning All!

The blower on my 07 Mk1 C4 failed this week, i have had it out at the weekend, checked and replaced fuses and still no joy.

At one point during testing (fan out + plugged in) i turned the car on and the fan switched on for about a second then went off again - which makes me believe it is not the fan - or the power.....

I have changed Fuse 11 on the below
Image

and fuse 11 on the below
Image

I have read about failing relays and changing the entire fuse board as well as the heater resistor, but was hoping for a little more guidance before spending money.

( i appreciate diagnosis over the internet is a little difficult)
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38581
Joined: 15 Sep 2015, 19:38
x 6012

Re: Blower Motor - Am I missing something?

Post by GiveMeABreak »

The most common cause for the motor failing (apart from the blower motor itself) is the Blower Motor Control Module. When these resistor controls fail, either the fan will remain on full blast or nothing.

If this is the case, then which type you need, will depend on the specific vehicle and type of air conditioning you have (simple or automatic).

If you need an original, genuine part number or part diagram, and can't already find the info you need on the Forum, we do ask for a membership upgrade for official parts data as we are in turn charged for this. It will cover you for future part number requests for up to 2 years, so excellent value.

If interested, links are below, then pop your VIN up.
A response to your question by a Forum Admin requiring parts or additional information requires you to have made a current contribution (£10 min.) to the Forum.
To Upgrade Your Membership & Donate Click Here

For Further Information About Vehicle Parts and VIN Numbers Click Here
Please Don't PM Me For Technical Help

Marc
Rosco88
Posts: 4
Joined: 17 Apr 2023, 09:38

Re: Blower Motor - Am I missing something?

Post by Rosco88 »

Hi Marc,

Thanks for the response.

The aircon unit in the car is this one (only pic i can find online)

Image

and the blower motor is this
Image

and form what i can read it says the Resistor Pack is part of the front panel? So its potentially a new unit job?
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38581
Joined: 15 Sep 2015, 19:38
x 6012

Re: Blower Motor - Am I missing something?

Post by GiveMeABreak »

No, it won't be there. The Blower control module is located to the side of the heating unit, not in the air conditioning control panel. You'll need to remove the passenger lower right side footwell trim to get to it.
Please Don't PM Me For Technical Help

Marc
wheeler
Posts: 7000
Joined: 21 Sep 2002, 19:07
x 765

Re: Blower Motor - Am I missing something?

Post by wheeler »

The heater speed controller/resistor unit is on the left side of the heater box, remove the glovebox for access. Its a kind of bayonet fitting where you do a quarter twist anti clockwise to remove it. Plenty of new aftermarket ones on ebay for under £20 inc postage.
Cheap enough for a punt but be aware heater problems on early C4's can be caused by the under bonnet fusebox, There is a big (non replaceable) relay in there that can play up.
Attachments
resistor2.jpg
resistor.jpg