Hi all

A forum for new members to introduce themselves to the rabble already onboard. Not compulsory!
Tell us a little about yourself, lie if you have to but keep it to just an introduction, not a car discussion.

Moderator: RichardW

NZKiwi
New User
Posts: 1
Joined: 29 Dec 2021, 12:58

Hi all

Post by NZKiwi »

Hope all are doing well these holidays.

I have a few issues with a Peugeot 2010 308 Turbo 6speed Auto.
Searching internet I came across the French Car Forum. I found a comment made by a member of the Forum Admin Team Xantia on a post linked below & so I joined to ask if the person would point me in the direction of the "alternator control module that shares a fuse with the turbo cooling pump"

viewtopic.php?t=63940

Not sure when I will be able to PM as this is my first post.
User avatar
mickthemaverick
Donor 2022
Posts: 8678
Joined: 11 May 2019, 17:56
x 2398

Re: Hi all

Post by mickthemaverick »

Hi NZKiwi and :welc: to the FCF
My partner is a Kiwi so its always good to hear from that side of the world :-D . If you don't get a reply on this thread then go to the Peugeot section of the Forum from the Board Index above and post your query up there. While you are in the board index have a look around the forum in general, there are some very diverse topics under discussion, especially in the Off Topic Chat Lounge so join in anything that intrigues you!! :)
User avatar
xantia_v6
Forum Admin Team
Posts: 8060
Joined: 09 Nov 2005, 23:03
x 534

Re: Hi all

Post by xantia_v6 »

I don't know where the alternator control module is physically located (we can probably find it in the documentation). In my case the fuse was blowing because the auxiliary cooling pump on the turbo had failed, this is the common failure, but the diagnostics indicated an alternator fault. Unplugging the pump and replacing the fuse showed that the charging system was actually OK.
User avatar
xantia_v6
Forum Admin Team
Posts: 8060
Joined: 09 Nov 2005, 23:03
x 534

Re: Hi all

Post by xantia_v6 »

What symptoms do have?