xantia no injection pulse

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
saeedm
Posts: 66
Joined: 29 May 2021, 11:51
x 14

xantia no injection pulse

Post by saeedm »

hi there.
the engine is xu10-rfv
car start for like 2 seconds and then turns of. after that it is not starting.
looks like it is not injecting fuel.
why it is not injecting fuel?
Online
wheeler
Posts: 5271
Joined: 21 Sep 2002, 19:07
x 316

Re: xantia no injection pulse

Post by wheeler »

Have you confirmed there is no injector pulse with a noid light or similar? are the injectors being supplied with 12v? Are you getting a spark? can you see engine RPM in live data?
User avatar
saeedm
Posts: 66
Joined: 29 May 2021, 11:51
x 14

Re: xantia no injection pulse

Post by saeedm »

yes i checked with light and multimeter. it is not geting injection pulse.
all 4 injector connector have ground (-12volt).
when i sparyed fuel to air intake , it started!
so it have spark. and rpm is rising on dashboard when crancking.
User avatar
saeedm
Posts: 66
Joined: 29 May 2021, 11:51
x 14

Re: xantia no injection pulse

Post by saeedm »

update:
i disconnect all 4 injectors connector and checked them with light bulb. it was pulsing! but light was so weak!
then i ejected injectors and applied voltage to them from battary they are not injecting fuel still.
Online
wheeler
Posts: 5271
Joined: 21 Sep 2002, 19:07
x 316

Re: xantia no injection pulse

Post by wheeler »

Dont want to state the obvious but as you haven’t mentioned it is the fuel pump operating & is there fuel in the tank (don’t believe the fuel gauge)?
Is there enough fuel pressure?
User avatar
saeedm
Posts: 66
Joined: 29 May 2021, 11:51
x 14

Re: xantia no injection pulse

Post by saeedm »

last update:
i checked fuel injector and they was stuck and not operating
so i connect them directly to battery and tried to flush them.
and now car is working just like new.
Online
wheeler
Posts: 5271
Joined: 21 Sep 2002, 19:07
x 316

Re: xantia no injection pulse

Post by wheeler »

All 4 of them??
User avatar
saeedm
Posts: 66
Joined: 29 May 2021, 11:51
x 14

Re: xantia no injection pulse

Post by saeedm »

yes bro.
this car has not worked for 5 years!
injectors were stuck badly and they were clogged up