Xsara Picasso 04 - crank, no start

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

victorimba
Posts: 3
Joined: 14 Mar 2021, 14:01

Xsara Picasso 04 - crank, no start

Post by victorimba »

Greetings!

Im having trouble with my Xsara Picasso that cranks but doesnt start. Im getting the following DTCs: P0200 and P0350 (the ignition coil was changed by the last owner a couple of weeks ago, so its pretty new) and I want to do some troubleshooting. I've been looking everywhere for a wiring diagram over the circuits regarding the injectors and ignition coil, but cant seem to find anything useful. My question is if anyone here knows how these systems are wired, or even better has a wiring diagram overseeing it?

Right now im working by the best of my general knowledge and im finding about 2.5V at the contacts to the injectors and 0V at the connector to the ignition coil. My best guess is that i should find 5 or 12V at the injectors and 12V at the contact to the ignition coil (key on, engine off).

By this im being drawn into thinking its an issue with the wiring or maybe the ECU, but its a wild guess at this point. Does anyone have any valuable input to this?

wheeler
Posts: 4738
Joined: 21 Sep 2002, 19:07
x 228

Re: Xsara Picasso 04 - crank, no start

Post by wheeler »

What is the last 8 digits of the VIN please?
Injectors & coil are 12v feeds but you may only get this on cranking.
Did the engine run after the coil was changed then stop again or was it replaced to try & cure the fault?
Have you checked ALL the fuses & removed the ECU plugs to check for water ingress or corrosion?

victorimba
Posts: 3
Joined: 14 Mar 2021, 14:01

Re: Xsara Picasso 04 - crank, no start

Post by victorimba »

The last eight digits are: 39587020

Ah, I tested the connector to the ignition coil with a LED-test light while cranking and it didn't light up, I could try the same with the injector connectors.

From my understanding the car died on him and he towed it to the local mechanic that diagnosed a faulty ignition coil and put in a new one. The car then ran fine for a while until the engine light lit up again giving him a P0420-code. He installed a new catalytic converter and the car ran for a couple of miles until dying on him again. The car was towed back home and here we are. There is also a EVAP-related code present, but i think the car should start anyway.

I've checked all fuses in the fuse box to the right in the engine compartment and at the driver side inside the car (its a left hand drive).

By removing the plugs you mean the three female connectors to it? If so, yes. I've checked them and the pins on the ECU. I cant see any apparent water or electrical damage or corrosion, it looks clean as new.

wheeler
Posts: 4738
Joined: 21 Sep 2002, 19:07
x 228

Re: Xsara Picasso 04 - crank, no start

Post by wheeler »

Here is the full injection system diagram
1331-1334 are the injectors & 1135 is the coil pack.
Attachments
picasso.jpg

victorimba
Posts: 3
Joined: 14 Mar 2021, 14:01

Re: Xsara Picasso 04 - crank, no start

Post by victorimba »

You are a real saint, thank you!