C4 Heater Blower not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

mikezener
Donor 2021
Posts: 7
Joined: 19 Jan 2021, 14:17
x 2

C4 Heater Blower not working

Post by mikezener »

Good afternoon all. For my sins I agreed to look at a friends C4 Hatchback Diesel on a 15 plate (2015) as the heater blower has stopped working. After trawling the internet for some time and coming across this forum it looked like the heater control resistor would be a good place to start. The control panel on the dash is lighting up as it should.
Having dropped out the glove box and the paneling on steering side (RHD) i am having real difficulty locating it. Having looked at the various drawings and you tube video's of the heater they don't look anything like whats fitted in the C4. Any help would really be appreciated.

Mikez

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22604
Joined: 15 Sep 2015, 19:38
x 2341

Re: C4 Heater Blower not working

Post by GiveMeABreak »

Are you talking about the C4 (B7) car, not the C4 Picasso? If so, the heater blower control module is on the left (passenger side) which is why you can't find it I suspect. It might be better to pop the VIN ups so we can be sure of what model you have.

mikezener
Donor 2021
Posts: 7
Joined: 19 Jan 2021, 14:17
x 2

Re: C4 Heater Blower not working

Post by mikezener »

Ok thanks, its definitely not the Piccaso. I will pop the Vin as soon as i can

Mike

mikezener
Donor 2021
Posts: 7
Joined: 19 Jan 2021, 14:17
x 2

Re: C4 Heater Blower not working

Post by mikezener »

Hi Mark VIN VF7**************[VIN obfuscated, can be read by forum staff]

Mike

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22604
Joined: 15 Sep 2015, 19:38
x 2341

Re: C4 Heater Blower not working

Post by GiveMeABreak »

Ok you have C4 (B7) same as the DS4, see my posts here for the location of the unit:

viewtopic.php?p=670207#p670207

and here:

viewtopic.php?p=662328#p662328

mikezener
Donor 2021
Posts: 7
Joined: 19 Jan 2021, 14:17
x 2

Re: C4 Heater Blower not working

Post by mikezener »

Hi Marc, Thanks for your help. Dropped out module connector and checked with multi meter. (low volts from supply across pins 3 and 6) Turned out to be a bad ground in the connector on your drawing 10 PR/59 CLM. I took that out completely and replaced with a choc block. Al's good now, just got to put all the fascia back :rofl2:
Mikez

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22604
Joined: 15 Sep 2015, 19:38
x 2341

Re: C4 Heater Blower not working

Post by GiveMeABreak »

Excellent - good news and thanks for the Forum donation. That has upgraded your member status too - so will cover you for any live part numbers for up to 2 years.

User avatar
Paul-R
Donor 2020
Posts: 5177
Joined: 07 May 2009, 16:24
x 705

Re: C4 Heater Blower not working

Post by Paul-R »

Shouldn't it now say Donor 2021 if the donation was within the last couple of weeks?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22604
Joined: 15 Sep 2015, 19:38
x 2341

Re: C4 Heater Blower not working

Post by GiveMeABreak »

Yes, we need to make some configuration changes. Shouldn't take too long to resolve.

mikezener
Donor 2021
Posts: 7
Joined: 19 Jan 2021, 14:17
x 2

Re: C4 Heater Blower not working

Post by mikezener »

Hi Marc, No problem with the donation. Faults turn out a lot easier to fix when you do have the correct info too hand. Hopefully I wont have to bother you too much but we do have 5 citroens in the family :rofl2:
Mikez