No heating/Air conditioning - Baffled

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

No heating/Air conditioning - Baffled

Post by KennyW »

Well suspension working fine but heating/air con nothing.

Had look at 40 amp fuses in engine fuse box nothing to suggest fuse blown.

Are there any wires which run near to where the suspension pipe runs to the rear.

Pipe runs underneath engine mount down bulkhead to fuel tank up and over then up and behind electric handbrake module ALL ALONG OFFSIDE of car.

Going to put lexia onto carry and check for faults.

Do C5's have the same problem as Xantia's re control module transistors blowing ?

Kenny

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

They do Kenny. Have you got any lights on the Climate control panel at all? If it is the blower motor control module, that will only affect the blower motor. It should not affect the air distribution and air mixing flaps though, not the A/C. So if you can't hear any of the mixer or air distribution motors moving when adjusted, it may be more than the blower motor control module - possibly the Climate control panel itself. But check with Diagbox as you can check the operation of the stepper motors etc.

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

Thanks Marc,

You hear nothing at all but I'm thinking I should do a BSI reset again as I had the battery of the car . I forgot to say there are lights on the climate control showing temperature etc.

Strange thing was the battery was dead when I removed it to fit pipe no lights or anything when I turned the ignition to on, hence battery out and recharge.

I may have done some thing when refitting battery.

I did a diagbox check but nothing for heating / air con.

There was a F5FF code which may indicate I didn't do the reset right.

Will leave reset until tomorrow but any other thoughts gratefully received.

Just happy suspension is working fine, only to check heights and re input parameters to set properly.

Kenny

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

F5FF is an unexpected re-initialisation fault coming from the BSI and possibly also as a consequence of a weak battery.

BSI Reset / Battery Disconnect / Reconnect Procedure

For when you reconnect it.

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

Thanks Marc,

I'm wondering if that is the reason for the heating / aircon is not working. It's been raining here so can't do the reset. I've got the procedure printed.

Kenny

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

The ECU is inside the climate control panel - so if the ECU is a bit out of kilter a reset may sort it.

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

I'll let you know the outcome.

Kenny

RichardW
Forum Treasurer
Posts: 9296
Joined: 07 Aug 2002, 17:12
x 378

Re: No heating/Air conditioning - Baffled

Post by RichardW »

You always get the reinitialisation fault when the battery's been off. It might just have some damp in it as you've not used it in a while, take it for a run and warm it through and see what happens?

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

Thanks Richard, It's been to Edinburgh and back and still no change but I opened the front o/s door and interior light did not come on.

I've not tried the rear doors but the interior lights in the boot came on.

Just coincidence or what !

Kenny

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

BSI reset done and no change.

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

Looking for wiring diagram for heater blower

Is the module part of blower or a separate unit?

Kenny

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

Separate unit Kenny. I'll put something up in a second - check back here later:

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

Item (10) is the Blower Control Module:
image_2020-11-13_002003.png
8045 is the Blower Control Module
8050 is the Blower Motor
8080 is the Climate Control Panel

Image

User avatar
KennyW
Donor 2020
Posts: 1996
Joined: 17 Jan 2006, 22:22
x 49

Re: No heating/Air conditioning - Baffled

Post by KennyW »

Thanks Marc,

All I need to do now is take the module and blower out at least it's not left hand drive !!!!!!!!!!

Kenny

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: No heating/Air conditioning - Baffled

Post by GiveMeABreak »

Kenny - have a look at the pictures on my post here that I included when changing the pollen filter - there's a couple of pics of the blower control unit about half way down and some pics of where the plastic trim parts are for removal of the side panel of the passenger footwell - so you can avoid any snapping.

viewtopic.php?t=56902