Citroen Xsara Cooling Fans Problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Go6unatora
Posts: 3
Joined: 01 Nov 2020, 15:03

Citroen Xsara Cooling Fans Problem

Post by Go6unatora »

Hello!
First to introduce myself. I am 20 years old and I just got my first car. My dad used to drive it, he bought a new one and he gave me his car.
Its Citroen Xsara Break 1.9TD 90hp. Car drives so good and is actually fast for 90hp when the turbo kicks in. So when my father bought the car back in 2009, the fans were not spinning when the engine gets hot so he put a small key under the dashboard.(the car has A/C). When I got the car I decided to fix that. I saw that the car has BiTron module which is located under the left headlight. Before trying to find it, I found out that the Fuse for the fans was removed. I put one 20A and the fans kicked in at max speed instantly while the car was not hot (it wasnt even running). I removed the fuse and searched for the BiTron. When I found it and took it off I saw that the plastic was broken and there was green stuff inside( when the metal is exposed to water it gets this green look ). I cleaned everything and soldered some of the things ( i know this and that ) and closed it with Sillicon. I plugged it in (the car had STOP warning lamp) and started the car and the STOP warning light was gone!!! I put the fuse back and now only the right fan kicks in. Before it was both of them and now its only the right one. I know that on this car when i turn on the A/C the right fan should start spinning. Well it spins all the time now until i remove the fuse. The left fan is okay and doesnt start spinning like before (that means i fixed the bitron??)
I found out as well that my father took electricity for the handmade fan switch from some fuse under the dash as the wire that goes to the fans relay( the boxes between both fans ) doesnt go through the battery.
There is a weird problem as well. The RPM meter was not working so i changed the sensor which goes to the gearbox (the crankshaft sensor) but it did nothing. So yesterday i was just changing some fuses as there were some blown ones and after starting the car i found out that i have RPM meter again? I started taking out the fuses one after one and the 12th fuse on the right row from up to down. (for the backlights and stop switch) When i take it off the rpm meter starts instantly and there is a BEEP BEEP noise at 1800 RPM, but i lose the reversing lights and the stop switch lights)
Can anyone enlighten me as this is my first french car and its so good, only the eletrical problems are a bit hard to deal with. Thanks! I think the is equipped with the XUD9TE/Y engine. (90hp with turbo/intercooler).

wheeler
Posts: 4392
Joined: 21 Sep 2002, 19:07
x 165

Re: Citroen Xsara Cooling Fans Problem

Post by wheeler »

There are lots of cooling fan setup variations depending on model year & equipment, I would need the last 8 digits of the VIN to get the correct wiring diagram to have a look.

As for the rev counter, if it was working again why were you removing fuses? this is a bit confusing.

Go6unatora
Posts: 3
Joined: 01 Nov 2020, 15:03

Re: Citroen Xsara Cooling Fans Problem

Post by Go6unatora »

wheeler wrote:
01 Nov 2020, 16:54
There are lots of cooling fan setup variations depending on model year & equipment, I would need the last 8 digits of the VIN to get the correct wiring diagram to have a look.

As for the rev counter, if it was working again why were you removing fuses? this is a bit confusing.
36516157 are the last 8 digits on the VIN. Well when I remove the fuse the lights on the back when i put on reverse or press the brake doesnt not come up anymore, and as well the beeping sound on 1800 rpm.
I dont wanna risk driving without the back lights as it can confuse other drivers.

wheeler
Posts: 4392
Joined: 21 Sep 2002, 19:07
x 165

Re: Citroen Xsara Cooling Fans Problem

Post by wheeler »

OK this is the diagram for the cooling fans, looks like you have the twin fan setup using 3 relays to alter the speeds.
The Left fan is 1511. I would start by checking the 3 relays in between the 2 fans, they are prone to corrosion due to the location.
Sorry i still dont understand why you are now removing fuses?
Attachments
xsara fans.jpg

Go6unatora
Posts: 3
Joined: 01 Nov 2020, 15:03

Re: Citroen Xsara Cooling Fans Problem

Post by Go6unatora »

wheeler wrote:
01 Nov 2020, 23:21
OK this is the diagram for the cooling fans, looks like you have the twin fan setup using 3 relays to alter the speeds.
The Left fan is 1511. I would start by checking the 3 relays in between the 2 fans, they are prone to corrosion due to the location.
Sorry i still dont understand why you are now removing fuses?
Image
Well I started taking them out to see which fuse blocks the RPM meter because when i plugged literally every fuse hole the RPM meter went out. So i found out that when i put in the fuse for the reverse lights and stop switch my RPM meter is gone. When i take out the fuse the RPM meter comes up again and the beep sound at 1800 RPM which i dont know why it comes on. Thank you for the diagram!