C4 xenons judder and rattle on startup

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

C4 xenons judder and rattle on startup

Post by Cutac »

Hi all, I've a question regarding C4 I xenons startup procedure.

Ever since I had the car, when I would turn the key to the first position, xenons would make a noise and that's it. I though it was normal because all worked well. I was talking to a guy who has a C5 first gen with xenons and said that mine made a rattling noise. His on the other hand don't. That got me thinking, why do mine rattle then, is something broken?
To check what's happening when they initialise, I've set up my camera to record them.

As seen in the video, when they get to the inner position, noise starts and projectors visibly judder as if they're hitting an obstacle or a limiter. Further examination and research got me a picture of the azimuth motors. They are connected to the projectors via a steel cable which seems to have an oval ring on it.

So, should I be nervous about the juddering and should I unscrew the torx holding the cable and move the projector outwards a bit so it doesn't "hit the limiter" any more?

Also, could someone with C4 I and xenons please listen to theirs if they make the same noise. Also, if you could turn the dipped beam on before switching the ignition so you could look at the beam pattern on the wall and see if it shakes/judders?
I'd be very grateful for that :-D

Here's a video of my headlamps and here's a photo of the azimuth motor and the cable.



Image

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21224
Joined: 15 Sep 2015, 19:38
x 2116

Re: C4 xenons judder and rattle on startup

Post by GiveMeABreak »

The MK I C5s (pre-facelift) Xenon's didn't have directional lighting, they were the fixed type, so his would not have made a noise regardless.

My MKII C5 (facelift) models fitted with xenons were directional and did the self-test routine each time and made no grinding noise.
My MK III has them and make no noise either.

Is it doing this on both sides or just one?

They may need adjusting or it may be that the motor(s)s are on the way out as it seems to be trying to turn the lamp past the 'stop' position and then keeps rebounding back and forth. There shouldn't be any grinding like that.

It may be the Azimuth adjustment motor(s) that are out of calibration. It shouldn't be anything to do with the height sensors as that is for the vertical adjustment. The only other thing is the headlamp ECU that performs the calculation.

But before all that - when did you last have the beam alignment checked? These can be adjusted (including the Azimuth position), but needs beam setting equipment:
image_2020-10-19_103938.png
Correct the vertical setting of the headlamp (height) by acting on the screw (at "f").
Correct the horizontal setting of the headlamp (azimuth) by acting on the screw (at "g").
image_2020-10-19_104040.png
Align the beam of light "j" of the headlamp slightly below the line de demarcation "h".
Note: Adjusting the dipped headlamp automatically adjusts the main beam headlamp.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 xenons judder and rattle on startup

Post by Cutac »

The noise is present on both sides.

Can the motors be calibrated in the Diagbox?

Beam is checked annually on the MOT and is fine. I've tried turning the "g" knob for adjustment but it won't budge on either headlamp. But even if it was misaligned, would it be designed in a way that a slightly misaligned projector would judder on the "bump stop"?

P.S. I think there's no juddering present if I activate azimuth motors on the Diagbox, if I remember correctly.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21224
Joined: 15 Sep 2015, 19:38
x 2116

Re: C4 xenons judder and rattle on startup

Post by GiveMeABreak »

There's no adjustment in Diagbox available. It has to be done with a Beam setter tool. I wouldn't try adjusting it without the proper tool as it might make it worse.

The only other thing I can think off is the motor units themselves or the ECU in that case.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 xenons judder and rattle on startup

Post by Cutac »

I meant is it possible to calibrate the motors through the Diagbox?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21224
Joined: 15 Sep 2015, 19:38
x 2116

Re: C4 xenons judder and rattle on startup

Post by GiveMeABreak »

No - there's no adjustment / calibration in Diagbox as I mentioned - and I am referring to the motors.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 xenons judder and rattle on startup

Post by Cutac »

So I can just lubricate the cable and hope for the best :D