C4 I directional headlamp ECU

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

C4 I directional headlamp ECU

Post by Cutac »

Hello!

Long time no see :)
Does anyone know where directional headlamp ECU is located on a 2006 C4 VTS? I have the "no connection to directional headlamp ECU" fault but can't find the ECU anywhere.

Thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

The headlamp adjustment ECU location is near the left hand wheel arch are of the engine bay.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Thanks!
It's not in the fusebox, right?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

Correct, it’s a separate ECU.

I’d try and show you, but I’m in the process of suing Microsoft after Windows 10 had another fail last night, after some ‘updates’.

I’m restoring my systems at the moment, so back to good old iPhone!

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Good luck with that, mate! Fingers crossed you'll succeed :)

I have offline servicebox, but I can only find a vague display of the ECU and can't find it mentioned in the workshop manuals. I'll try to trace wiring back to it.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

Not very good, but it should be near to the left side of the fusebox - I've arrowed it - item 6606.
cutac.PNG
cutac.PNG (37.49 KiB) Viewed 71 times
Like this:
cutac 2.PNG

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Found it, under(above) the wheel liner.
All is well, all connections are fine.

Thing is, that ECU is greyed out in the Diagbox. Can it be re-paired to the car? Resynchronised or whatever it's called.

Online
Hell Razor5543
NOT Alistair or Simon
Posts: 10867
Joined: 01 Apr 2012, 09:47
x 1107

Re: C4 I directional headlamp ECU

Post by Hell Razor5543 »

I wonder if a BSi reset might help here? Marc has the details.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Did that, didn't help.

3 years ago I've had that problem(although, I didn't have the Diagbox at the time so I don't know what exact fault it was), took it to "the guy" and he said something along the lines of "I've freshly paired your car with the headlamps" and that fixed whatever problem there was.
I'll try to do something like that tomorrow.

Is it possible to ruin something? I don't want to start some kind of pairing process only for it to fail because of some faulty component and find myself without dipped beam or indicators.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

You didn't mention what the initial problem was.

There's no pairing involved at all - only the configuration of the ECU parameters (if there is anything configurable on your unit of course). Without knowing what the issue is, I can only assume you don't have the directional headlamps working - and that these are only working dead ahead? If you've turned on the directional function using the steering wheel control to access the menu and it isn't working, then there should be a fault code. I think the ECU is called 'LAD' on Diagbox, but could be wrong. Hard to see without some screen shots of your ECU list.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Yep, the lamps are stationary. They do track normally, they're not pointing to the ground though.
When directional lamps are switched off in the vehicle menu, all is good, but when I switch them on, I get SERVICE light, flashing dipped beam symbol and a "Directional headlamps" faulty message on the screen.

I'll do some Diagbox screenshots tomorrow. The fault code is F089.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

Unfortunately there's nothing additional on that apart from what you already know as F089: Fault no communication with the directional headlamps ECU : Not characterised, is just that - an unknown fault, so maybe the ECU is dead or the connection to it is faulty so there's no power or comms with it.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

So it means I'm in for a ride :D
If that ECU is greyed out it just confirms that BSI thinks it's unplugged, right?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21621
Joined: 15 Sep 2015, 19:38
x 2171

Re: C4 I directional headlamp ECU

Post by GiveMeABreak »

A3 is your CAN Low Intersystem
A1 is your CAN High Intersystem
G3 is your Earth
B2 is your LIN Bus
D2 Earth
G2 is your power to the engine fuse box.

As the headlamps are working I would ignore the power connections and earths (D2 & G2) and focus on the CAN connections on pins A3 & A1 and the earth G3 - as these are the network communications lines to the BSI and it is through these connections we know it can't communicate through.

User avatar
Cutac
Posts: 344
Joined: 28 Aug 2016, 19:36
x 20

Re: C4 I directional headlamp ECU

Post by Cutac »

Thank you. I've printed out a PDF from SEDRE and I'll follow the pictures and check every connection.

These codes(A3, A1, G3, ...), is there a scheme for them?