ET6G gearbox fault

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

steenschalls
Donor 2020
Posts: 20
Joined: 22 Dec 2018, 09:44
x 2

ET6G gearbox fault

Post by steenschalls »

Hello dear Friends

I have a C3 Picasso with semi auto gear box. I have now the service lamp on, unable to extinguish, in the display I have engine and gearbox fault, but no engine fault symbol. The engine seems to function normally with power and revs.
When I set the gear lever in auto and drive, it will not shift out of 1 gear. I can manually shift up to 3 gear. If I then go neutral with gear lever and back to manual I can shift up to 6th gear, Going down in speed it comes normally back to 1st gear. I have a P171A fault in Lexia, but NO ABS or BRAKE fault.

VF7**************[VIN obfuscated, can be read by forum staff]
192000 km
Best regards

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21609
Joined: 15 Sep 2015, 19:38
x 2171

Re: ET6G gearbox fault

Post by GiveMeABreak »

Hi Steen

Your Gearbox ECU has gone into a backup mode caused by the fault.

P171A means there is coherence fault in the CAN and brake wiring and this will prevent gears above third being selected.

Suspect areas:
  • Gearbox ECU
  • Sealing of the connectors and harnesses
  • 28-way connector of the piloted manual gearbox ECU
  • 28-way harness of the piloted manual gearbox ECU
  • Brake switch
First thing I would do is check or replace your brake switch as this is the easiest and cheapest option. Have you had any work done on it lately? If the gearbox ECU connection has been disturbed that can also be a candidate.

When this mode is engaged, it's usual only to start the engine with the gear selector in manual mode and in Neutral with presses on the brake pedal.

steenschalls
Donor 2020
Posts: 20
Joined: 22 Dec 2018, 09:44
x 2

Re: ET6G gearbox fault

Post by steenschalls »

Thank you for your reply. Brake sw changed, still same fault. Both front shock absorbers changed recently. But the gear box had no faults for about a week after the repair? I have no ABS or brake fault

Regards
Steen

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21609
Joined: 15 Sep 2015, 19:38
x 2171

Re: ET6G gearbox fault

Post by GiveMeABreak »

So 2 things:

1) When you replaced the brake switch, check the locking of the brake switch: The force required for locking is slight at the start of the quarter turn and goes beyond the point of resistance at the end of the quarter turn to validate the locking. If it's not locked properly it can cause an operating fault.

2) The next thing I would check considering the work you have done is to check all the electrical connectors to the piloted Gearbox ECU. One of the recommendations and could easily of been disturbed or damaged during the repairs.

I have highlighted the 28 pin connector to the gearbox ECU below with a green arrow. Check this connection, and also the gear engagement (10) and gear position (11) sensors shown:
steen.PNG

steenschalls
Donor 2020
Posts: 20
Joined: 22 Dec 2018, 09:44
x 2

Re: ET6G gearbox fault

Post by steenschalls »

I cannot find any fault on wiring or connectors. Now there is a fault code P1445, particulate filter full. Can this lead to the gearbox back up mode?
Regards Steen

User avatar
GiveMeABreak
Forum Admin Team
Posts: 21609
Joined: 15 Sep 2015, 19:38
x 2171

Re: ET6G gearbox fault

Post by GiveMeABreak »

No, that won't effect the gearbox, only the engine ECU at some point, because P1445 means your particle filter is at end of life. The volume free in the particle filter is not sufficiently large enough and iot will be necessary to replace the particle filter at the next service interval.

It means that the maximum amount of additive fluid has been pumped into the system and the compounds that cannot be burnt off like Cerine, ash and engine / oil deposits, hydrocarbons etc., are clogging the filter. You can get it cleaned - but it will never get all of these elements out.

Your gearbox issue is separate.

steenschalls
Donor 2020
Posts: 20
Joined: 22 Dec 2018, 09:44
x 2

Re: ET6G gearbox fault

Post by steenschalls »

Dear friends

The gear problem is now solved after extensive trouble shooting at the local Citroen dealer. The fault was in the generator. The charging was fine, but there is a direct connection from generator to gearbox computer, because of the installed start-stop system. This output from the generator was missing. The service lamp warning has also gone, and the car is now driving as a new one.
Thank you for your inputs

regards Steen