Flat spots & P1462

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

pauljordanie
Posts: 62
Joined: 14 Nov 2018, 14:39

Flat spots & P1462

Post by pauljordanie »

2009 Peugeot 308 1.6HDI DV6TED

Scanned codes P1462 & P2299

When lightly press accelerator from coasting there is a flat spot were it hesitates and then goes. That flat spot also sometimes happens when driving along, it feels like it dies for a sec or two then picks up. Live data shows EGR throttle electrovalve invalid reading at idle, also invalid readings sometimes when driving along. Is the P1462 linked to EGR throttle electrovalve and where is the EGR throttle? In the dossier?

moizeau
Donor 2020
Posts: 991
Joined: 12 Jan 2015, 17:08
x 131

Re: Flat spots & P1462

Post by moizeau »

Do an actuator test on the egr to confirm. Also unplug the MAF and go for a spin. The hesitation / flat spot sounds similar to mine, also mine didn't like 3000 rpms under load on 4th or 5th, and felt a bit flat.
Have a read through this,
https://www.frenchcarforum.co.uk/forum/ ... 3&start=45
the flat spot bit is page 4 about 1/2 way down.

pauljordanie
Posts: 62
Joined: 14 Nov 2018, 14:39

Re: Flat spots & P1462

Post by pauljordanie »

Thanks, I did actuator test and EGR valve clicks.
Last edited by pauljordanie on 04 Jul 2020, 07:08, edited 1 time in total.

pauljordanie
Posts: 62
Joined: 14 Nov 2018, 14:39

Re: Flat spots & P1462

Post by pauljordanie »

I've disconnected the MAF sensor and the problems gone. Except MIL and depolution warning as expected. Can I take it that MAF needs replacing?

User avatar
myglaren
Forum Admin Team
Posts: 18201
Joined: 02 Mar 2008, 14:30
x 1034

Re: Flat spots & P1462

Post by myglaren »

You could try cleaning the MAF - handle it very carefully and don't touch the fine wires with anything, just use a few shots of a spray cleaner - I used carburettor cleaner that worked perfectly but there are dedicated MAF cleaners now.
Three years since I did mine and it is still OK.

moizeau
Donor 2020
Posts: 991
Joined: 12 Jan 2015, 17:08
x 131

Re: Flat spots & P1462

Post by moizeau »

Happy days

pauljordanie
Posts: 62
Joined: 14 Nov 2018, 14:39

Re: Flat spots & P1462

Post by pauljordanie »

I took the MAF off and cleaned. Put back on and problem comes back. Luckily my wife has a C4 GP with same engine so I swapped MAF over. Problem is still there. So I think the MAF is good and the info its giving to ECU is effecting something else.....

User avatar
Paul-R
Donor 2020
Posts: 4149
Joined: 07 May 2009, 16:24
x 427

Re: Flat spots & P1462

Post by Paul-R »

pauljordanie wrote:
05 Jul 2020, 10:58
Luckily my wife has a C4 GP with same engine so I swapped MAF over. Problem is still there.
Almost more importantly, is the problem not there on your wife's car with your MAF?

pauljordanie
Posts: 62
Joined: 14 Nov 2018, 14:39

Re: Flat spots & P1462

Post by pauljordanie »

Swapped suspect MAF onto wife's car. Problem isn't there so pit back on 308...since the code was associated with EGR throttle electrovalve I disconnected the electrical connector to that throttle on the dosser with the original MAF fitted. EML off problem not there....

Drove about 30 miles and EML came on but car runs ok.
Last edited by pauljordanie on 05 Jul 2020, 19:02, edited 1 time in total.

moizeau
Donor 2020
Posts: 991
Joined: 12 Jan 2015, 17:08
x 131

Re: Flat spots & P1462

Post by moizeau »

Mine was a dirty plug connector on the harness, not the actual MAF. I'm not sure of the pinouts to test the plug but I'm sure someone who knows will be along.