Erratic Bluetooth Connection in 2011 Dispatch van

This section is where Audio / Telematics Posts will be placed temporarily

Moderator: RichardW

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

I'm trying to figure out why the bluetooth in my van connects one day but not the next?
When it fails to connect automatically the screen showing the connection details is unresponsive. You cannot delete paired devices or 'interrogate' devices.
I appears to be very random? Does anyone know how to fix this issue?
Thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22618
Joined: 15 Sep 2015, 19:38
x 2341

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by GiveMeABreak »

The best thing to do is unpair the connection from both your phone's stored bluetooth connected devices and also from the head unit. Then try pairing the phone again.

User avatar
Sloppysod
Donor 2019
Posts: 564
Joined: 23 May 2015, 23:35
x 51

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by Sloppysod »

mikej101 wrote:
14 Apr 2020, 15:22
I'm trying to figure out why the bluetooth in my van connects one day but not the next?
When it fails to connect automatically the screen showing the connection details is unresponsive. You cannot delete paired devices or 'interrogate' devices.
I appears to be very random? Does anyone know how to fix this issue?
Thanks
Hi Mike, Just so you don't feel it's just you..........My C5 does the same, infact today I ended up locking the car for about 10 minutes, so the onboard systems go to sleep, then repairing my phone. On another note, apart from bluetooth not connecting, I also sometimes have problems accessing the USB drive, it's (the RD4 radio) got Gremlins!!

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Thanks for the response guys.
Marc, I have done that several times, once I even went to the lengths of disconnecting the battery for 15 mins. When I reconnected the battery the Bluetooth worked fine and I connected my phone. The following morning I jumped in van and the Bluetooth would not connect ! The following day whilst sat in the van pondering what to do with it, my phone rang and I answered it. Whilst in conversation with my son the Bluetooth 'just' connected ? I then started the engine and the Bluetooth disconnected and didn't again connect. It's so random it's getting annoying !
Stu - Glad you added your comments and I to have issues with the USB port. I have loads of music on USB sticks which usually just connects up as soon as I plug in the stick. The USB now does not actually work at all since this Bluetooth issue started.
I'm wondering if its a fault with the actual Bluetooth box in the dash?
I'll carry on with my investigations.....
Well, apparently my Apple iPhone 6Plus is not actually compatible with the 'connection box' in my van - that is according to the Citroen website ? :rofl2:
https://www.citroen.co.uk/about-citroen ... patibility
Why then did it work for ages and then start playing up ?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22618
Joined: 15 Sep 2015, 19:38
x 2341

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by GiveMeABreak »

That info should really be given a wide berth as it is generally so out of date as the bluetooth profiles are updated and firmware is released to correct issues with handsets and vehicle head units.

I have a 6 Plus which is not even on the list :roll: and it works faultlessly since day one on my C5 X7 with Navidrive 3D.

I really could do with knowing what head unit you have to start with (or a VIN even better) then I can have a look to see if there are any known issues.

Having said that, if this is for your dispatch, then it will very likely have a Fiat system on board as these are basically Fiat vehicles and these are known to have troublesome units - especially with the tracking units and other bumpf they bundle in there.

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Hi Marc,
VF7**************[VIN obfuscated, can be read by forum staff]
will that help?

I've PM'ed you

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22618
Joined: 15 Sep 2015, 19:38
x 2341

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by GiveMeABreak »

Hi Mike

Ok, so no weird Fiat stuff going on here, you have a standard RD4 head unit with a telephone interface kit and USB port.

So in this case you need to do the following:

1) Delete all the paired Bluetooth devices from both the RD4 / Handsfree Unit and the Phone.
2) Next, try and pair the phone searching from the RD4. If the result is the same, then again delete the bluetooth devices from the RD4 and your mobile again.
3) Next, attempt the pairing operation again, but this time search for the RD4 / Handsfree / Citroen device from the Mobile handset.

Go through these 2 stages in order - completely deleting all the pairings form both the RD4 Head Unit in your van and the iPhone first before attempting re-pairing.

The last option (3) seems to work for most people - initiating the pairing operation from the mobile phone end and searching for the Head Unit and not the other way round.

Make sure you have your iPhone software updated to 12.4.5, which is currently the latest software available for the iPhone 6 Plus at the time of posting.

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Thanks for the input Marc,
Right I've done just about all I can now.
I've found if I remove the power from the back of the radio for a few minutes the Bluetooth will connect to my phone automatically when the ignition is turned on. BUT as soon as I start the engine the Bluetooth drops and will not reconnect. The Bluetooth menu becomes unusable ! You can get access to 3 of the four functions but when you enter the functions, nothing responds. You cannot access the menu to delete paired devices, you cannot search for devices as that function is greyed out...., Could it be something to do with the van computer ? I'm totally fed up with it now !
Mike

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22618
Joined: 15 Sep 2015, 19:38
x 2341

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by GiveMeABreak »

So several possibilities. Your RD4 Head Unit does not contain the bluetooth hardware, you have a separate hands free kit module in the vehicle that is linked to the Multifunction screen which controls the RD4 Head Unit. So it is possible that the Hands free unit is faulty itself or there is a wiring issue somewhere. But whatever it is, it's likely to be somewhere between the Hands free module, the screen and the head unit.

Try a full BSI reset as a last resort BSI Reset / Battery Disconnect / Reconnect Procedure

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Hi Marc,
I already thought about the Bluetooth unit and bought one off Ebay. Put it in and the fault is exactly the same so I reckon you are right with something in the wiring. I just don't know where to start though. Did consider taking van into the dealers but frightened by the charges they might come up with and not fix the issue. I'll keep hunting for a solution. Cheers
Mike

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Follow up on this issue with Bluetooth not connecting.
So I bought another RD4 radio off Ebay just to prove one way or the other that it wasn't a problem with the radio.
Put the unit in van and it worked OK apart from the obvious beep.beep which I expected anyway.
Connected Bluetooth with engine off no problem. Started engine and bluetooth disconnected and would not reconnect. Exact same problem ?
Turn engine off and lock van, turn radio on without engine and it would connect to bluetooth same as before but as soon as engine starts it disconnects and will not reconnect.
Trying now to find some diagnostic kit that I can purchase to investigate further but not really confident that the kit available is going to work as it all says to use with Windows XP ! Obviously old kit !
Any further suggestions to solve this issue would be gratefully accepted.
Mike

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Marc,
Reading your guide on the system reset - how do I go about disconnecting the battery with all the doors shut when the battery is actually in the floor of the drivers side?
Do I sit in the van with door shut and do it that way ?
Your comments appreciated
Mike

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

Marc,
What's this Diagbox you keep refering to ?
Mike

mikej101
Posts: 9
Joined: 04 Apr 2020, 22:13

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by mikej101 »

OK. I've found out what you mean by Diagbox.
If I buy one of these devices Lexia 3 Evolution XS Full Chip Interface and Cables can I re-program the radio I bought to work in my van without it bleeping?
Thanks
Mike

User avatar
GiveMeABreak
Forum Admin Team
Posts: 22618
Joined: 15 Sep 2015, 19:38
x 2341

Re: Erratic Bluetooth Connection in 2011 Dispatch van

Post by GiveMeABreak »

Hi Mike

The VCI kit with Diagbox will enable you to programme your VIN code into the Head unit to prevent it beeping. It is a clone of the official diagnostic kit used by PSA for Citroen, Peugeot and DS vehicles. It will work on windows 7 or 10 (ensure it is installed on a 32 bit operating system if you are intending using the older Lexia or PP2000 encapsulated software for older vehicles pre-2008 era).

As for the BSI reset - if your battery is inside, then shut all the doors, but on the driver's door, manually flick the door latch to trick the car into thinking the door is shut.

However, I doubt it will be the head unit Mike as I said before.

You have a separate module installed that is the hands free / Bluetooth unit. This is installed behind the dash and is responsible for the bluetooth elements and talks to the head unit and display screen.

It looks like this:
Nomad.PNG
This unit was updated with a replacement part, so could of gone faulty on you. So if there is no joy with the BSI reset, nor with your new RD4 unit, I would suspect the bluetooth Nomad Unit.