Rain sensor not working on 308 T9

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Rain sensor not working on 308 T9

Post by mara- »

Hello,

My rain sensor is not working properly since I bought the car. I noticed that windshield is changed, but sensor is still there. Wiping is done very late, when you can't see anything from the rain.

I purchased token on servicebox and scanned the car. The following error is here:

B1174 95 - Installation incorrect

To me, physically everything looks fine, i removed the cover to check that sensor is present and plugged in.

I tried doing Initialization in Diagbox which is done when rain sensor or windshield is replaced. I get the error "ecu didn't respond" most of the time. Once I managed to get that initialization could not be performed. Strangely, I managed to update the rain sensor ecu since there was TSB for it, but it didn't help. Now it's behaving even worse, it's wiping intermittent every 10 second, like it's not using sensor at all.

When I checked Standard Parameter measures in Diagbox, it's showing fixed value for one of the rain sensor cells. To me it looks like it's stuck and detecting always the same amount of rain.

Any suggestion what could be wrong? Is the rain ecu = rain sensor? Should the sensor replacement cure the problem or something else could be the issue?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

Ok, so fault B117495 is Fault adaptation of the windscreen sensor impossible.

This means that the sensor cannot adapt to faults and this will therefore disable the rain sensor part, which is why it is in backup mode. So when this fault is active, the rain and brightness sensor does not measure the rainfall.

This can be caused by a downloading error of the calibration file.

Suspect areas are the rain and brightness sensor and / or the location on the windscreen of the rain sensor.

These are highly sensitive devices. I had my windscreen replaced on the C5 X7 and warned them about the sensor and that it must be functioning perfectly as it was before they started the job. Sure enough, they reused the old sensor and it was not the same - worked at only about 30% efficiency, so complained, ordered the correct sensor and they paid for it (£250) and fitted a new one for me.

So it's possible that if the windscreen on your 308 has been replaced, and they have reused the old sensor- it may have got air bubbles in / or gone opaque and therefore the signal is impaired.

If this is the case, it is also possible that when you tried to calibrate the sensor doing a download, that it could not properly calibrate because of the faulty sensor. I've often found that these sensors have to be replaced (depending on type) or at the least a new gel pack applied (for some sensors).

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Thanks for the reply. Visually sensor look strange, like some stains in one part and that might explain it. And yeah, new sensor is really expensive. Indeed, this backup mode started after updating the ECU, I guess because it could not calibrate/initialize it as you said. Before update it probably had old calibration but didn't work anyway properly, that's why I tried with the update.

Luckily, it seems that light part still works fine since auto lights work fine.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

Here's the sensor - 2 examples
Sensor A.PNG
Sensor B.PNG
This one Is how it should look - nice and clear.Here's a bad example - all the glue and debris
- the sensor area is probably opaque and not much good.

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Yeah. But, it seems I messed up the lights now with the ECU upgrade. They are always on, even in daylight. Didn't know that until this morning, it was night when I did the upgrade. Do you think I can do anything now regarding that except replace the sensor?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

What ECU did you upgrade? The BSI? Be aware that some clones are not suited to performing updates to ECUs - they have been known to leave them in an unconfigured state. I would NEVER attempt any ECU update with a clone interface - leave that to the dealer who can do it directly from the servers and several times is often necessary in some cases and even then, the original configuration has to be checked against the vehicle's options to ensure all the equipment corresponds correctly to what you have on the vehicle.

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Not the BSI. The rain sensor ECU. Yes, I did it with the clone, full chip. I bought the token from servicebox and downloaded official Diagbox.

This is my brothers car, we have the same car and that might be the issue. Since I bought only one token, for my VIN, I used mine VIN on his car for the rain ECU since I sow it was the same Hella ECU. Interface is not the issue for sure, I even did the engine ecu upgrade on my car successfully, no issues. But, it could be that some wrong configuration is in the rain sensor ecu now.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

That extra information is important....

There are 2 variations of electronic architecture on the 308 T9, Full Multiplexed AEE2010 and Economy Multiplexed AEE2010.

Each have different CAN networks and on the full AEE2010 there are more data networks than on the other version. Secondly, one version uses the engine fuse box for certain functions to do with the lighting and wiping where the other version goes directly via the BSI (it's more complex and uses other components - too much to go into here).

So it is very important that when you are downloading or configuring an ECU - that you MUST use the VIN for the specific vehicle needing the download.

This is probably your issue, as if the other vehicle has different options or a different electronic architecture, then the software may be different for the ECU and it may also update the BSI as well as the Rain / brightness ECU. It's why the correct VIN must always be used to avoid mis-configuration. This can brick an ECU if not careful.

I suggest you try again with the correct VIN and see if it will allow the new calibration / update to take place.

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Yeah, it was fullish from me now when I think about it. I though that sensor is not so complex and it would work. I would not try with any other ECU for sure. Brother has Active equipment, mine is Allure. I think he has Economy architecture since I could not activate corner lights on his and could on mine. I'll check the price at the dealer and decide what's the cheapest option. Token is 42€ for one VIN.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

Ok, so here's my thoughts for what it's worth:

Example 1) If you pay the dealer to do it, they will charge you their standard diagnostic time (maybe €90 Euros) - advantages are that they will have the correct kit and software to do it and can do it as many times as they need to get the update - if you are asking them to do this job specifically. Worst case scenario is they tell you the sensor is now useless and needs a new one. Best case scenario - they calibrate it and job done, lesson learned.

Example 2) If you decide to have another go and purchase a token again for the correct VIN this time, chances are that it may work - problem solved and you save yourself at least half of what the dealer may charge. The worst case is that it will not update because either the sensor is kaput, or because the clone VCI can't update it (clone unit) and then you have wasted €42 and will have to pay the dealer to do it in example 1 costing you more.

Example 3) Live with it and use manual lighting and wiping. :-D

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Thanks for your opinion. I'm from Bosnia, dealer is not so expensive as in other countries, at least for service parts (but still expensive for the standard here), parts are different story.

According to this TSB, time they need is half an hour. They charge 25€ per hour for service, so my estimate is 12.5€, but we'll see when they respond to my email.

Third option is a must now. I could live without the wipers, but lights are the problem because of the law, I could forget to turn it on.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

No law in Europe to say you have to have auto lights that I'm aware of :-D But they have to have a backup manual system which is fine - but the car will remind you anyway - from your manual:
An audible signal when a front door is opened warns the driver that the vehicle's exterior lighting is on, with the ignition off and in manual lighting mode. In this case, switching off the lighting stops the audible signal. With the ignition off, if the dipped headlamps remain on, the vehicle goes into "ECO" mode to avoid discharging the battery.

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

Yeah, but I'm afraid of forgetting to turn on lights in the evening because I am so used to auto, and sometimes people forget because of street lights.

Anyway, I overestimated. :rofl2:

Dealer says 7€ for the procedure in TSB, which is basically rain sensor ecu update. I'll try to do it tomorrow and report back with results.

mara-
Posts: 60
Joined: 26 Feb 2018, 20:05
x 5

Re: Rain sensor not working on 308 T9

Post by mara- »

No luck with the dealer. They also can't calibrate it, same error.

Question, if you know. I found online the original and new rain sensor with same part number as on servicebox for the specified VIN, but, on the servicebox there is a note: "Specify the VIN when ordering". So, what's the deal there? This seller online sells it considerably cheaper, around 80€, and dealer is asking 200€.

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19524
Joined: 15 Sep 2015, 19:38
x 1886

Re: Rain sensor not working on 308 T9

Post by GiveMeABreak »

The sensor will need calibrating and may or may not need configuring to the type of vehicle (hence specifying the VIN on ordering) or if not coding / calibrating after fitting.

There's no guarantee if you fit a used sensor that it won't need calibrating or configuring if it not from an identical vehicle as your own.