Coolant problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

zalman
Posts: 2
Joined: 19 Jul 2019, 09:39

Coolant problem

Post by zalman »

Hello All,
My car is Citroen C5 2007 2.0 petrol,automatic.
In the morning when i turns on the cold engine i have the following problem : coolant temperature gauge is immediately on top red and cooling fan comes on. The car barely carrying.
Anyone know the problem and how to cure it ?

User avatar
GiveMeABreak
Forum Admin Team
Posts: 19412
Joined: 15 Sep 2015, 19:38
x 1869

Re: Coolant problem

Post by GiveMeABreak »

It's probably the engine coolant temperature sensor that's faulty.

User avatar
white exec
Moderating Team
Posts: 5849
Joined: 21 Dec 2015, 13:46
x 950

Re: Coolant problem

Post by white exec »

That's what would happen if the temp sensor was disconnected.
Could either be a poor connection, or (as Marc says) a faulty sensor. Easily replaced.

User avatar
xantia_v6
Forum Admin Team
Posts: 7204
Joined: 09 Nov 2005, 23:03
x 374

Re: Coolant problem

Post by xantia_v6 »

I think by that date there would only be a single temperature sensor which also feeds the engine ECU, which would get quite upset not having a valid temperature. I think that the problem may lie elsewhere, perhaps in the A/C system. You really need to have the fault codes read to know what is going on.

zalman
Posts: 2
Joined: 19 Jul 2019, 09:39

Re: Coolant problem

Post by zalman »

Thanks for all the replies.