Coolant problem

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

zalman
Posts: 2
Joined: 19 Jul 2019, 09:39

Coolant problem

Post by zalman » 19 Jul 2019, 09:56

Hello All,
My car is Citroen C5 2007 2.0 petrol,automatic.
In the morning when i turns on the cold engine i have the following problem : coolant temperature gauge is immediately on top red and cooling fan comes on. The car barely carrying.
Anyone know the problem and how to cure it ?

Online
User avatar
GiveMeABreak
Forum Admin Team
Posts: 16825
Joined: 15 Sep 2015, 19:38
x 1569

Re: Coolant problem

Post by GiveMeABreak » 19 Jul 2019, 10:14

It's probably the engine coolant temperature sensor that's faulty.

User avatar
white exec
Moderating Team
Posts: 4679
Joined: 21 Dec 2015, 13:46
x 629

Re: Coolant problem

Post by white exec » 19 Jul 2019, 13:23

That's what would happen if the temp sensor was disconnected.
Could either be a poor connection, or (as Marc says) a faulty sensor. Easily replaced.

User avatar
xantia_v6
Forum Admin Team
Posts: 6716
Joined: 09 Nov 2005, 23:03
x 327

Re: Coolant problem

Post by xantia_v6 » 19 Jul 2019, 14:02

I think by that date there would only be a single temperature sensor which also feeds the engine ECU, which would get quite upset not having a valid temperature. I think that the problem may lie elsewhere, perhaps in the A/C system. You really need to have the fault codes read to know what is going on.

zalman
Posts: 2
Joined: 19 Jul 2019, 09:39

Re: Coolant problem

Post by zalman » 20 Jul 2019, 13:02

Thanks for all the replies.