2002 Citroen Xsara 5DR hatch - Rear washer not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

AdieuHydropneumatic
Posts: 19
Joined: 27 Feb 2019, 22:13
x 2

2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by AdieuHydropneumatic »

2002 Citroen Xsara 5DR hatch - Rear washer not working

Dear Board,

Front wash/wipe works fine. Rear wash was intermittent then stopped completely. Rear wiper works fine.

After looking about on internet, it seems front & rear wash works off one pump & one reservoir under main front off side chassis member & behind wheel arch lining. Also it seems sometimes the flow reverse bit of the pump sometimes sticks. So I bought a new pump and asked my local garage to fit it whilst doing a service.

Seems I jumped the gun as new pump made no difference (although it sounds a lot healthier) Garage reckons its the stalk switch at fault as there is no pump noise when its twisted but rear wiper responds.
Probably a coincidence but on the audio control stalk just below the wipe control stalk, the search button on top of this stalk doesn’t work, that is you can only search radio stations in one direction.

Any help would be much appreciated.
Cheers
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28938
Joined: 15 Sep 2015, 19:38
x 3594

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by GiveMeABreak »

Possibly your comms unit has / is failing. They can also affect headlights, indicators and the like when they go on the blink.

I have your VIN so I'll check out the parts for you....

Ok, so assuming you have front fog lights as there are 2 options of units for your car. I think you do have front fogs - but do let me know as the VIN does not state (age).

The Comms unit is part number: 96787362XT
The audio stalk itself is 6242Z6
Xsara Comms.PNG
Here's a link to a supplier - they sell both new units and refurbished ones, £160 and £90 respectively.

https://peugeotpartsforsale.com/index.p ... egory_id=0

You don't have a steering wheel angle sensor to worry about as you have no ESP system. But be wary of Airbags - always disconnect the battery and wait 15 minutes for capacitor to discharge before doing any work on the steering wheel.

Procedure here:

Battery Disconnect / Reconnect Procedure

The fault in the audio stalk may be related to the comms unit. With the comms unit you generally retain the additional cruise control (where fitted) and audio stalks to fit into the replacement comms unit - they just clip in. So I wouldn't go ordering an audio stalk at this point until you are happy that it is the comms unit.

Unfortunately, a diagnostic rarely brings up faults with the comms unit as the issues are intermittent. But most common stalk issues, including wiping and lights are comms unit related.
AdieuHydropneumatic
Posts: 19
Joined: 27 Feb 2019, 22:13
x 2

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by AdieuHydropneumatic »

Hi Marc and thanks again!
Front fogs are integrated into main light unit not separate on/under bumper
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28938
Joined: 15 Sep 2015, 19:38
x 3594

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by GiveMeABreak »

Ok, so as long as you have the option on the lighting stalk for fogs and that these do operate, then we are good to go with that part number.
AdieuHydropneumatic
Posts: 19
Joined: 27 Feb 2019, 22:13
x 2

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by AdieuHydropneumatic »

Hi Marc and thanks again for your detailed help.
As its a minor fault and so I understand, not an MOT issue, as well as the cost of part, I'll just put up with it for now.
Thanks again
Cheers
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28938
Joined: 15 Sep 2015, 19:38
x 3594

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by GiveMeABreak »

No, fogs are only tested on cars for vehicles first used from 1st March 2018 on the UK MOT.
AdieuHydropneumatic
Posts: 19
Joined: 27 Feb 2019, 22:13
x 2

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by AdieuHydropneumatic »

Dear All
Have just replaced main battery and then did a BSI reset as set out by GiveMeABreak Marc. The rear wash is now pumping!
Thanks Marc!
User avatar
GiveMeABreak
Forum Admin Team
Posts: 28938
Joined: 15 Sep 2015, 19:38
x 3594

Re: 2002 Citroen Xsara 5DR hatch - Rear washer not working

Post by GiveMeABreak »

No worries - glad you can now see out your rear window again :-D