Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 30 Jun 2019, 11:56

The car has done 178000 miles and runs very nicely still.

It has an intermittent problem which only came up about once a week (car was used daily) but now happens at least 2 or 3 times on every journey.

You are driving along quite happily and all of a sudden the car decelerates. If you press the accelerator pedal down there is no response, it continues to lose speed. If you then release the pedal and the push it down again it responds normally and car runs normally. It can happen across all the gears.

I’ve stopped using the car now as it’s dangerous especially as you pull off a junction or roundabout and a few yards later it loses acceleration as explained above.

On one occasion I couldn’t get the power to engage again and ended up coasting down a slight incline and into a parking space - I was lucky.

I have replaced the throttle position sensor with a new one but this has had no effect.

I have used Lexia but there are no fault codes reported.

Is there another sensor on the accelerator pedal itself?

I’ll be grateful for any suggestions!

Thank you in advance..

User avatar
GiveMeABreak
Forum Admin Team
Posts: 16825
Joined: 15 Sep 2015, 19:38
x 1569

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by GiveMeABreak » 30 Jun 2019, 12:08

VIN please..... There were 2 types of system fitted depending on build date. - FLy by wire and a mechanical cable type. Once we have the VIN we can determine what you have.

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 30 Jun 2019, 12:24

Thank you Marc

The vin number is VF7**************[VIN obfuscated, can be read by forum staff]

There is a cable linked to the throttle position sensor, I guess coming from the pedal

User avatar
GiveMeABreak
Forum Admin Team
Posts: 16825
Joined: 15 Sep 2015, 19:38
x 1569

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by GiveMeABreak » 30 Jun 2019, 14:31

Well that wasn't really much help unfortunately as either type could be fitted - so you'll have to do a visual check to see which you have:
C5 22 Accelerator A.PNG
C5 22 Accelerator B.PNG
Electronic TypeMechanical Type with Cable
None of the accelerator pedals are available from Citroen now (NFP)

So I would expect some sort of code to be stored if it is loosing speed - unless the accelerator pedal is faulty (assuming the electronic one) and that it is just thinking you have removed your foot off the pedal so is slowing down. So a careful check of its condition may be in order - but honestly I don't think there is much you can do if the tracks have or are beginning to wear on it, short of replacing it. If it was engine related - again I would expect a code.

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 30 Jun 2019, 14:43

I guess 5 in the mechanical diagram is the cable going in to the throttle position sensor from the pedal?

I’m not with the he car now but I did remember having re attach a cable to the throttle position sensor when I changed it.

There were no faults shown in Lexia at the time though I will check again during the week.

I’ll try to source a used part off eBay to see if that makes a difference.

The car just slowed down without me moving my foot. Pressing down had no response. Releasing the pedal and then pressing down caused it to work again. (Except the one time I mentioned in first post)

Thanks Marc

User avatar
GiveMeABreak
Forum Admin Team
Posts: 16825
Joined: 15 Sep 2015, 19:38
x 1569

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by GiveMeABreak » 30 Jun 2019, 14:49

No worries - yes the wire will work on similar TPS in the engine.

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 01 Jul 2019, 15:21

I’m drawing a blank.. tried a second throttle position sensor.. still having the problem.

It’s the mechanical system that’s fitted to my car.

Bloke at the scrapyard suggested could be a diesel pump, turbo or ecu problem, where the ecu is detecting a build of pressure in the turbo and momentarily shutting down fuel for protection hence the deceleration.

Once the gas is off, pressure subsides and then car responds to pedal again. I’m not so sure if to believe or not.

Does anyone have any other ideas?

I’ve again hooked it up to Lexia but cannot see any faults, temporary or permanent.
Last edited by chasqui on 01 Jul 2019, 15:23, edited 1 time in total.

User avatar
myglaren
Forum Admin Team
Posts: 16450
Joined: 02 Mar 2008, 14:30
x 575

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by myglaren » 01 Jul 2019, 15:22

Have you looked at the throttle stepper motor?

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 01 Jul 2019, 15:24

No! Never heard of the stepper motor,, where is it? I’ll have to research!

User avatar
GiveMeABreak
Forum Admin Team
Posts: 16825
Joined: 15 Sep 2015, 19:38
x 1569

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by GiveMeABreak » 01 Jul 2019, 15:25

Did you tun a full global diagnostic on it and is it detecting ALL ECUs?

User avatar
myglaren
Forum Admin Team
Posts: 16450
Joined: 02 Mar 2008, 14:30
x 575

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by myglaren » 01 Jul 2019, 15:27

chasqui wrote:
01 Jul 2019, 15:24
No! Never heard of the stepper motor,, where is it? I’ll have to research!

Not certain but presumably on the throttle body.
Marc will know :)

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 01 Jul 2019, 15:52

GiveMeABreak wrote:
01 Jul 2019, 15:25
Did you tun a full global diagnostic on it and is it detecting ALL ECUs?


Yes.. all ecu’s detected..

Global test done.

chasqui
Posts: 44
Joined: 02 May 2009, 12:02
x 1

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by chasqui » 01 Jul 2019, 15:52

myglaren wrote:
01 Jul 2019, 15:27
chasqui wrote:
01 Jul 2019, 15:24
No! Never heard of the stepper motor,, where is it? I’ll have to research!

Not certain but presumably on the throttle body.
Marc will know :)


I’ll explore that. Thanks

Nemo26
Posts: 59
Joined: 19 Apr 2017, 09:26
x 3

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by Nemo26 » 01 Jul 2019, 16:16

You should hook up your tester and do some diagnostic while driving.

User avatar
mickthemaverick
donor 2019
Posts: 880
Joined: 11 May 2019, 17:56
x 257

Re: Accelerator pedal intermittent no response - C5 2003 2.2 hdi MK1 manual

Post by mickthemaverick » 01 Jul 2019, 16:48

Sounds like the car thinks its in cruise control and you have pressed the -set button and then the throttle will pick up again. So does it have cruise?