Parking sensor dosn't work

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Sufii
Posts: 81
Joined: 13 Nov 2018, 00:01
x 3

Parking sensor dosn't work

Post by Sufii »

Hi again guys

On my Citroen C5 2009 model, the rear and front parking sesnors dosn't work. I had the car diagnosed with the fault codes:

BC7: Rear left inner parking aid sensor
BC8: Rear right outer parking aid sensor

I ordered two sensors from ebay, but I dont know witch ones has to be replaced?
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

When there is a fault with any of the sensors, the whole system is deactivated until the fault or the faulty sensor is replaced.

I've marked the ones in question here in red for you:
X7 Parling B.PNG
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

There is a way to test these - if you switch the ignition on and put the car in reverse, gently and lightly place your finger just above the sensor a few millimetres away from the sensor - you should feel a slight pulsing from each sensor - those that pulse should be working, those that aren't are likely to be faulty - but the surest way is a diagnostic, which you have done - so replace those 2 first.
Sufii
Posts: 81
Joined: 13 Nov 2018, 00:01
x 3

Re: Parking sensor dosn't work

Post by Sufii »

Thank you very much! You saved me once again. I'm waiting on the correct replacement parts, I will post pictures and the results on every post.
Sufii
Posts: 81
Joined: 13 Nov 2018, 00:01
x 3

Re: Parking sensor dosn't work

Post by Sufii »

SOLVED! Replaced those two sensors , ordered them from Ebay. Works fine now!
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

Good - another result.
User avatar
Paul-R
Donor 2020
Posts: 5401
Joined: 07 May 2009, 16:24
x 789

Re: Parking sensor dosn't work

Post by Paul-R »

Excellent. Which ones from Ebay as a matter of interest?
Sufii
Posts: 81
Joined: 13 Nov 2018, 00:01
x 3

Re: Parking sensor dosn't work

Post by Sufii »

User avatar
Paul-R
Donor 2020
Posts: 5401
Joined: 07 May 2009, 16:24
x 789

Re: Parking sensor dosn't work

Post by Paul-R »

Ta. I wonder what the Citroen price for that would be!
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

£123 for the unpainted ones (non-painted)


£66.84 for the primed one (ready to be painted)
Sufii
Posts: 81
Joined: 13 Nov 2018, 00:01
x 3

Re: Parking sensor dosn't work

Post by Sufii »

Will never buy something directly from Citroen.
tapkaJohnD
New User
Posts: 2
Joined: 11 Feb 2021, 14:33

Re: Parking sensor dosn't work

Post by tapkaJohnD »

Reviving this thread, as I have had the opposite result!

I have a 2011 C5 tourer, and the reversing system failed. I found out about the 'pulsing', but it's not so easy to check as it's a two man job, one in the drivers seat selecting reverse with the engine on, and their foot on the clutch - the system will not engage if engine not running - and one trusting perosn behind listening to the sensors. I say listening, as I used a mechanics stethoscope. And one was faulty, so like the OP above, I bought a new one off eBay, £19, identical in every way. Lovely Jubbly, I've thwarted the exorbitant charge that a dealer would make!

Except the system STILL didn't work! And the new sensor was still silent. I moved it to another position - the old one worked in the faulty one's original position, but the new one didn't, so a wiring fault seemd unlikely, but I was at the limit of my car repair knowledge, and took it to my local independant garage. Who checked again, and asked where the new sensor had come from. Then he shocked me - he said that Citroen, and other manuafacturers, use identical parts to those available on eBay, but have them 'tagged' so they will only work on their vehicles and an untagged item won't. Such arrogance must be expected, but the real shock was the price of a "genuine" Citroen part - £119!!

I gave him the work, and it works. So either I bought a faulty part, or he was right, and Citroen are profiteers of the worst sort!
Can anyone confirm this tale?

JOhn
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

That's the biggest load of baloney I've ever heard. :rofl2:

You need a new mechanic I think.

Sensors are available on the aftermarket - but you do have to watch the brand and quality as they are not all the same. There are 2 major manufacturers of these sensors - Siemens VDO and Schraeder - both of which were used on the C5 X7. Of course there will be cheaper versions - but you get what you pay for. A TPMS sensor battery typically lasts 10 years or even longer - so with an original OEM unit you will expect to pay a bit more - but even these can be bought for less of you look around. However, if you buy unbranded stuff from the Far East, I would not be surprised if there were problems with pairing and or longevity.

As for the test - you don't need 2 people, just leave the ignition switched on and the car in reverse, then you can go and gently feel the sensors for a slight pulsing effect.

Also, be aware that water can be thrown up onto the sensor plug wiring and on some occasions can roll back into the sensor causing intermittent operation.
tapkaJohnD
New User
Posts: 2
Joined: 11 Feb 2021, 14:33

Re: Parking sensor dosn't work

Post by tapkaJohnD »

GMaB
Thank you for your wise words.
However, and perhaps your excuse is an older/diferent version of the car/system, but I can assure you that on my car, the system does not engage and the sensors don't work, unless the engine is running. I tried testing the reversing warning before I sought an assistant.
Water on the sensors, Gosh! I would never have thought of that, where they are installed in the rear bumper, even after seen the amount of mud lodged there.

Are you usually as agressive to new members?
John
User avatar
GiveMeABreak
Forum Admin Team
Posts: 25418
Joined: 15 Sep 2015, 19:38
x 2832

Re: Parking sensor dosn't work

Post by GiveMeABreak »

Really - Aggressive :?:

I can't see anything aggressive in my post to be honest, maybe you are being over-sensitive.

I had the same vehicle, a little earlier with front and rear assistance, so know that the test works on my vehicle - although if your car has gone into economy mode, it may not work of course.

As far as water can affect the sensors - yes, I speak from extensive experience on all 3 MK I, MK II and MK III C5s I have owned. Water can get up behind the bumper and if the wiring has become unsecured or is hanging in a certain way, any water can run back down the wire and into the sensor module itself causing the intermittent issues.

With this system, it is all or nothing - if any one sensor goes then the system does not work for safety reasons.

The other possible issue apart from a faulty sensor is that the ECU itself has been knocked, or has a bad connection in the wiring plug, or has had some liquid spilled onto the module that is causing problems, for which this also had that happened to me too after 5 litres of screen wash leaked into the boot floor and got into the ECU. It took several weeks to clean and dry it out.

These are just possible answers - but of course the best thing is to have it diagnosed properly with an appropriate diagnostic tool like Diagbox that will provide a fault code(s) and will help determine the cause.