RNEG/ENEG2 Swap Problem

This unit is the eMyWay system, also referred to as RT6, RNEG2, or WIPNAV+ for the Peugeot platform and made by Magneti Marelli.
Main Features: The eMyWay colour satellite navigation has high resolution mapping, Bluetooth Telephone & Audio Streaming supported profiles, USB support for Media files & CD

Moderator: RichardW

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

RNEG/ENEG2 Swap Problem

Post by goggi10 »

Hi guys,

I have finally menage to swipe in my Citroen C5 X7 2012 RNEG with RNEG2 eMyway. But after swap when i turn on radio i can hear music but i have constant beeping and its very loud. One info i have just swap radio and display do i need to do some bsi changes and which one.

Can someone help me out.

Thanks

Online
Hell Razor5543
Donor 2021
Posts: 11681
Joined: 01 Apr 2012, 09:47
x 1398

Re: RNEG/ENEG2 Swap Problem

Post by Hell Razor5543 »

You need to 'introduce' the radio to the car. When the original radio was fitted at the factory the systems were informed as to serial numbers, and so they were 'part of the same team'. Now you have a different radio (and to put off thieves) you are getting the beeping every couple of seconds.

I had to replace the radio on my C5 Mk1. When I did it also was beeping. I managed (as I have a Lexia clone) to sort this out (probably through the radio diagnostic pages in the Lexia software), and the noise died mid-beep, and has never happened since. However, I cannot remember exactly what I did, as it was well over two years ago.

User avatar
EDC5
Donor 2020
Posts: 1216
Joined: 01 Jul 2017, 21:48
x 104

Re: RNEG/ENEG2 Swap Problem

Post by EDC5 »

That is correct. The new head unit must have the VIN of your car programmed into it. You will need access to Diagbox/Lexia to do this.

Bjornar
New User
Posts: 1
Joined: 14 Oct 2018, 19:02

Re: RNEG/ENEG2 Swap Problem

Post by Bjornar »

Hi

Please forgive for asking before introducing myself to the forum, but did you manage to get rid of the beeping?

I've done a swap from RNEG1 to RNEG2 / rt6 on my 5008 too, but my local dealer claims they can't get contact with the unit from their system to code the VIN (which they charged me about £40 for).

Thanks!

Bjørnar

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

There will likely be some other options that need to be coded or checked too, as if it is a second hand unit, it will likely have options programmed in from the previous car.

In either case of the VIN and the programming, it will have to be done via Lexia / PP2000.

You will have a problem if the ECU cannot be accessed to reprogram it.

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

Re: RNEG/ENEG2 Swap Problem

Post by goggi10 »

I have sucssefully register new unit to bsi via lexa i jave enabled all parking sensors only 2 thing are anoying to me and i can finde the option first scroll on the rigt sidw of wheel doeant work i cant scroll between station and second thing when i dimm light in car all orange light is dimmed in all car but 9n rt6 unite they are not doea sombody know whay and wherw to change this

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

Sorry Goggi - I really didn't understand much of what you said there - can you try and be precise, then use Google Translate as English clearly isn't your first language.

I think you say you have coded the VIN ok, but are having some other issues with the scroll wheels? What functions are you trying to operate?

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

Re: RNEG/ENEG2 Swap Problem

Post by goggi10 »

Sorry i have typed while i was in store hahahahah. I coded via lexia almost evrything but two funcrion is missing and i can find it. 1st one on the right side of wheel next to back butun you have a scroll and with that scroll i could scroll trough radio station when i click list buttun on the wheel but now after rneg rneg2 swipe that scroll doesnt work and when i click list on the wheel it doesnt show list of radio station.
2nd thing when you are dimming ambient ligjt all ambient light in car is dimming but only at rneg unit button light is bright and it doesnt dimming.

Do you maybe know the sution for this.

Thanks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

Have you changed any other settings in Diagbox that you perhaps should not have? I only say this as some options that are there are not intended for the X7’s configuration. For example the BSI has options for other cars that display information differently - and if these are changed, they can cause problems with the X7 controls and display.

The best thing to do is to take screen shots of each area if the settings in Diagbox, and I will have a look at these to compare with what they should be.

Areas to focus on are the RNEG2 ECU settings of course, but also the instrument panel settings too.

I will have a look through he configuration settings for the RT6 that I have, but can you please post up your VIN so I can determine the correct settings for the options on your car

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

Re: RNEG/ENEG2 Swap Problem

Post by goggi10 »

Hi

My vin is BL562351. With lexia i have registred my vin to the head unit, i have enabled vidwo mod (which doesnt work i will shut it off) and i have enabled front + rear parking sensors which i have but the didnt worked when i put RNEG2 unit in. Do i have to change something else. I dont like to use mira scripts.

Thamks

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

Yes don’t do anything with Mirascripts yet as you might make it harder to troubleshoot. Before any ‘mods’ you need to get the basics working first. Can you post the FULL 17 digit VIN please.

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

Re: RNEG/ENEG2 Swap Problem

Post by goggi10 »

VF7**************[VIN obfuscated, can be read by forum staff] i found out that my RNEG2 is 2015 unit

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

Ok, here are the configuration tables for the RT6: Note I have marked the correct values for your car in green.

Note: For anyone else reading this - the settings below are specifically for a C5 X7 and for the specification of the OP's vehicle only!
  • USB Socket Setting in Yellow - you should of fitted this as part of the upgrade - as this setting is required although you did not have the USB originally.
  • Items I have highlighted in Red: You must set these to the values I have marked. It does not mean you don't have A/C or Cruise Control - it is only concerning the Head Unit ECU.
  • Items marked with a (2) in the end column must NOT be changed with any other value!
Configuration of the Customer Options
Parameter to be ConfiguredValues to be ConfiguredComments
CD PlayerAbsent
Present
Absence CD Changer
Presence Of CD Changer
HIFI AmplifierMultiplexed Amplifier
Electronic Amplifier
Presence Of A Bass Box
Absence Of A Bass Box
USB SocketPresent(2)
Auxiliary Audio InputPresent(2)
Auxiliary Video InputAbsent
Present
No Reversing Camera
Presence Of A Reversing Camera
Video Input From The Reversing CameraAbsent
Present
(1)
Fold-Away Multifunction ScreenAbsent(2)
Type Of Steering Wheel ControlsCondition 2(2)
Parking AssistanceAbsent
Present Rear
Present Front & Rear
Without Parking Assistance
Presence of Proximity Sensors
in the Bumper (Rear)
Presence Of Proximity Sensors
in the Bumpers (Front & Rear)
Air ConditioningAbsent(2)
Presence Of The Fold-Away Multifunction ScreenAbsent(2)
Multifunction Control PanelAbsent(2)
Cruise ControlAbsent(2)
Noise Level Linked To Vehicle SpeedActive(2)

Configuration of the Audio Functions
Parameter to be ConfiguredValues to be ConfiguredComments
Geographical Area Of UseEurope
JAPAN
South America
Asia And China
Arab Countries
(1) According To Country
AM WavebandActivated(2)
Fader FunctionActivated(2)
Number of Radio Aerials2(2)
Type Of Antenna FM1/AMActive Aerial(2)
Type Of Antenna FM2Active Aerial(2)
Digital RadioDigital Radio Deactivated(2)
Bluetooth Streaming FunctionActivated(2)

Configuration of the Other Functions / Personalisation Options
Parameter to be ConfiguredValues to be configuredComments
Display of the External TemperatureDisplaying Activated(2)
Temperature UnitDegrees Celsius(2)
Time DisplayDisplaying Activated(2)
Display of Languages & UnitsDisplaying Activated(2)
Choice of Imperial Units for Trip Computer & NavigationMetric(2)
Speed Threshold for Locking of the Main MenuDeactivated(2)
Displaying of Alerts & "Hazardous Areas" on the Multifunction ScreenDisplaying Activated(2)
Display of the Speed LimitDisplaying Activated(2)
Display of Audio Information on the Instrument Panel & on the Head Up DisplayDisplay off(2)
Displaying of the Navigation InstructionStatus Displayed on the Instrument Panel Matrix Display(2)
Type of Intersection Zoom In the Instrument Panel Matrix16 Segments, With Street Names(2)
Displaying of the Status LogDisplaying Activated(2)
Displaying of the Warnings LogDisplaying Activated(2)
Display of the Personalisation MenuDisplaying Activated(2)
Trip Computer FunctionFunction Deactivated(2)
Specific Welcome PageStandard Page
Standard Stop & Start Page
Without Stop & Start
With Stop & Start
Selection of the Marque Logo for the Welcome PageCitroën(2)
Suspension IHMDeactivated(2)
Preferred SID (Automatic TMC Station)France(2)
Display of Vehicle Warning MessagesDisplaying Activated(2)
Separate Control KeypadAbsent(2)

goggi10
Posts: 36
Joined: 04 Feb 2017, 15:40

Re: RNEG/ENEG2 Swap Problem

Post by goggi10 »

Thanks m8 i own you a dring as soon as i get nack im Serbia i will send you vie pay pal or western union to have a drink.

Many thanks. Pm me how i can send you a treat

User avatar
GiveMeABreak
Forum Admin Team
Posts: 24442
Joined: 15 Sep 2015, 19:38
x 2671

Re: RNEG/ENEG2 Swap Problem

Post by GiveMeABreak »

No problems, but you may still have an issue - but at least getting the settings correct is the first step. Then you can try a BSI reset afterwards, which may reinitialise the BSI after all these configuration changes. No guarantees though :-D
  • Open bonnet and Driver side window.
  • Ensure all doors are closed and remove key from the ignition
  • Wait for 5 minutes, then disconnect the vehicle battery negative and wait at least 5 minutes. Don't open any doors or press any buttons.
  • Reconnect the vehicle battery, wait a further 3 minutes (do not open doors).
  • Switch on the side lights through the driver's window.
  • Switch on the ignition only, don’t start vehicle yet and check system's functionality.
  • With key still in ignition hold lock button on key down for 5 seconds.
  • Remove key through window, then operate Central locking several times.
  • Now open door and start the engine and complete the system's check.
  • Failure to follow this procedure could result in incorrect operation of many BSI related items.
goggi10 wrote:
20 Oct 2018, 10:32
Thanks m8 i own you a dring as soon as i get nack im Serbia i will send you vie pay pal or western union to have a drink.
Many thanks. Pm me how i can send you a treat
I give my time freely, but if anything has helped, you might wish to consider a small donation to the Forum, which helps keep it running without adverts - details here (plus you will get some free FCF stickers too): :-D

Donate Here