C4 heater/air con not working

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

usticm
Posts: 2
Joined: 06 Feb 2021, 10:28

Re: C4 heater/air con not working

Post by usticm »

Hi all. new to the forum. I have what appears to be a common problem and that is that my heater blower is not working. After advice from the local dealer, I've replaced the resistor and blower .. and it still doesn't work. I'm then advised that the fusebox is at fault. New fuse box circa £320. Car is 2006 C4 1.6 Petrol.. Whilst at the dealer, they did what I could only describe as linking a wire I assume from a positive feed to one side of the blower fuse and demonstrated that the heater works.. and the fault was the fusebox. Whilst I decide on what to do with the fusebox, could someone advise/confirm the the wiring trick so that I can get my blower working for now. I will run whatever through another fuse to be on the safe side.

With reference to the fusebox, having removed it to check the part numbers etc, I can see the following:

9658539680
BSM-L06-00
S118983006M

When searching the web.. I can find similar units available but not anything that matches all 3 sets of numbers. What I'd like to know is if I locate part number 9658539680, and the fusebox has everything in the correct place, does it matter if the letter at the end of the S number is different if the number is correct.. for example K or N instead of M

Thanks in advance for any assistance

REG DATE: 2006
MODEL: LHD C4 5 DOOR
VIN: VF7**************[VIN obfuscated, can be read by forum staff]

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23126
Joined: 15 Sep 2015, 19:38
x 2423

Re: C4 heater/air con not working

Post by GiveMeABreak »

Just match up the 9658539680 number and you will be fine.

usticm
Posts: 2
Joined: 06 Feb 2021, 10:28

Re: C4 heater/air con not working

Post by usticm »

Hi Marc

Thanks for the response... does it matter if the new fusebox comes from a diesel where mine is a petrol?

adrianruk
Donor 2020
Posts: 50
Joined: 18 Aug 2019, 22:56
x 5

Re: C4 heater/air con not working

Post by adrianruk »

Hi all
Help required for C4 coupe BSM (fusebox) removal. My granddaughter’s 2006 C4 Coupe has recently suffered the dreaded climate control fan failure. The bridging trick well documented on this forum has effected a substantial improvement but I would like to replace the BSM fusebox with a secondhand one. Citroen advise me that new ones are no longer available even though they gave me a price! The part number they gave me seems to cover a number of different boxes so I would like to replace with a number exactly matching the existing.
The problem is the number is not visible in its fitted position. I am 120 miles away & cannot justify the journey in the current lockdown. How easy is it for a lay person, granddaughter or husband (non-driving) to remove the box sufficiently to read said number? I suspect the associated plugs will need disconnecting but photographs don’t seem to show any forms of fixing. I assume also that the battery will need disconnecting to effect this.
Any help gratefully accepted.
Adrian

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23126
Joined: 15 Sep 2015, 19:38
x 2423

Re: C4 heater/air con not working

Post by GiveMeABreak »

usticm wrote:
07 Feb 2021, 17:18
Hi Marc

Thanks for the response... does it matter if the new fusebox comes from a diesel where mine is a petrol?
What is important is the correct part number as the units are used over several models and marques, but have to match.

admiral51
Donor 2019
Posts: 2237
Joined: 24 May 2007, 10:11
x 248

Re: C4 heater/air con not working

Post by admiral51 »

Hi Adrian
If Citroen have given you the part number from the Vin number then i would like to say that it will be the correct part but post the Vin number and hopefully someone can give you the correct part number.
I replaced one on my old C4 2005 maybe 3 years ago and to be honest i cannot remember the way it is fixed in place, the old grey matter nudges me to say it is 1 bolt/nut and some locating pins.
Most of the plugs are easy enough to figure out, pinch the tabs and pull but think there was one that caused me issues as it took me a while to figure it out and i think it was push in, slide up and pull away.
In all it took me around 20 mins to swap old for new and yes battery does need to be disconnected.

I got a new one from EuroCarCare as it eliminated any other faults i had at the time.
9807028780.jpg
9807028780.jpg (17.91 KiB) Viewed 72 times
Borrowed from EuroCarCare

This image shows the what i think are the fixings and the location of the part number

And they are plug and play no need to code them to the car.
The new one i bought came complete with fuses in place, all i had to do was put the plugs back into place and they can only go in there correct spot :-D

Colin

adrianruk
Donor 2020
Posts: 50
Joined: 18 Aug 2019, 22:56
x 5

Re: C4 heater/air con not working

Post by adrianruk »

Hi Colin

Many thanks for your reply. I have read this thread many times over & note your experiences. Your posts have been very useful. Eurocarcare no longer supply the part unfortunately. I arranged for the bridging repair to be done by my grandson but he's now back at uni. It worked but it's not the proper cure.

The part no which Citroen gave me was 6500CK. This relates to a BSM-L04-00 on all the parts I can find for sale (eBay). I have a photo of the unit currently installed in the car which has a label L11-00 on the top. There are a few of those for sale. Physically the units look identical but I know that can be misleading. I have also found L11-00 units with a totally different fuse layout but apparently the same plugs & connections. Very confusing for me. That's why I really need to get the exact part number from the present unit. I strongly suspect I know what it will be from the L11-00 as all those for sale of that configuration have the same part number.

I think my research this evening has revealed that I probably don't need to get the unit number from the label as I think the L11-00 tells me all I need to know. Begs the question then is the current unit fitted the correct one. Up until the recent blower failure everything has worked as it should. My quandary really is should I buy an L11-00 of the same configuration or should I buy an L04-00 (6500CK) which Citroen say is the correct one.

The VIN is VF7**************[VIN obfuscated, can be read by forum staff]

Again any advice will be much appreciated.

Adrian

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23126
Joined: 15 Sep 2015, 19:38
x 2423

Re: C4 heater/air con not working

Post by GiveMeABreak »

HI Adrian

Can you please re-check the VIN - it's 1 alphanumeric too short. It should be 17 and it doesn't look right after the first 3. If you're having trouble reading it - it will be on the V5C log book.

There are quite a few variants of the fusebox part numbers for the C4 and quite a few replacements too, so the VIN would really be needed to ensure you get the right one.

adrianruk
Donor 2020
Posts: 50
Joined: 18 Aug 2019, 22:56
x 5

Re: C4 heater/air con not working

Post by adrianruk »

Hi Marc

I've finally got the correct VIN from granddaughter. I had missed off the final 5. The full VIN is VF7**************[VIN obfuscated, can be read by forum staff]. I am confident that the BSM fitted is the original as the car has only had 2 previous owners & we have receipts for just about everything done to from new.

Thanks again

Adrian

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23126
Joined: 15 Sep 2015, 19:38
x 2423

Re: C4 heater/air con not working

Post by GiveMeABreak »

Ok, so 6500CK is the correct PSA part number for your C4. Stick to that one.

adrianruk
Donor 2020
Posts: 50
Joined: 18 Aug 2019, 22:56
x 5

Re: C4 heater/air con not working

Post by adrianruk »

Hi Marc

Thanks for that. I’ll advise progress. Difficult with the current lockdown when the car is so far away.

Adrian

adrianruk
Donor 2020
Posts: 50
Joined: 18 Aug 2019, 22:56
x 5

Re: C4 heater/air con not working

Post by adrianruk »

Hi all

Just to tidy up. The easing of the Covid lockdown has finally allowed me to replace the BSM on the car. It all went very smoothly & everything is now functioning as it should. I actually replaced it with a BSM L11-00 matching exactly the the one fitted to the car. Cost £33 including postage.

I have a happy granddaughter again!

Many thanks to Marc & Colin for your usual help & advice.

Adrian

User avatar
GiveMeABreak
Forum Admin Team
Posts: 23126
Joined: 15 Sep 2015, 19:38
x 2423

Re: C4 heater/air con not working

Post by GiveMeABreak »

Thanks for the update Adrian - glad it's all sorted.

admiral51
Donor 2019
Posts: 2237
Joined: 24 May 2007, 10:11
x 248

Re: C4 heater/air con not working

Post by admiral51 »

Really pleased you got it sorted Adrian :bouncy: :bouncy:

Colin