Oh no 🤦🏼‍♂️ I've just bought another Xantia !

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
CitroJim
A very naughty boy
Posts: 49826
Joined: 30 Apr 2005, 23:33
x 6262

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by CitroJim »

zs&tas wrote: 26 Nov 2020, 20:48 I've just taken delivery of some metal for welding it 👊
I saw it being delivered...
Is that enough?
Is that enough?
Seriously, really enjoying this and keen to follow your adventures with this very desirable Xantia :D Maybe time to start a blog perhaps? It'll make a good read and a good record of your work ;)
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

:rofl2: Creepy guy "I saw it being delivered "

Hope so it's not that bad ! I usually bung stuff on Instagram with related #'s 🤷🏼‍♂️
User avatar
CitroJim
A very naughty boy
Posts: 49826
Joined: 30 Apr 2005, 23:33
x 6262

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by CitroJim »

zs&tas wrote: 27 Nov 2020, 12:02
I usually bung stuff on Instagram with related #'s 🤷🏼‍♂️
You'll find me on Instagram under the same name as I use on here 😉 And Facebook too...

I enjoy my social media 🙂
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
User avatar
ksanturion10
Posts: 228
Joined: 14 Oct 2018, 21:59
x 19

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by ksanturion10 »

zs&tas wrote: 26 Nov 2020, 20:48 That's the plan ! I've just taken delivery of some metal for welding it 👊
What or where are you going to weld over it?
Only himself the stupid makes wrong, many are being confused by the clever :P
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

Under battery tray and left rear sill , pics are above ^^^
User avatar
ksanturion10
Posts: 228
Joined: 14 Oct 2018, 21:59
x 19

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by ksanturion10 »

My sills are constantly bubbling since I bought the car, and at the right one there is a big hole now, just under the center of the front door - it is getting pretty ugly though.
One misleading question ;), on your pic with the whole car, I've red, that it has hydractive suspension, but still - it was set at Normal heigh before you took the picture, right?

BR
Martin
Only himself the stupid makes wrong, many are being confused by the clever :P
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

Sorry not my picture lol

I've finished welding and fixed a blown hydro pipe . Two more issues poped up , the car wouldn't turn off untill I stalled it , I then found a fuse to pull to get the ignition off. And since jacking the car up and welding the rear sill, and now the cars running again it seems the rear is 'stuck up ' 🤦🏼‍♂️ hoping to mot Thursday !
admiral51
Donor 2023
Posts: 2625
Joined: 24 May 2007, 10:11
x 378

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by admiral51 »

Have you bleed the system after fixing the blown pipe, trapped air may cause the car to stay high
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

The pipe was in the front , it's the back that's up . But maybe ??
User avatar
xantia_v6
Forum Admin Team
Posts: 9134
Joined: 09 Nov 2005, 23:03
x 847

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by xantia_v6 »

zs&tas wrote: 11 Dec 2020, 21:16 Sorry not my picture lol

I've finished welding and fixed a blown hydro pipe . Two more issues poped up , the car wouldn't turn off untill I stalled it , I then found a fuse to pull to get the ignition off. And since jacking the car up and welding the rear sill, and now the cars running again it seems the rear is 'stuck up ' 🤦🏼‍♂️ hoping to mot Thursday !
It could be that the "dog bone" has come off the linkage from the rear anti-roll bar to the rear height corrector. See item 6:

Image
User avatar
CitroJim
A very naughty boy
Posts: 49826
Joined: 30 Apr 2005, 23:33
x 6262

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by CitroJim »

zs&tas wrote: 11 Dec 2020, 21:16 the car wouldn't turn off untill I stalled it
If this is a 2.1TD then it's a very common problem with the EPIC Injection Pump... The ESOS valves will be failing. These are solenoid operated valves to control pump timing and governance.

The 'stop solenoid' analogue in the ESOS valve group is very prone to failing.

It can be fixed on a DIY basis. If it is the ESOS valve then the engine will eventually stop of its own accord as the pump employs a different tactic to cause a stop. The EML (K Light) may illuminate when this happens...

I've posted extensively about this in the past and some old posts of mine should come up in a search...
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

Xantia V6 thanks for the diagram 👌

Citrojim, hope you didn't get to wet today out there ? I feel it was electronic as the dash lights were on too as if it was running ?
User avatar
CitroJim
A very naughty boy
Posts: 49826
Joined: 30 Apr 2005, 23:33
x 6262

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by CitroJim »

zs&tas wrote: 12 Dec 2020, 15:21
Citrojim, hope you didn't get to wet today out there ? I feel it was electronic as the dash lights were on too as if it was running ?
Mercifully it stayed dry and quite mild too! Ideal weather really 🙂

Indeed, that does sound a lot like it's not the pump and something else. Ignition switch has to be a prime first suspect...
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...
zs&tas
Posts: 260
Joined: 18 Mar 2013, 17:07
x 16

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by zs&tas »

ive never had to have an ignition switch apart , it seems wierd i can move the key to off and take it out but the ignition switch should move to no ? its like there is a relay somewhere stuck on and not releasing ? not sure which one where tho !
User avatar
CitroJim
A very naughty boy
Posts: 49826
Joined: 30 Apr 2005, 23:33
x 6262

Re: Oh no 🤦🏼‍♂️ I've just bought another Xantia !

Post by CitroJim »

zs&tas wrote: 14 Dec 2020, 08:41its like there is a relay somewhere stuck on and not releasing ? not sure which one where tho !
Check the double injection relay in the vicinity of the engine ECU. If it has sticky contacts it might account for the symptoms you are seeing...

Try giving it a good bash to see if it brings forth a resolution to the issue...
Jim

Runner, cyclist, time triallist, duathlete, Citroen AX fan and the CCC Citroenian 'From A to Z' Columnist...