C4 Grand Picasso Gear lever contact issue

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Cittotraang
Posts: 3
Joined: 29 May 2024, 06:36

C4 Grand Picasso Gear lever contact issue

Post by Cittotraang »

Ok, So i have been having the Gear faulty issue on my 2009 C4 Grand Picasso and have done some looking into this issue. My Diagbox/Lexia throws the standard codes regarding the gear lever and the gear box.
The gear lever works sometimes and sometimes not ending up in the no reverse, shift between A1 and Neutral with the paddles. I have taken it apart and looked at the soldering of the sensors which have been prone to coldsolering. The optic sensors have been cleaned with electronic spray very carefully. I have checked the cables to see if there is a crack or a broken casing that can shortcut. Nothing checked out. BUT, as an act of despair, I plugged the contact straight on to the circuitboard and it works...... I can change gears, no codes, no problems. as a downside, no upper lever casing and no steering column case so it looks iffy but it works. Does anyone know any details to the contact and maybe how come it is working?
Attachments
C4 contact.jpg
Cittotraang
Posts: 3
Joined: 29 May 2024, 06:36

Re: C4 Grand Picasso Gear lever contact issue

Post by Cittotraang »

An update of the problem. I have managed to put the lever together and isolated it as a whole new problem.
It works as long as it lies down. As soon as I try to mount it to the steering column, it degrades into proclaiming Gearbox faulty.
So my question is if someone has the same problem and can test this theory to see if it any substance that covers more devices than mine. And if anyone more electronically inclined person can give a suggestion to what component that is prone to fail at the 45° inclination