Citroen C4 1.6 HDI 9HY NO POWER

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Amine1ouri
Posts: 18
Joined: 22 Feb 2022, 17:41
x 2

Citroen C4 1.6 HDI 9HY NO POWER

Post by Amine1ouri »

Hello,

I have a citroen c4 2008 1.6 hdi 9HY (110HP) NO FAP, ecu reference edc16c34 0281011629.

I've been suffering with a power problem for over 7 years, I've been to several garages and no one has managed to solve the problem or identify its origin.

When I press down on the gas pedal, it takes an enormous amount of time for the car to react; you have to wait until 2000 rpm for it to get going, and it doesn't always do that, sometimes even at 2000 rpm it doesn't give much, and that's often the case. a real calf !

I have no torque under 1500 rpm.

This problem disappears when I disconnect the flowmeter, but only for a few minutes, once I've been driving for more than 10 minutes, it becomes slow, but it's still much better than with the flowmeter connected, because even with the flowmeter connected, this loss of power becomes much more pronounced if the engine is hot.

No fault code is displayed in the ecu.

But in the parameter measurements, I noticed that every time I touch the accelerator pedal, an 'invalid value' is displayed on RCO EGR solenoid valve, then it displays a percentage and as soon as I touch the pedal again it displays it again. or if I exceed 3000 rpm (so when it closes).




- One strange thing I've noticed is that the scale (the y-axis) of the percentage (RCO) changes with excessive values up to 50,000 and sometimes converts to negative values, as you can see in the video:




- Engine off, ignition on: I keep getting an 'invalid value' in RCO EGR



What has already been done:


- Of course, we started by changing the flowmeter, new valeo egr valve... etc. with no result.

- Once at 260,000 kms, an injector tore near its nose, eating into the cylinder head, I decided to change the whole engine, because I already suspected that the injectors were out, hence the lack of power.

- Replacing the engine with a 9HY of course with its wiring harness and ECU --> result :
The car behaves exactly the same as before, it looks like I didn't change the engine.

PS: The engine came complete with all its components, sensors, egr alternator ... so in principle everything has been replaced.

- BSM replacement --- > same result.

- Tried another engine ECU ---> same result with invalid value (ignition on or engine running).

- Tried another accelerator pedal ---> no improvement

- In short, I've done everything with no result.


Please help
PaulC5
Donor 2024
Posts: 393
Joined: 06 Jun 2023, 15:26
x 98

Re: Citroen C4 1.6 HDI 9HY NO POWER

Post by PaulC5 »

Is the exhaust blocked ?
Amine1ouri
Posts: 18
Joined: 22 Feb 2022, 17:41
x 2

Re: Citroen C4 1.6 HDI 9HY NO POWER

Post by Amine1ouri »

No its all clean and I dont even have the FAP, I disconnected the exhaust after the turbo, and the car drives like it was, no improvement at all, except a little bit after 3500 rpm and that's normal because there is nothing after the turbo.

It's not a mechanical problem, because when I unplugg the maf sensor, it drives quite normal, but only for a certain time (5min to 10min) then there is a huge decrease in power as the engine warms up. But it stills better than the maf sensor connected.

Also it means that all the engine components are working fine, except the ones that are disabled if the maf sensor is unplugged like the egr ...

This phenomena of power loss when the engine warms up, happens even if the maf sensor is plugged.

I wanna solve the invalid value problem