Citroen C3 Picasso 1.6hdi 110

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

jimbbobw1977
Posts: 2
Joined: 13 May 2024, 11:19

Citroen C3 Picasso 1.6hdi 110

Post by jimbbobw1977 »

Hello All 👋

I’m hoping that the forum could help with ongoing issues I have with my C3 Picasso.

It is a 2011 1.6hdi 110 manual (8v engine) exclusive it’s done 52k miles. We got it when it had done 28k miles and previously we had all four injectors replaced at 35k miles when it started to cough on long journeys that would put it into limp mode, also the injector clamps were replaced.

Fast forward - it started to play up on long journeys coughing again but most of the time would carry on however it has failed now completely and in limp mode.

The faults at the time on a Carly reader were

P12B4 EGR (now replaced and new one coded in)
P0113 Air temp sensor
P0102 Air flow sensor
P2299 Pedal sensor
P0571 Brake switch
P14A4 EGR heat exchanger
F40A Generic fault BSI

Had these cleared and it still would not run - I’m limp mode with ASR/ABS lights lit up and EML on and only running on three cylinders limited power.

Now sometimes it would come up with other fault codes relating to injectors and this would vary between different injectors so I may have

After a retest I have had

P0268 - Injector 1 control and P1621 control unit 1

C1390 Fault regulation of engine toque
C1391 engine torque not cleared fault

After numerous clearing of fault codes sometimes a reread of codes will bring up

P0271 Cylinder 4 injector circuit high
C1391 engine torque not cleared fault
P0271 and P1621 for injector 1

Fast forward to currently - i have the replaced the EGR and coded in, I have replaced the main fuse box next to the ECU as that had the usual water ingress into the brown plug and was a mess as the pins had corroded it still would not work… I took it to a garage who said that they think it was a split wire for the injector they replaced this and replaced injector 4.. they said it drove for them with no issues as soon as I collected it ran with no warning lights on then it coughed and went into limp mode with the usual ABSASR fault and reduced power.

Not wanting to throw anymore money at it with the garage they said it could be the ECU that is at fault.. so I got a replacement ECU - cloned unit.

However this has not fixed the problem and it is still the same. These are my current faults codes showing

C1391 Engine torque not cleared fault
U35FF Internal generic fault
P0268 / P1621 Injector 1

The earlier ones I had have now gone and just these remain..

VIN VF7**************[VIN obfuscated, can be read by forum staff]

I am not sure where I should now start looking next? Do I start with checking the ABS ECU in the wheel arch for broken wires? Do I need to worry about the BSI in the glove box any help would be appreciated as I’m at a loss!

The faults have got worse over time - starting intermittently and only appeared on longer motorway journeys… it seems to me it could be electrical.

Many Thanks - James
RichardW
Forum Treasurer
Posts: 10961
Joined: 07 Aug 2002, 17:12
x 1028

Re: Citroen C3 Picasso 1.6hdi 110

Post by RichardW »

Sounds like it needs another injector... failure is not uncommon on this engine.
Richard W