Problems with jbl audio system

This unit is the eMyWay system, also referred to as RT6, RNEG2, or WIPNAV+ for the Peugeot platform and made by Magneti Marelli.
Main Features: The eMyWay colour satellite navigation has high resolution mapping, Bluetooth Telephone & Audio Streaming supported profiles, USB support for Media files & CD

Moderator: GiveMeABreak

Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Problems with jbl audio system

Post by Samuel308 »

Hi i have peugeot 308sw 2009 1,6hdi 110
My problem is with jbl audio sometimes it plays and sometimes it doesn’t. The problem starts when you turn on radio (rt6) without engine started and without key in ignition the stereo plays great until the lights and dashboard turns off after that the music plays a few seconds but than monitor will write that there is a fault in car and radio can’t work because of it. Than goes black and.when you turn it back on everything works except sound system
The fuse is good there is power to the system
Attachments
IMG_9012.jpeg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Problems with jbl audio system

Post by GiveMeABreak »

Needs a diagnostic if this is the factory fitted system. If there's a fault, it will generally provide a code if using something like PP2000 or Diagbox.

The separate amp will draw significant power and will cause the vehicle to go into economy mode very quickly without the engine running. I would not recommend running it without the engine running as you could flatten the battery and this will cause issues with other systems.
Please Don't PM Me For Technical Help

Marc
Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Re: Problems with jbl audio system

Post by Samuel308 »

Hi thanks for replay,it’s not an economy mode that’s different. Jbls are not from factory,I will tell you later when I connect lexia.
Edit: it’s factory system from another car implemented to my car.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Problems with jbl audio system

Post by GiveMeABreak »

I'm just saying that the energy management system will kick in a lot quicker if your battery falls below a certain voltage.

With that extra information, which would of been useful in the first place, have you configured the amp correctly? - as you can't just install these as they are.
Please Don't PM Me For Technical Help

Marc
Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Re: Problems with jbl audio system

Post by Samuel308 »

Hi ! I did a bit of investigating with diagnostic tool and the results are here:

1.I started by fault scanning nothing was there
So I played music and turn the car off scanned it again and there was fault in bsi F04C
Scanning further i found 2 faults in amplifier CD2A and CD2C

2.On one photo are amplifiers with you can choose but I don’t know what kind of I have so i tried to change the amplifier type to electronic one but that didn’t work and the faults in radio are after this configuration.Before that I didn’t had any fault in radio and it was set on multiplexed connected amplifier.
Attachments
Faults with electronic amplifier
Faults with electronic amplifier
IMG_9041.jpeg
IMG_9038.jpeg
Amplifier configuration
Amplifier configuration
IMG_9039.jpeg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Problems with jbl audio system

Post by GiveMeABreak »

So what's the VIN of this vehicle and what is the part number of the amplifier you have fitted? It will be a 98* or 96* number most likely.
Please Don't PM Me For Technical Help

Marc
Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Re: Problems with jbl audio system

Post by Samuel308 »

Hi amplifier number 9660045680
My vin VF3**************[VIN obfuscated, can be read by forum staff]
Also somewhere on internet i saw that one guy had this problem (F04C) but not the problem with sound system.And he updated the bsi firmware
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Problems with jbl audio system

Post by GiveMeABreak »

Unfortunately I can't help you with this as that is not the part for an optional amp for this vehicle. There are various types of amps, but each depend on vehicle equipment and options. You may have the manufacturer / international part number, but it is not listed under parts.
Please Don't PM Me For Technical Help

Marc
Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Re: Problems with jbl audio system

Post by Samuel308 »

Hello opening this topic again i was changing the egr valve and I noticed this strange thing in diagbox

In with places amplifier needs to be coded ? I did it in radio and in bsi a setup equaliser
Attachments
IMG_9217.jpeg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Problems with jbl audio system

Post by GiveMeABreak »

Yes there are settings for configuration / selection of an amplifier system in Diagbox, but these can be different types (multiplexed or non-multiplexed) and other types of amp, so this will affect operation. But be careful if you select the incorrect amp type as the system will expect the correct one to be present.
Please Don't PM Me For Technical Help

Marc
Samuel308
Posts: 20
Joined: 14 Sep 2021, 18:39

Re: Problems with jbl audio system

Post by Samuel308 »

It only works as a multiplexed connected other types don’t work