1.6hdi cuts off while driving and won't start

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

berdza
Posts: 10
Joined: 19 Dec 2022, 01:11

1.6hdi cuts off while driving and won't start

Post by berdza »

Hi everyone, I am in need of your help.
I drive Citroen c5 2005 1.6 hdi 80kw, and it shut down while driving, and the car won't start.
Air intake is fine, but there is fuel supply problem
The car doesn't have a fuel pump in its reservoir, i have changed the fuel filter and primed it with handpump, but the car still doesn't start. No fault codes on autocom 2021
It reads that there is 330bar fuel pressure, but when we unscrewed the pipes to injectors the reading still said 330bars even when there was no pressure in system
We unscrewed the feed pipe from high pressure pump to common rail and cranked the car and it did not send any fuel
We changed fuel pressure regulator but nothing changed and autocom reads out that fuel regulator is opening from 16% to 24%
Do you have any idea what could be the problem
xsara92
Posts: 17
Joined: 06 Feb 2024, 20:49
x 1

Re: 1.6hdi cuts off while driving and won't start

Post by xsara92 »

My 1.6HDi was cutting out randomly, just managed to get it fixed, and the culprit was the fuel rail pressure sensor. It was allowing the fuel pressure to get too high, resulting in triggering shutdown to prevent fuel system damage.
My mechanic told me the individual sensor can be obtained online.
One of a number of possibilities..
berdza
Posts: 10
Joined: 19 Dec 2022, 01:11

Re: 1.6hdi cuts off while driving and won't start

Post by berdza »

xsara92 wrote: 07 Mar 2024, 20:17 My 1.6HDi was cutting out randomly, just managed to get it fixed, and the culprit was the fuel rail pressure sensor. It was allowing the fuel pressure to get too high, resulting in triggering shutdown to prevent fuel system damage.
My mechanic told me the individual sensor can be obtained online.
One of a number of possibilities..
I changed a lot of sensors crankshaft, camshaft, fuel pressure regulator, but still no help
So one thing i know is that pressure should be 0 when car is off but ecu doesn't have that info, its only getting info that there is 330 bars of pressure, but even when i disconnect the fuel pressure sensor it has that info. So its either that ecu is bad or wiring from ecu to fuel pressure sensor. I will try to change ecu and see what happens
xsara92
Posts: 17
Joined: 06 Feb 2024, 20:49
x 1

Re: 1.6hdi cuts off while driving and won't start

Post by xsara92 »

Did changing the ECU solve the issue?