Loss of connection services DS7

This is the Forum for all your DS Automobiles Technical Questions, Problems or Advice.

Moderator: RichardW

Sabres54
Posts: 3
Joined: 01 Feb 2023, 07:42
x 2

Loss of connection services DS7

Post by Sabres54 »

I have an issue that my connection services have stopped working on my DS7.

The Sat Nav was working fine then the next day I went to work and noticed the TOMTOM services were not working ( subscription runs out May2025).

Checked the app and there was an update installed the update but it was still not working.

Followed the instructions on how to get the services to work and went to the connection services where it says it is activated but the globe symbol that is normally there that you press to connect the service has disappeared. I have searched every where and cannot seem to find any answers on how to sort this issues.

Has anyone had the same problem.
User avatar
MacSlavko
Posts: 102
Joined: 17 Aug 2017, 23:39
x 21

Re: Loss of connection services DS7

Post by MacSlavko »

A weired one...
I suppose you were out on the open area with sufficient GSM coverage on the phone (3G at least)?
Built-in BTA module connects to the same network, so should get the signal as well...
Maybe was just a temporarely issue in your area (on TomTom's end)?
Had my Connected services working normally (in Croatia, though).

If problem persists, I'd check the issue with nearest main dealership office. Although, it's often that they don't know much on this subject so don't expect expertise...
Last edited by MacSlavko on 03 Mar 2024, 13:50, edited 1 time in total.
Sabres54
Posts: 3
Joined: 01 Feb 2023, 07:42
x 2

Re: Loss of connection services DS7

Post by Sabres54 »

The car is back in the garage as it's one of a number of issues I'm having. It's at the point where DS France are having to come and look at the car.

In regards to the connected services I tried to get into work in different locations with no luck.