207 1.4 vti variable valve timing issues and wiring diagrams

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Yewboy69
Donor 2024
Posts: 6
Joined: 19 Feb 2024, 18:30

207 1.4 vti variable valve timing issues and wiring diagrams

Post by Yewboy69 »

Hi everyone, I am new to the forum and I have a few issues that I would be so grateful for any help with!

After spending hours searching forums and watching videos I am not getting anywhere!

The car is a 2012 207 1.4 vti. It starts and runs although lumpy on idle.

The fault codes I have are:

P1062 variable valve lift system position regulation fault

P0010 control of inlet camshaft variable valve timing solenoid valve open circuit

P023a coolant pump declutch (this I know is unplugged)

P1015 variable valve lift system reference value in downgrade not reached

P1078 variable valve lift system electrical circuit temp too high (intermittent)

P1050 power supply to variable valve lift system open circuit to power circuit

P1048 power supply to the variable valve lift system short circuit to earth on power circuit (intermittent)

So far I have tried an actuation test for the variable valve relay but I hear no clicks anywhere and cannot locate any obvious relay..is there one on this vehicle or is it powered directly from the ecu?

I have also tried an actuation test on the variable valve position motor and I get nothing. No noise from the motor and when I disconnect the plug from the motor and check the voltage to the plug I get no power to the plug.

I unplugged the plug on the ecu with the wires that go to the valve timing motor and put 12v direct to the wires to the motor and I can hear the motor move in both directions so I assume the motor is not the fault.

So I am guessing I have a wiring or ecu fault but this is as far as I got.

So my next question is where to look for a wiring diagram for this vehicle so I can start tracing wires! I have searched and searched but I cannot find anything.

Any help or pointers would be greatly appreciated
Yewboy69
Donor 2024
Posts: 6
Joined: 19 Feb 2024, 18:30

Re: 207 1.4 vti variable valve timing issues and wiring diagrams

Post by Yewboy69 »

For the wiring diagrams I got a copy of service box off ebay

I have removed the lift motor today. It turns with power put directly to it, although smoother in one direction than the other. In one direction it almost feels like there is an initial notchy resistance.

I am now getting power to the lift motor plug when it is disconnected with the ignition on, around 6 volts, I cannot find any information on what voltage I should expect to see. I get a fluctuating voltage when performing an actuation test which is what I would expect.

However with the motor plugged in I get no movement from the motor. If I touch the motor when the ignition is turned on I can feel an initial very faint vibration 'buzz' and then nothing. This, along with the notchy feeling is leading me to believe its the motor at fault so I am going to try a replacement.
User avatar
Rp0thejester
Donor 2024
Posts: 2388
Joined: 11 May 2022, 19:54
x 807

Re: 207 1.4 vti variable valve timing issues and wiring diagrams

Post by Rp0thejester »

First of all..... Welcome! I'm sure you'll get the info you need here. Why not look at our Off Topic Chat and get involved
Ryan

'99 Xsara 1.6 X (Red) with Sunkissed bonnet. T59 SBX
'54 Astra Estate 1.7DTI (Artic White)
'06 C8 2.2Hdi Exclusive (Aster Grey)

Champion of Where's CitroJim :-({|=
Yes I ask the stupid questions, because normally it is that simple.
User avatar
Rp0thejester
Donor 2024
Posts: 2388
Joined: 11 May 2022, 19:54
x 807

Re: 207 1.4 vti variable valve timing issues and wiring diagrams

Post by Rp0thejester »

If looking for part numbers for a replacement then post in the parts thread, as your a donor you will get access to the parts thread. GiveMeABreak (a hero) will be able to supply part numbers and diagrams if available
Ryan

'99 Xsara 1.6 X (Red) with Sunkissed bonnet. T59 SBX
'54 Astra Estate 1.7DTI (Artic White)
'06 C8 2.2Hdi Exclusive (Aster Grey)

Champion of Where's CitroJim :-({|=
Yes I ask the stupid questions, because normally it is that simple.
Yewboy69
Donor 2024
Posts: 6
Joined: 19 Feb 2024, 18:30

Re: 207 1.4 vti variable valve timing issues and wiring diagrams

Post by Yewboy69 »

Just as an update to this..

The replacement motor did not change anything.

I currently have the motor wound manually about halfway between the stops. Its starts and idles smoother than before although dies after running for around 5 seconds unless I blip the throttle. After this it idles no problem, runs up to temperature and stays steady.

A replacement BSM did not change anything (I had read somewhere that the valve lift motor relay was located inside this)

I have checked the timing with a timing tool and that was spot on.

I got the coolant pump actuator plugged back in (very awkward!) Nothing changed.

The inlet valve solenoid open circuit was a broken wire.

What I am trying to work out now is codes P1050, P1048 and P1078. If anyone has any insight it would be much appreciated as I am in a bit over my head on this one but keen to try to sort it.

I am now suspecting a wiring issue and my feeling is the wires to the valve lift motor from the engine ecu.

The car came to me with these issues and it is clear that somebody has already had a crack at it before me as alot of the wiring has stab holes through the insulation where I assume electrical probes have been pushed through. I am not sure if this is standard practice with auto electrics (auto electrician I am not!) But its a concern to me to the point I am considering a replacement loom

Vin VF3**************[VIN obfuscated, can be read by forum staff]