Left signal blinking rapidly - but normal on hazards.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Mexico14
Donor 2023
Posts: 94
Joined: 11 Aug 2020, 14:34

Left signal blinking rapidly - but normal on hazards.

Post by Mexico14 »

I've recently changed a rear brake bulb since then...
All bulbs are working as they should but an error message come up relating to the signal light not working correctly. Right and left bulbs all working but when indicating left the indicator blinks twice the speed. When hazards are on, all the bulbs blink at their normal speed. Any idea how this can be fixed please?
User avatar
mickthemaverick
Donor 2024
Posts: 13884
Joined: 11 May 2019, 17:56
x 6125

Re: Left signal blinking rapidly - but normal on hazards.

Post by mickthemaverick »

Does your car have the indicator repeaters in the mirrors and if so have you checked the left mirror bulb? :)
I used to be indecisive, now I'm not so sure!
I used to ride on two wheels, but now I need all four!
Mexico14
Donor 2023
Posts: 94
Joined: 11 Aug 2020, 14:34

Re: Left signal blinking rapidly - but normal on hazards.

Post by Mexico14 »

Update:

The indicators are all working as expected but now have a side light issue. Tested the sidelight bulbs in the dipped headlight and they work perfectly. Issue isn't the bulbs. Any idea where to look next? Do the sidelights have a fuse I could replace?
User avatar
xantia_v6
Forum Admin Team
Posts: 9167
Joined: 09 Nov 2005, 23:03
x 861

Re: Left signal blinking rapidly - but normal on hazards.

Post by xantia_v6 »

What is the issue with the side lights?
Mexico14
Donor 2023
Posts: 94
Joined: 11 Aug 2020, 14:34

Re: Left signal blinking rapidly - but normal on hazards.

Post by Mexico14 »

The issue ended up being the replaced rear stop light had blown again. Done a bsi reset, replaced bulb again. All good so far. I think I upset the bsi as I originally replaced the bulb with the ignition on!