Hydractive suspension not risong when engine started

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Tommythegreek1977
Posts: 2
Joined: 06 Dec 2023, 16:07

Hydractive suspension not risong when engine started

Post by Tommythegreek1977 »

Hi guys and ladies!
New to the forum and just need to state what a wonderful job you re all doing here - bravo! If anyone can help with my Gremlins:?:
Citroen 2.2hdi estate yr2002 the suspension won't rise when the engine is running. It will get lower, but wont rise. When i turn the engine off, and switching on the ignition again, the pump comes on and the requested height is obtained, whatever that might be. The problem is that when the engine is running, the suspension will not adjust upwards - lets say someone sits at the back for instance, it wont pump up itself again. If one steps out of thecar, it will adjust back down.. lexia gives no faults on the suspension, all spheres are checked and not leaking, fuses checked, connectors to the pump, and all in the enginebay fuse box cleaned and checked. Any ideas??
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38040
Joined: 15 Sep 2015, 19:38
x 5899

Re: Hydractive suspension not risong when engine started

Post by GiveMeABreak »

Very likely to be either the rear height corrector or the rear centre sphere hydraulic block.
Please Don't PM Me For Technical Help

Marc
Tommythegreek1977
Posts: 2
Joined: 06 Dec 2023, 16:07

Re: Hydractive suspension not risong when engine started

Post by Tommythegreek1977 »

Tnx for the quick response - any way to test these two, or am I just swaping and see what works?