RT6 Does not turn off

This unit is the eMyWay system, also referred to as RT6, RNEG2, or WIPNAV+ for the Peugeot platform and made by Magneti Marelli.
Main Features: The eMyWay colour satellite navigation has high resolution mapping, Bluetooth Telephone & Audio Streaming supported profiles, USB support for Media files & CD

Moderator: GiveMeABreak

Trickytail
Posts: 2
Joined: 17 Sep 2022, 21:50

RT6 Does not turn off

Post by Trickytail »

Hi everyone,
previously i upgraded my 2008 C4's RD4 for a RD45 and everything worked flawlessly. Now i bought a RT6 and i was able to have everything working, even coded the VIN (directly modifying the files on the sdcard since at the start the confirm button did not work). The problem is when i removed my RD45 the 12v switched remote does not work as intended and only turns off after like 30 seconds, instead of when i turn the ignition off, not only that but everytime a door opens or closes everything turns on and it stays on for that amount of time, before this it only turned on when turning the ignition on or pressing the power button on the RD45.
Well, thing is i expected that when i connected the new RT6, it would go back to normal since i guessed it was the radio's job and it was only happening because there was no radio or C screen connected. This didn't happen and everything stayed the same, the RT6 turns off after about 30 seconds even if it goes into power saving mode instantly, it just shows the main screen and disables every button as if it was turned off but with the screen on, closing or opening any door repeats this. Also, every time it turns on it's as if it reseted, a loud thud plays through the speakers and sometimes the VIN number resets as well (maybe since i change it directly from the sd card there is some kind of protection or verification it's reverting my changes?). :?
Seeing the pinout for both radios i noticed pin 11 is the switched remote on the RD45 and in the RT6 is empty, but removing it did nothing. I also removed pin 15 which was 12v on the RD45 and in the RT6 shows it is the display's ground (although i didn't make it a ground and is just empty now, but i don't think this is the issue since it also happens with everything disconnected).
Every function seems to be working fine in the RT6 despite that behaviour, although sometimes when it resets i have to load the VIN again since it goes back to the old one.
I have no clue what to look for, any help is appreciated

PS: if it's of any help for anyone, i could not make my steering buttons work on my 2008 C4 VTS, the flag for the steering wheel controls shows: VMF/VCCF "Configure type of steering wheel commands" being only described "0=column controls (like C3/DS3), 1= old C4 fixed cube controls, 3 seems to be DS5/508 CAN2010", well none of those worked for me, even disabled some buttons on the RT6 itself, turns out option 2 which is non existant in the description worked for me.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38237
Joined: 15 Sep 2015, 19:38
x 5941

Re: RT6 Does not turn off

Post by GiveMeABreak »

You don't have the correct electrical harness most likely as telematics units are configured differently to the RD systems. Plus there will be other options that need telecoding using Diagbox before the unit will work correctly, apart from the VIN.
Please Don't PM Me For Technical Help

Marc