C4 2011 Fuel pump and gauge

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

drsd
Posts: 3
Joined: 20 May 2023, 17:04

C4 2011 Fuel pump and gauge

Post by drsd »

My C4 is impossible to start after it's been sitting for a couple days. However when I prime the fuel filter it starts right up.

I'm suspecting the fuel pump in the tank is broken as I can not hear it what so ever when turning on the ignition.
I looked under the rear seat to find a bit of a surprise when it came to the wiring. On all the videos I've seen the main connector has 4 wires going in to it, mine only has 2. But I also have a set of 3 mystery wires that go somewhere else that I have not seen anywhere.
I'm guessing the wires connected to the big connector are for the fuel gauge as the resistance measured changes with changing fuel content.
Does anyone have any idea what the connector at the top of the picture is for?
PXL_20230520_154939677.jpg
After screwing around with the fuses and connectors my fuel gauge decided to stop working. it's just showing dashes. Any idea on how to fix this?
PXL_20230520_155246506.jpg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38747
Joined: 15 Sep 2015, 19:38
x 6055

Re: C4 2011 Fuel pump and gauge

Post by GiveMeABreak »

I'll need your VIN to see exactly what you have (please post your VIN in full without spaces - it will be automatically masked from public view after submitting your post & will only be visible to staff).

Some vehicles are fitted with a pump and gauge, others have a gauge only, so expect spare wiring that is unused. Other connectors could be for the additive pump but we don't know yet as you haven't mentioned anything about the vehicle including whether it is a petrol or diesel. But post the VIN and I'll know everything I need.
Please Don't PM Me For Technical Help

Marc
drsd
Posts: 3
Joined: 20 May 2023, 17:04

Re: C4 2011 Fuel pump and gauge

Post by drsd »

Forgot the details.
It's a diesel with the eHdi engine.

VIN: VF7**************[VIN obfuscated, can be read by forum staff]
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38747
Joined: 15 Sep 2015, 19:38
x 6055

Re: C4 2011 Fuel pump and gauge

Post by GiveMeABreak »

Ok, so as I thought you only have a gauge module, not the gauge with pump.

No display of the fuel can be a result of the following:
  • Configuration of the BSI
  • Built-in systems interface
  • Instrument panel
  • Connectors
  • Electrical harness
  • Tank unit module
Also depending on the quantity of fuel added, it can fail to register if adding small quantities. At least 10 -15 litres should be added for the system to recognise and report the correct level.

I suggest you trace your steps back and check you have connected everything back up.

You may want to try a BSI reset: BSI Reset / Battery Disconnect / Reconnect Procedure
Please Don't PM Me For Technical Help

Marc
drsd
Posts: 3
Joined: 20 May 2023, 17:04

Re: C4 2011 Fuel pump and gauge

Post by drsd »

Ok that's interesting.

What else would cause the car to not start after it's been parked for a while then?
It cranks just fine but wont start until push the primer on the fuel filter a few times.
And when it doesn't start it generates fault code for low pressure in the fuel rail.

I'll look over all the wiring i screwed around with.
I did try to feed the plug i. The tank directly from a 12V battery as i though this was for the pump so i might have fried the level sensor. Although it did measure fine when checked with multimeter after.
I tried the BSI reset with no luck.

I filled the tank up so i know it's full. Measured around 50ohm with the tank full. About 240ohm with it 1/4 full.
User avatar
myglaren
Forum Admin Team
Posts: 25816
Joined: 02 Mar 2008, 14:30
x 4997

Re: C4 2011 Fuel pump and gauge

Post by myglaren »

drsd wrote: 20 May 2023, 20:38 What else would cause the car to not start after it's been parked for a while then?
It cranks just fine but wont start until push the primer on the fuel filter a few times.
And when it doesn't start it generates fault code for low pressure in the fuel rail.
A small leak in the fuel line before the HP pump, allowing air in and the fuel to drain back into the tank.