Light on Dash No Codes...

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Martin345
Posts: 3
Joined: 17 May 2023, 16:41

Light on Dash No Codes...

Post by Martin345 »

Hi all

I've got a problem with my C4 Picasso hdi (2016). I was driving on Sunday and got engine management and urea lights on the dash. I've got a little code reader so bobbed that in and it pulled back a P20ee code. My wife's uncle thought it would probably be a sensor or dpf pipe blocked so came down with the dpf cleaner and the engine management light went off.

Now, I've still got the urea light on and when I start the car I get a message saying "emission control system fault: starting prevented in 600 miles" along with an audible warning.

I took it to the garage this morning and there were no codes relating to the SCR system and they advised I do a BSI reset.

I've done that but the lights still on. I've tried googling it but I can't find anybody else with this issue. Does anyone have any ideas how I can resolve this?

Thanks,

Martin
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38747
Joined: 15 Sep 2015, 19:38
x 6055

Re: Light on Dash No Codes...

Post by GiveMeABreak »

Well the UREA warning has absolutely nothing to do with the DPF. It's a separate system, so putting DPF cleaner in won't have the slightest effect on the SCR System.

That's telling you that the Adblue tank needs topping up. If you don't, starting will be disabled once the countdown reaches zero.

Follow the guidance in your handbook for topping up the system, specifically to the minimum amount of fluid to top-up with and the timings involved before you turn the ignition on.
Please Don't PM Me For Technical Help

Marc
Martin345
Posts: 3
Joined: 17 May 2023, 16:41

Re: Light on Dash No Codes...

Post by Martin345 »

Sorry, yes should have said I've topped it up but it's still coming on.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38747
Joined: 15 Sep 2015, 19:38
x 6055

Re: Light on Dash No Codes...

Post by GiveMeABreak »

In that case you'll need a dealer visit to investigate if the UREA warning light has not gone off after a 10 minute drive or so.

There are several possibilities, but needs investigation. One may be a new tank as the pump module is integrated - but you will need to have this confirmed if the dealership can't reset the warning.
Please Don't PM Me For Technical Help

Marc
Martin345
Posts: 3
Joined: 17 May 2023, 16:41

Re: Light on Dash No Codes...

Post by Martin345 »

Ok thank you for your help
User avatar
Doo
(Donor 2022)
Posts: 461
Joined: 09 Sep 2019, 16:53
x 116

Re: Light on Dash No Codes...

Post by Doo »

A friend had this on his 20 Berlingo. Turned out to need a dealer update. But there are stories of the tank & pump needing replaced at many many pounds Sterling..... :roll:
Has anyone seen the plot? :?