[C5 X7] Strange intermittent 'knock' from front when going lock-to-lock.

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

User avatar
Stickyfinger
(Donor 2016)
Posts: 10593
Joined: 28 Mar 2013, 22:05
x 1374

Re: [C5 X7] Strange intermittent 'knock' from front when going lock-to-lock.

Post by Stickyfinger »

Well that is a strange one....like Matt, I cannot see how this would not hit the drive shaft....and change the driving characteristics or ride height on that side..............very strange
Alasdair
Activa, the Moose Dogger
User avatar
MattBLancs
Donor 2024
Posts: 2785
Joined: 25 Apr 2022, 09:03
x 1493

Re: [C5 X7] Strange intermittent 'knock' from front when going lock-to-lock.

Post by MattBLancs »

Just for completeness, FRIP with grease nipple installed today:
IMG_20231204_161326701.jpg
Described profusely here:
viewtopic.php?p=782201#p782201
the-termin8r
Donor 2023
Posts: 80
Joined: 29 Dec 2022, 23:31
x 6

Re: [C5 X7] Strange intermittent 'knock' from front when going lock-to-lock.

Post by the-termin8r »

Here's a condensed version of a long-ish update I posted that got deleted with my account, but didn't come back with it.

Got the knock sorted, wasn't a fripp joint. Instead it was my front right strut not being attached at the bottom. The place I took it to somehow missed it when I asked them to look for the knock, but found it when doing the MOT (no idea what they were doing during the troubleshooting). They said the only way it could be in the condition they found it in was if a human hadn't reassembled it properly. I had taken it to a different place for a wishbone replacement a year prior. But they only worked on the left side of the car. I can only assume they disassembled the right as a reference guide and didn't reassemble it properly. That garage is the only one to have ever suspension work on the car. That means I've been driving around like this for a year. The even more terrifying option is that I've been driving around like this for 3-4 years because that's when the right was last replaced, but it hasn't been knocking for that long.

Pretty insane that the car felt completely fine to drive to me, my dad (who drove it for 8 years before me) and the mechanic. The only issues exhibited were the knock mentioned in the OP and some slight vibrations above 85 MPH which I assumed was just iffy wheel balance. I think I was able to drive it because the strut was likely wedged between the bolt it was supposed to be mounted on and the vertical metal piece through which the bolt is threaded.

Image
Image
- Rob

My account accidentally got deleted late Dec '23, so if you're reading my posts from then or earlier and they look weird / are missing media, that's why. Not much can be done, sorry.