C5 II 2.0 16v Break with ABS/ESP/depollution error

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Morten
Posts: 50
Joined: 30 Apr 2002, 03:59

C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by Morten »

Hi,
got ABS/ESP error where warning light is on. In addition it has caused the directional headlights not to work properly and got a depollution error light. I have recently replaced calipers front, wheel bearing rear, ballbearing rear arms where rear callipers was removed. Changed brake fluid and bleeded the system. Car worked for 5k km and then I got the error. Tried to replace battery with no change. Got an Autel MP808Z-TS scanner and got quite a few error codes. Have removed those that is not related to ABS/ESP error (like parking sensor and lane assist errors). Question is where it is most likely to find the error(s).

VIN: VF7**************[VIN obfuscated, can be read by forum staff]

2005 C5 II Break, 2.0l 16v 140hp

Error codes:
Anti-lock brake system -- ESP_MK60 ( 1 DTC )
C1135 Steering wheel angle sensor signal Internal Permanent fault

Suspension -- SUSPENSION_ECOTECH ( 1 DTC )
U1205 No communication with the steering wheel angle sensor incorrect value received Permanent fault

Power steering -- GEP ( 1 DTC )
U1205 Steering wheel rotational speed information incorrect value received Permanent fault

Directional headlamps -- PROJECTEURS ( 1 DTC )
U1205 Dialogue with the steering wheel angle sensor incorrect value received Permanent fault


Thanks,

Morten
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38684
Joined: 15 Sep 2015, 19:38
x 6039

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by GiveMeABreak »

You have an error in your VIN - it's one digit short.

Have you done any work concerning the steering wheel - or removed any stalks or controls on the unit there? This contains the steering wheel angle sensor and looks to be faulty whether the unit itself is out of calibration (which will be the case if removed), or there is a fault on the data network linking it to the ESP ECU.

When you have corrected your VIN, do also include the other fault codes as sometimes faults can be triggered by other problems that may not be obvious to some.
Please Don't PM Me For Technical Help

Marc
Morten
Posts: 50
Joined: 30 Apr 2002, 03:59

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by Morten »

See if this is correct.
VIN: VF7**************[VIN obfuscated, can be read by forum staff]
Morten
Posts: 50
Joined: 30 Apr 2002, 03:59

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by Morten »

Here are all error codes:

Anti-lock brake system -- ESP_MK60 ( 1 DTC )
DTC Description Status
C1135 Steering wheel angle sensor signal Internal Permanent fault
Lane departure Warning system -- AFIL ( 2 DTCs )
DTC Description Status
FCF6 Communications fault on LIN Permanent fault
8CE5 Sensor number 5 information no signal Permanent fault
Passenger's door module -- MDP_PASSAG ( 1 DTC )
DTC Description Status
FC0E Door mirror heating output Permanent fault
Parking assistance -- AIDE_STAT ( 2 DTCs )
DTC Description Status
FBC7 Internal rear left hand sensor Permanent fault
FBC3 Inner front RH sensor Permanent fault
Suspension -- SUSPENSION_ECOTECH ( 1 DTC )
DTC Description Status
U1205 No communication with the steering wheel angle sensor incorrect value received Permanent fault
Radio -- AUTORADIO ( 1 DTC )
DTC Description Status
F905 Auxiliary audio inputs no. 1 Permanent fault
Power steering -- GEP ( 1 DTC )
DTC Description Status
U1205 Steering wheel rotational speed information incorrect value received Permanent fault
Directional headlamps -- PROJECTEURS ( 1 DTC )
DTC Description Status
U1205 Dialogue with the steering wheel angle sensor incorrect value received Permanent fault
Air conditioning -- CLIMATISATION ( 1 DTC )
DTC Description Status
F702 Passenger compartment humidity sensor Permanent fault
Morten
Posts: 50
Joined: 30 Apr 2002, 03:59

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by Morten »

GiveMeABreak wrote: 24 Apr 2023, 11:12 You have an error in your VIN - it's one digit short.

Have you done any work concerning the steering wheel - or removed any stalks or controls on the unit there? This contains the steering wheel angle sensor and looks to be faulty whether the unit itself is out of calibration (which will be the case if removed), or there is a fault on the data network linking it to the ESP ECU.

When you have corrected your VIN, do also include the other fault codes as sometimes faults can be triggered by other problems that may not be obvious to some.
Nothing is done with the steering wheel or controls. Replaced calipers and handbrake cable with guides and have 10K+ km on the meter after that.
According to the scanner, the steering wheel is calibrated. Tried to re-calibrate it but it stopped.
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38684
Joined: 15 Sep 2015, 19:38
x 6039

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by GiveMeABreak »

Unfortunately most of those codes are not coming up as valid, so you didn't use a Lexia by the looks of things.

But if I recall there is little available from Citroen on these older Petrol engines fault code wise, with little or nothing.

All I can say is that from what you have listed above is there is a fault on the LIN (Local Interconnect Network). The LIN connects some equipment together on a network and if there is a problem it can affect information to and from ECUs.

There seems to be a fair few issues from Parking assistance, AFIL, Directional Headlamps and of course the Steering Wheel Angle Sensor.

I would check to make sure you haven't knocked a wiring connection / plug anywhere where you were working. Also make sure you haven't spliced into any wiring for aftermarket equipment or fitted anything recently that may be interfering with the network.

I wish I could be of more help, but as I said on this engine there is very little data on the fault codes provided by Citroen.
Please Don't PM Me For Technical Help

Marc
Morten
Posts: 50
Joined: 30 Apr 2002, 03:59

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by Morten »

GiveMeABreak wrote: 24 Apr 2023, 19:03 Unfortunately most of those codes are not coming up as valid, so you didn't use a Lexia by the looks of things.

But if I recall there is little available from Citroen on these older Petrol engines fault code wise, with little or nothing.

All I can say is that from what you have listed above is there is a fault on the LIN (Local Interconnect Network). The LIN connects some equipment together on a network and if there is a problem it can affect information to and from ECUs.

There seems to be a fair few issues from Parking assistance, AFIL, Directional Headlamps and of course the Steering Wheel Angle Sensor.

I would check to make sure you haven't knocked a wiring connection / plug anywhere where you were working. Also make sure you haven't spliced into any wiring for aftermarket equipment or fitted anything recently that may be interfering with the network.

I wish I could be of more help, but as I said on this engine there is very little data on the fault codes provided by Citroen.
Thanks for your effort and help.
Can the replacement of rear wheel bearing play a role in this? Or maybe rear ABS sensor have got a hit when removed ? Had one incident with ABS/ESP light after i replaced wheel bearing, but it disappeared. Just guessing. Will start to look at wiring. Will download wiring layout.

Thanks,
Morten
User avatar
GiveMeABreak
Forum Admin Team
Posts: 38684
Joined: 15 Sep 2015, 19:38
x 6039

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by GiveMeABreak »

Normally a faulty wheel speed sensor will give a specific fault code for the specific wheel, so I'm not confident that would be the issue here. Further, the wheel sensors are not multiplexed themselves - but provide data to the ESP ECU that uses CAN connections to other ECUs.
Please Don't PM Me For Technical Help

Marc
OlegR
Posts: 19
Joined: 22 Feb 2023, 10:13

Re: C5 II 2.0 16v Break with ABS/ESP/depollution error

Post by OlegR »

I have allmost the same bunch of errors permanently.
I bought the car with the Steering Wheel Angle error, the mechanic, checked, and fixed.... all the wires that are related to ABS. Nothing changed.
The other errors (headlamps, suspension...)are caused by the main one Steering Angle error.
With Lexia it shows me that it's calibrated, but when I'm reading the parameters of the steering wheel sensor, it shows weird numbers. And they are different after I do a new calibration.
Like millions of degrees on the right even if the steering wheel is like 5'.

But mine had a bunch of errors due to the fact that the old owner, once a month connected the battery, let the car run for a few mins, disconnected the battery, and did this for years. The car drove only 200km in 6 years.
I still hope that a proper calibration or few, will fix this.