C4 Picasso HDI automatic starts when pressing brake in accesories key position

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Cheriff
Posts: 6
Joined: 17 Jun 2022, 13:10
x 1

C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by Cheriff »

Hi.

I have a problem with my 2007 C4 Picasso 2.0 HDI automatic. When I put the key into ignition and move to accesories position, the car asks to press brake as if I was turning the key to start position. When in this situation I press brake, the car starts but the gearbox does not change gears.

The problem matches with the fact that the fusebox/BSI was left without the plastic cover and it was a little bit wet due to a washing. I opened and dry all elements, but the problem persists. Also, I checked with diagbox and there were some errors, some of them due to battery removal, another about brake pedal correlation, but none of them were persistent when I cleared them. Now I have no errors.

Anyway, the thing that is extrange for me is that, whn I remove the 3 pin ignition key connector, I have 12v on 2 of them. By how the ignition switch works, there should only be 12v on one of that pins and the other two should return 12v when in accesories and ignition.

The problem is that I have no wiring diagrams to see where to look for the problem.

Do you have any information to guide me?

Thanks.

Regards.
wheeler
Posts: 5796
Joined: 21 Sep 2002, 19:07
x 428

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by wheeler »

Cheriff wrote:
17 Jun 2022, 14:44


Anyway, the thing that is extrange for me is that, whn I remove the 3 pin ignition key connector, I have 12v on 2 of them. By how the ignition switch works, there should only be 12v on one of that pins and the other two should return 12v when in accesories and ignition.

You are correct, there should only be 1 12v feed at the ignition switch, the other wire is the ignition output and the other one is the starter signal wire.
This is going to be almost certainly (as you have already kind of worked out) caused by the under bonnet fusebox (BSM), if it has had water in is it may now be damaged even though you dried it out.
If I can have your VIN i should be able to get you the correct wiring diagram to check this further.
Cheriff
Posts: 6
Joined: 17 Jun 2022, 13:10
x 1

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by Cheriff »

wheeler wrote:
17 Jun 2022, 15:40
Cheriff wrote:
17 Jun 2022, 14:44


Anyway, the thing that is extrange for me is that, whn I remove the 3 pin ignition key connector, I have 12v on 2 of them. By how the ignition switch works, there should only be 12v on one of that pins and the other two should return 12v when in accesories and ignition.

You are correct, there should only be 1 12v feed at the ignition switch, the other wire is the ignition output and the other one is the starter signal wire.
This is going to be almost certainly (as you have already kind of worked out) caused by the under bonnet fusebox (BSM), if it has had water in is it may now be damaged even though you dried it out.
If I can have your VIN i should be able to get you the correct wiring diagram to check this further.
Thanks for your quick reply. VIN number is VF7**************[VIN obfuscated, can be read by forum staff]

Regards.
wheeler
Posts: 5796
Joined: 21 Sep 2002, 19:07
x 428

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by wheeler »

I've zoomed in on the relevant bits for clarity.
Pin 2 of the ignition switch should be live all the time.
Pin 1 is the signal to switch on the ignition
Pin 3 is the starter signal, This goes to pin 9 of the 28 way grey connector on the under bonnet fusebox then the output to the starter motor is from pin 2 of the 5 way yellow connector (its actually grey but its yellow underneath)
If the other live your getting at the ignition switch is on pin 3 i would say the fusebox is faulty.
Attachments
c4pic.jpg
Cheriff
Posts: 6
Joined: 17 Jun 2022, 13:10
x 1

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by Cheriff »

wheeler wrote:
17 Jun 2022, 16:04
I've zoomed in on the relevant bits for clarity.
Pin 2 of the ignition switch should be live all the time.
Pin 1 is the signal to switch on the ignition
Pin 3 is the starter signal, This goes to pin 9 of the 28 way grey connector on the under bonnet fusebox then the output to the starter motor is from pin 2 of the 5 way yellow connector (its actually grey but its yellow underneath)
If the other live your getting at the ignition switch is on pin 3 i would say the fusebox is faulty.
Image
Thanks!

It seems the problem is BSM (fusebox) as you said. I've seen a working second hand one (same reference number) in eBay, so I could replace it. As I understand it is a direct replacement without coding needed, right?

Regards.
RichardW
Forum Treasurer
Posts: 9914
Joined: 07 Aug 2002, 17:12
x 562

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by RichardW »

Correct, underbonnet fusebox is a direct fit - just make sure it has the same number marked on it, there are loads of variations!
Cheriff
Posts: 6
Joined: 17 Jun 2022, 13:10
x 1

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by Cheriff »

Okay.

Lots of thanks for your help, Wheeler and Richard!!
Cheriff
Posts: 6
Joined: 17 Jun 2022, 13:10
x 1

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by Cheriff »

wheeler wrote:
17 Jun 2022, 16:04
I've zoomed in on the relevant bits for clarity.
Pin 2 of the ignition switch should be live all the time.
Pin 1 is the signal to switch on the ignition
Pin 3 is the starter signal, This goes to pin 9 of the 28 way grey connector on the under bonnet fusebox then the output to the starter motor is from pin 2 of the 5 way yellow connector (its actually grey but its yellow underneath)
If the other live your getting at the ignition switch is on pin 3 i would say the fusebox is faulty.
Image
Wheeler, by the way. Where do you get that schematics? Are they from Diagbox?

The problem was solved, but now I have the problem that windshield water pumps does not work. I have to see in schematics what connector they use, because I have one connector free on fusebox and I'm not sure if it should be connected (I don't find the cable).

Thanks!
wheeler
Posts: 5796
Joined: 21 Sep 2002, 19:07
x 428

Re: C4 Picasso HDI automatic starts when pressing brake in accesories key position

Post by wheeler »

The diagrams are from SEDRE, The same program as the dealers use.
Did a new fusebox solve it?
Have you checked all the fuses are good?