Xantia - no brakes, suspension or steering

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

Jaf
Posts: 477
Joined: 09 Dec 2010, 20:17
x 19

Xantia - no brakes, suspension or steering

Post by Jaf »

Hello. Went to check the levels on Fred and I have no brakes, suspension or steering. She was fine when I parked a couple of days ago. Auxiliary belt is good.

Suspect the pump but before I take it off is there anything else I should check for?

Thanks! It's a bit hot here and I'm boiling!
User avatar
xantia_v6
Forum Admin Team
Posts: 8102
Joined: 09 Nov 2005, 23:03
x 543

Re: Xantia - no brakes, suspension or steering

Post by xantia_v6 »

If there is LHM in the tank and no power steering with the engine running, then you probably have an air-lock in the pipe from the reservoir to the pump. Probably also a loose connection on that hose.

You may need to disconnect the.hose at the reservoir and fill it with LHM to prime the pump.
Jaf
Posts: 477
Joined: 09 Dec 2010, 20:17
x 19

Re: Xantia - no brakes, suspension or steering

Post by Jaf »

Thanks. I'll check the pipes later when it's cooler.
Jaf
Posts: 477
Joined: 09 Dec 2010, 20:17
x 19

Re: Xantia - no brakes, suspension or steering

Post by Jaf »

Aha! Squishy bit of pipe where it's tied to the pump. Hopefully that's it, will repair tomorrow.
20220613_203441.jpg
Jaf
Posts: 477
Joined: 09 Dec 2010, 20:17
x 19

Re: Xantia - no brakes, suspension or steering

Post by Jaf »

You were right! I've had to use a join to the original pipe as the new pipe fits on the pump but not the reservoir as the pipe is too small. Obviously can't find a citroen pipe so this repair will have to do. You were right about priming the pump too.

Thank you.