2005 Citroen Dispatch 1.9 D Enterprise Loss of power and white smoke. Help?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

RyanCharles
Posts: 6
Joined: 18 Mar 2021, 22:37

2005 Citroen Dispatch 1.9 D Enterprise Loss of power and white smoke. Help?

Post by RyanCharles »

I've had my 2005 Citroen Dispatch 1.9 D Enterprise for 2 years now and have converted it into a campervan. Absolutely love the van apart from this one issue we've had since we bought it.

The problem is that sometimes the van will lose power (I'd say about 75% of the power) and start producing grey smoke out of the exhaust if still accelerating.
To solve this problem I've had to resort to turning the ignition on and off and that usually fixes it. Sometimes for the rest of my journey or sometimes just for 200 meters down the road.

I recently took it into a garage to get it checked out and they said the computer said it had no problems (probably because this fault is intermittent and wasn't happening while checked).
They also took it out a test drive and low and behold it didn't happen on that drive! They did however fit a new fuel filter.

I paid my £60 for their service and drove home with no problems. However the next day on my way to work I had to stop at least 6 times on a 30 minute commute to turn the engine off and on. And since then it has been happening just as much as it was before.

I have seen other people with this problem in forums but they have never posted what their fix was, If there is one... :(

I love my van and would very much appreciate any help I can get.

Thanks in advance, Ryan.
wheeler
Posts: 5701
Joined: 21 Sep 2002, 19:07
x 402

Re: 2005 Citroen Dispatch 1.9 D Enterprise Loss of power and white smoke. Help?

Post by wheeler »

Does the engine sound change when this happens? does it sound like its knocking or rattling?
Is the engine using any oil?
RyanCharles
Posts: 6
Joined: 18 Mar 2021, 22:37

Re: 2005 Citroen Dispatch 1.9 D Enterprise Loss of power and white smoke. Help?

Post by RyanCharles »

Hi Wheeler,

The engine sound doesn't change and there is no knocking or rattling. Levels also stay the same when it happens.

The only thing I can see online is people saying it might be dumping fuel if that is the kind of smoke it is producing. Not found a fix for it yet though :(
Stewart(oily)
Posts: 881
Joined: 07 Oct 2005, 16:31
x 25

Re: 2005 Citroen Dispatch 1.9 D Enterprise Loss of power and white smoke. Help?

Post by Stewart(oily) »

On the front of your engine there is a large bore inlet pipe, on the right side of it is a thin metal cover, it covers an actuator that is intended to operate a butterfly valve in the inlet, just a simple push/pull device, if this gets disconnected from the little lug it is supposed to push/pull on it still moves the butterfly, but not properly, and can give a different result every time the engine is started, just remove the little cover and check it is properly connected.
It took a while to find this problem.