VIDEO: Strange clicking noise when ignition is turned on

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Ohfishalee
Donor 2022
Posts: 38
Joined: 02 Feb 2022, 21:44
x 4

VIDEO: Strange clicking noise when ignition is turned on

Post by Ohfishalee »

So my starting woes continue. I thought it was the inline fuel pump (it obviously didnt come factory installed).

I have a clicking sound emanating from under the engine cover.

Here is a YouTube video of it.




Thoughts?

Here is an update.

In the video Peugeot Partner problem. Part 2

https://youtube.com/shorts/Trd4w_Do3BM?feature=share

I set the camera, turn the ignition on. I then turn the key off.

Listen to the two distinct sounds......

1. Clicking sound from the area of the actual fuel injection pump under the engine cover.

2. The inline fuel pump "humming".

What could it be?

Is there a stop solenoid near the injection pump?
wheeler
Posts: 5807
Joined: 21 Sep 2002, 19:07
x 429

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by wheeler »

The buzzing from the injection pump is the advance electrovalve. This buzzing from it is completely normal on DW8 engines when the ignition is switched on. They all do it although that one sounds quite loud, dont know if its just your camera microphone though making it sound worse?
Ohfishalee
Donor 2022
Posts: 38
Joined: 02 Feb 2022, 21:44
x 4

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by Ohfishalee »

wheeler wrote:
07 Apr 2022, 09:46
The buzzing from the injection pump is the advance electrovalve. This buzzing from it is completely normal on DW8 engines when the ignition is switched on. They all do it although that one sounds quite loud, dont know if its just your camera microphone though making it sound worse?
Thanks. It is a DW8B if that makes a difference. Bear in mind that I have an inline fuel pump (non-peugeot) installed that "buzzes" or "hums" that is a separate sound than the distinct clicking.

The inline pump is seen on the left edge of the image below.
20220316_094327.jpg
Does the electrovalve continue the clicking noise after the key is turned off?
User avatar
Huskyxantia
Donor 2021
Posts: 762
Joined: 30 Jul 2018, 22:11
x 98

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by Huskyxantia »

I might be wrong but is this earthed correctly ?
wheeler
Posts: 5807
Joined: 21 Sep 2002, 19:07
x 429

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by wheeler »

Im aware of your additional pump but the noise i can hear that comes from the injection pump is normal. Its the advance electrovalve thats fitted into the pump, it should stop when you switch the ignition off. The DW8B variant will do it as this has an ECU.
Ohfishalee
Donor 2022
Posts: 38
Joined: 02 Feb 2022, 21:44
x 4

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by Ohfishalee »

wheeler wrote:
07 Apr 2022, 12:33
Im aware of your additional pump but the noise i can hear that comes from the injection pump is normal. Its the advance electrovalve thats fitted into the pump, it should stop when you switch the ignition off. The DW8B variant will do it as this has an ECU.
Thanks, it does it for about 6-8 seconds after the ignition is turned off sometimes as well. Glad to know that the sound is 'normal'.
Ohfishalee
Donor 2022
Posts: 38
Joined: 02 Feb 2022, 21:44
x 4

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by Ohfishalee »

Huskyxantia wrote:
07 Apr 2022, 11:43
I might be wrong but is this earthed correctly ?

Is [what] earthed correctly?

I am hoping that this is an ignition issue....let me re-phrase....I hope it is a simple issue to rectify.
Ohfishalee
Donor 2022
Posts: 38
Joined: 02 Feb 2022, 21:44
x 4

THANK YOU FOR ALL THE ASSISTANCE THUS FAR

Post by Ohfishalee »

As the title states:

THANK YOU ALL FOR THE ASISTANCE THUS FAR!!!
User avatar
Huskyxantia
Donor 2021
Posts: 762
Joined: 30 Jul 2018, 22:11
x 98

Re: VIDEO: Strange clicking noise when ignition is turned on

Post by Huskyxantia »

Ohfishalee wrote:
07 Apr 2022, 15:19
Huskyxantia wrote:
07 Apr 2022, 11:43
I might be wrong but is this earthed correctly ?

Is [what] earthed correctly?

I am hoping that this is an ignition issue....let me re-phrase....I hope it is a simple issue to rectify.
The fuel pump ? As i said i could be wrong But from what ive read it does seem normal whats its doing... but... , i just thought of a fuel solenoid not going to ground as if there was some sort of short circuit causing the solenoid to open and close all the time hence the ticking, but as i say i maybe wrong