Relay Rusty Coolant?

This is the Forum for all your Citroen Technical Questions, Problems or Advice.

Moderator: RichardW

BenEC
Posts: 3
Joined: 11 Jan 2022, 22:19
x 1

Relay Rusty Coolant?

Post by BenEC »

Hi All, recently acquired myself a 2017 Relay 35 2.0 BlueHDi 130 Enterpirse. Love the van! Only concern is the rusty brown coloured Coolant (see attached pic). My mind instantly goes to the worst option, blown headgasket! Though I realise that's a little alarmist. Anybody seen this before in these vans? Does it just need a good flush?

Thanks all! Ben
Attachments
20220108_125401.jpg
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26624
Joined: 15 Sep 2015, 19:38
x 3113

Re: Relay Rusty Coolant?

Post by GiveMeABreak »

The colour alone isn't a good guide as some of the long life OAT coolant can look an orangey brown colour. What's important is to test it. Also, from the pictures it looks like a chocolate milkshake - now that may be the tank, but check there's no 'mayonnaise' or other stuff in there.
User avatar
white exec
Moderating Team
Posts: 7439
Joined: 21 Dec 2015, 13:46
x 1463

Re: Relay Rusty Coolant?

Post by white exec »

That does look fairly yukky in there.
As Marc says, check for the presence of oil in the coolant.
Could be a case of neglected coolant changes, or an unfortunate result of mixing coolant types.

Again, I can recommend the use of LiquiMoly Radiator Cleaner (#2506), to remove rust, calc, oil/grease etc.
One 300ml can is sufficient for a clean-out. Just follow the instructions on the can.
BenEC
Posts: 3
Joined: 11 Jan 2022, 22:19
x 1

Re: Relay Rusty Coolant?

Post by BenEC »

Thank you for the advice both. It's still with the dealer that I have purchased from at the moment, I haven't officially taken delivery of it (or fully paid for it) yet. I've asked them to test the coolant and report to me. Of course I will do an independent visual too and insist that they flush it. It has just been serviced apparently.
BenEC
Posts: 3
Joined: 11 Jan 2022, 22:19
x 1

Re: Relay Rusty Coolant?

Post by BenEC »

Inspected the van again today, oil in sump and on cams seems clean and clear, coolant in reservoir actually looks quite clear, just the resovoir is a very orange/stained colour. Will flush it out and may do a combustion test.
Attachments
20220114_133748.jpg
20220114_133939.jpg
20220114_135049.jpg
20220114_133743.jpg