407 2007 Hdi V6 tourer - new toy

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

407
Donor 2021
Posts: 39
Joined: 20 Apr 2021, 08:55
x 3

407 2007 Hdi V6 tourer - new toy

Post by 407 »

As a sucker for punishment, I could not pass up a bargain 407 Tourer HdI v6 with only 142,000 kms

Seems to run okay, clean outside and inside and with 12 months of rego and new tyres included.

No codes showing so here's hoping

Can I get a characteristics spec sheet please

Vin is VF3**************[VIN obfuscated, can be read by forum staff]
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: 407 2007 Hdi V6 tourer - new toy

Post by RichardW »

You have mail...!
407
Donor 2021
Posts: 39
Joined: 20 Apr 2021, 08:55
x 3

Re: 407 2007 Hdi V6 tourer - new toy - Diag results

Post by 407 »

Having run Diag on the toy, can I ask what these "error" messages" mean

Important, ECU present on the vehicle but configured absent

Does it mean the specific ECU is physically present but not correctly enabled ?

I also get the rain sensor saying downgrade mode : this information is not guaranteed - any hints ?

Finally, I assume "diesel additive not present means no ad blue or EOLYS but the Engine ECU throws up a P1434 additive system error code ?

Engine is a EURO 4 DT14TED4 turbo with particle emission filter (based on vehicle characteristics - thanks Richard)

cheers
Attachments
Hdi missing ECU message.JPG
Hdi missing ECU message #4 P1434 additive.JPG
Hdi missing ECU message #3 diesel additive.JPG
Hdi missing ECU message #2.JPG
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26024
Joined: 15 Sep 2015, 19:38
x 2980

Re: 407 2007 Hdi V6 tourer - new toy

Post by GiveMeABreak »

Be very cautious about changing anything here, some systems are designed to be configured a certain way with default values. Take a screenshot of anything before you make changes, and have a read here as some things may not mean what you think they do.

viewtopic.php?t=60600

The Diesel Additive greyed out on this model is likely indicating that the additive function has now been incorporated into the engine ECU, so they may have done away with the separate additive ECU that could of been fitted on earlier models. Ignore it.

I have limited info on this engine ECU, but it may relate to an open circuit on the additive system - specifically the pump, so might be something to check around there.

Are you using PP 2000 or native Diagbox? If you have PP2000 as an option try that first.
407
Donor 2021
Posts: 39
Joined: 20 Apr 2021, 08:55
x 3

Re: 407 2007 Hdi V6 tourer - new toy

Post by 407 »

Thank Marc

using Diag clone 9.91 - I'll leave them be for now :)

I'll have a look under the car re additive (says left rear wheel well) when it stops raining here.

I did see a suspension ECU on top of the main ECU as its also throwing up a U1113 code (absence of communication with the ESP) but I'm hoping that is related to the front right hand side drivers side speed / ABS sensor which is also throwing up a C1330 code

of interest, came across this site https://www.ilcats.ru/?language=en in my searches for data
User avatar
GiveMeABreak
Forum Admin Team
Posts: 26024
Joined: 15 Sep 2015, 19:38
x 2980

Re: 407 2007 Hdi V6 tourer - new toy

Post by GiveMeABreak »

That may be a ghost fault - which can occur when the diagnostic tool interrogates the ECU when the car is not moving. But double check after you have eliminated the ABS Sensor issue.

As for that link - the data is years old and out of date. Many part numbers have been replaced and is is not official data - they don't even half any of the latest vehicles! I've warned about this site before, PSA do not licence their data for public release and the data they are showing on that link is from old off-line databases by the looks of it about 7 years ago...