308 SW 1.6 hdi help needed please

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

Timdoran
Posts: 3
Joined: 19 Nov 2021, 23:03

308 SW 1.6 hdi help needed please

Post by Timdoran »

I really hope that someone can help with my problem, so many thanks in advance.

I have a 2010 308 SW 1.6 hdi 110. Recently it has developed a hot start problem. It starts from cold and runs fine but wont start if its hot. On advice from a mechanic, if I pour water over the fuel pump it starts. Otherwise I have to wait 30 minutes for it to cool.

I have put a basic error code checker, and there were none.

Does this suggest that the high pressure fuel pump is on its way out, or could it be the fuel pressure sensor screwed into the fuel pump?

Any suggestions for what to do next would be greatly appreciated. I have had a search but not got an exact match back. Happy to be pointed in the direction of another good thread.

Cheers
Tim
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: 308 SW 1.6 hdi help needed please

Post by RichardW »

Are you sure it's the fuel pump? It's buried right down the back of the engine and is all but invisible... You would need to get it on a decent diagnostic computer to have a look at the live data when cranking to see what is wrong.
Timdoran
Posts: 3
Joined: 19 Nov 2021, 23:03

Re: 308 SW 1.6 hdi help needed please

Post by Timdoran »

Hi Richard, maybe we are thinking of different things. I thought the high pressure fuel pump is on the top of the engine to the right hand side?
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: 308 SW 1.6 hdi help needed please

Post by RichardW »

No, I suspect that is the fuel filter, can you post a picture? If it's not been changed, then I would get a new filter put in it as a start. These are sensitive to excess pressure drop through a dirty filter.
Timdoran
Posts: 3
Joined: 19 Nov 2021, 23:03

Re: 308 SW 1.6 hdi help needed please

Post by Timdoran »

This is not my engine, but the red circle shows where the fuel pump is. It's mostly hidden by the plastic air duct things. The filter is behind that.
It has had a fuel filter change with no change to the symptoms.
Image
free fonts copy and paste
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: 308 SW 1.6 hdi help needed please

Post by RichardW »

Ah, that's the vacuum pump...no idea why cooling that would affect starting! The engine earth is under there somewhere on top of the gearbox... maybe, just maybe, it is a bit iffy and the water runs down onto it and makes enough of a connection to get the starter speed up. Does it sound different cranking when you've cooled it?
alexvalcic
Posts: 7
Joined: 23 Apr 2021, 19:55
x 2

Re: 308 SW 1.6 hdi help needed please

Post by alexvalcic »

What you poured with water is a vacuum pump. On that occasion, you are actually cooling the starter on the gearbox. Check the speed at cold start and at warm start with the help of diagnostics.
User avatar
Huskyxantia
Donor 2021
Posts: 472
Joined: 30 Jul 2018, 22:11
x 72

Re: 308 SW 1.6 hdi help needed please

Post by Huskyxantia »

Egr valve ?