crazy dashboard full of faults ps abs engine comms HELP !!

This is the Forum for all your Peugeot Technical Questions, Problems or Advice.

Moderator: RichardW

JeffTT
Posts: 2
Joined: 26 Oct 2021, 21:48

crazy dashboard full of faults ps abs engine comms HELP !!

Post by JeffTT »

Hi all, thanks for the ad, I am hoping you guys can help, with only a basic code reader and voltage test meter available to me at the moment its driving me mad !!

So my 2005 407 sw was running just fine and then the master cylinder on the clutch let go and pedal went to the floor.

So ordered a new unit and fitted it ( pain in ass !) bled it and all fine, two days later and around 200 miles use the electric power steering started intermittently going off, with the red power steering warning and STOP on the cluster. but switching off and leaving to cool all came back on with no issues.

But the last week its got worse when cold all ok but after 10 to 15 miles the same thing and no power steering alomg with the same cluster warning comes, it cut on and off for maybe 10mins and then eventually defaults to off / with no ps.

I noticed the engine light was on I scanned the car and found a code U0121 communiction issue but with the abs unit ? I do know the canbus communication passes through the abs unit though to the ps pump.

I checked all over the engine for any displaced connectors and the fuses in the fusebox all removed cleaned and replaced.

Today it went crazy, my normal 10 to 15 miles of no issues followed by intermittent power steering that eventually went off completely so back to no power steering again ! but this time as I drove home the rev counter dropped off, so did the engine water tem gauge


Engine light came on
Rev counter went to zero
Water temp dropped to lowest figure

Cluster

Warning power steering and STOP ( Red )
Warning triangle for esp fault ( Yellow )
Warning triangle with exclamation mark ( Yellow ) ( Engine management fault )
Engine light on ( Yellow )

Note: ABS light not on



So pulled over and switched off, waited a few minutes and restarted and all back to normal but within 2 miles all back on, and steering off !

Pulled over again and switched off and did a code check


U0122

U0121

P0500

P0490

P0490

P0409



Cleared codes and went to start engine but nothing, no starter ? but dash lights were on.

On a hunch I disconnected the battery waited for 2 minutes and reconnected, engine started fine and drove home with the lack of power steering feeling like a small part of the problem now.

The headlights acted a bit strange by not coming on in auto ( was dark ) so sat there for a minute and was about to switch them on manually and they just came on as normal, maybe just the battery disconnect they had to reconfigure.

Got home and pulled up, switched the key off, all dashboard lights went off and pulled it out of the ignition switch but the engine carried on for maybe 15 seconds then stopped.

Tried a restart and it worked correctly and switched off correctly too ?? given up for tonight but just cannot get my head around the original steering fault developed into a near full car melt down, non of these problems were there before changing the clutch master cylinder !!

Is it possible I have caused this, I did have the fuse board out to check the resistance of the glow pulgs at the same time as I have been getting a code for one of them occassionally.

The other thing I missed above, the engine runs fine, no issues.

Help guys

Jeff
RichardW
Forum Treasurer
Posts: 9647
Joined: 07 Aug 2002, 17:12
x 490

Re: crazy dashboard full of faults ps abs engine comms HELP !!

Post by RichardW »

Seems likely the fault is with the fusebox, or associated wiring. Check that all the cables are properly seated, and that the power supply is tight. There are myriad different ones, best is to go off the number stencilled on it, you can usually find one on e-bay.
JeffTT
Posts: 2
Joined: 26 Oct 2021, 21:48

Re: crazy dashboard full of faults ps abs engine comms HELP !!

Post by JeffTT »

Yes I removed the BSI unit and checked the connections, from fuses to relays and out puts where I could and all seemed correct, but cleaned all of the plugs connectors to it and the ABS unit and the power steering pump.

Did a BSM reset I found on here and started fine and no engine light, no codes,no communications issues but after ticking over for 5 mins the power steering faults came up again, but leaving it sitting there it came back on and them after a minute back off again,I watched the dash cluster and there seemed to be a pattern.
So it runs ok with no steering issues and then the dynamic control fault comes up followed by the steering fault and then the power steering fails.
wait a few minutes leaving it ticking over and the warnings go away and all working again until the dynamic control fault comes up and again followed by the power steering fail ?? is there any circuit diagrams for the connection between the abs and power steering pump / control?
ozvtr
Posts: 113
Joined: 13 Oct 2020, 01:11
x 26

Re: crazy dashboard full of faults ps abs engine comms HELP !!

Post by ozvtr »

Check the basics first.
Check the alternator voltage at the battery terminals (not the clamps) and at the the alternator B+ terminal.
Have the battery LOAD TESTED by using a proper load tester. DO NOT just put a volt meter on the battery and say "looks good to me"!
Check the battery negative lead. Should have good, clean, sold connection to battery, chassis and gearbox.
Check positive battery connection at battery and BSM (engine fusebox). Not loose, not corroded.
Most of your problems could be attributable to low supply power.